aboutsummaryrefslogtreecommitdiff
path: root/irc/miau
diff options
context:
space:
mode:
authorOliver Eikemeier <eik@FreeBSD.org>2004-05-02 21:02:30 +0000
committerOliver Eikemeier <eik@FreeBSD.org>2004-05-02 21:02:30 +0000
commit7c59caf5e995cff0cd27a891377bb6ab09c9f1aa (patch)
tree39e022f9f5a3d506bc765dc3bcb2b18cec539382 /irc/miau
parent4931ba8bee0f6be3855b5446443afd3ee4650212 (diff)
downloadports-7c59caf5e995cff0cd27a891377bb6ab09c9f1aa.tar.gz
ports-7c59caf5e995cff0cd27a891377bb6ab09c9f1aa.zip
work around problems with ChatZilla
enable dump command
Notes
Notes: svn path=/head/; revision=108207
Diffstat (limited to 'irc/miau')
-rw-r--r--irc/miau/Makefile2
-rw-r--r--irc/miau/files/patch-src::server.c13
2 files changed, 15 insertions, 0 deletions
diff --git a/irc/miau/Makefile b/irc/miau/Makefile
index cf0e03ae5315..d481d7053eaf 100644
--- a/irc/miau/Makefile
+++ b/irc/miau/Makefile
@@ -7,6 +7,7 @@
PORTNAME= miau
PORTVERSION= 0.5.2
+PORTREVISION= 1
CATEGORIES= irc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= miau
@@ -31,6 +32,7 @@ CONFIGURE_ARGS= --enable-dccbounce \
--enable-privlog \
--enable-onconnect \
--enable-empty-awaymsg \
+ --enable-dumpstatus \
--disable-dependency-tracking
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
diff --git a/irc/miau/files/patch-src::server.c b/irc/miau/files/patch-src::server.c
new file mode 100644
index 000000000000..9b64799dd767
--- /dev/null
+++ b/irc/miau/files/patch-src::server.c
@@ -0,0 +1,13 @@
+--- src/server.c.orig Sun May 2 22:33:54 2004
++++ src/server.c Sun May 2 22:34:29 2004
+@@ -718,8 +718,8 @@
+ pos(status.idhostname, '@') + 1;
+ } else {
+ /* Should we do something about this ? */
+- status.idhostname = strdup("miau");
+- status.goodhostname = 0;
++ status.idhostname = strdup("miau@miau");
++ status.goodhostname = 5;
+ }
+
+ #ifdef UPTIME