aboutsummaryrefslogtreecommitdiff
path: root/irc/miau
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-07-18 07:39:19 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-07-18 07:39:19 +0000
commita13c1b8ed1645d76dca5721854bdf02a88d99555 (patch)
tree5c61bdb96b9d22417ef18a82a709b1b1b42c4259 /irc/miau
parentf714f145d0ab034f0cf0619706c0673ee1fea519 (diff)
downloadports-a13c1b8ed1645d76dca5721854bdf02a88d99555.tar.gz
ports-a13c1b8ed1645d76dca5721854bdf02a88d99555.zip
- Update to 0.5.4
PR: ports/82920 Submitted by: Laust S. Jespersen <freebsd-ports@ust.dk>
Notes
Notes: svn path=/head/; revision=139472
Diffstat (limited to 'irc/miau')
-rw-r--r--irc/miau/Makefile6
-rw-r--r--irc/miau/distinfo4
-rw-r--r--irc/miau/files/patch-src-dcc.h12
-rw-r--r--irc/miau/files/patch-src::server.c13
4 files changed, 18 insertions, 17 deletions
diff --git a/irc/miau/Makefile b/irc/miau/Makefile
index e4131a8e99e0..b16455cb24f7 100644
--- a/irc/miau/Makefile
+++ b/irc/miau/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= miau
-PORTVERSION= 0.5.3
+PORTVERSION= 0.5.4
CATEGORIES= irc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= miau
@@ -15,11 +15,13 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A fully featured easy to use IRC-bouncer
USE_BZIP2= yes
+USE_ICONV= yes
GNU_CONFIGURE= yes
USE_REINPLACE= yes
INFO= miau
+MAN1= miau.1
CONFIGURE_ARGS= --enable-dccbounce \
--enable-automode \
@@ -34,7 +36,7 @@ CONFIGURE_ARGS= --enable-dccbounce \
--enable-dumpstatus \
--disable-dependency-tracking
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="${LDFLAGS}" \
LIBS="${LIBS}"
diff --git a/irc/miau/distinfo b/irc/miau/distinfo
index bb852547d695..bdef450eb572 100644
--- a/irc/miau/distinfo
+++ b/irc/miau/distinfo
@@ -1,2 +1,2 @@
-MD5 (miau-0.5.3.tar.bz2) = bdc3b3430197fb63f8842c115e7c38b3
-SIZE (miau-0.5.3.tar.bz2) = 159745
+MD5 (miau-0.5.4.tar.bz2) = 4f4f74e3e271d51d184c21871b09600f
+SIZE (miau-0.5.4.tar.bz2) = 165876
diff --git a/irc/miau/files/patch-src-dcc.h b/irc/miau/files/patch-src-dcc.h
new file mode 100644
index 000000000000..85a05c86d62a
--- /dev/null
+++ b/irc/miau/files/patch-src-dcc.h
@@ -0,0 +1,12 @@
+--- src/dcc.h.orig Mon May 16 19:35:50 2005
++++ src/dcc.h Wed Jul 13 16:54:30 2005
+@@ -19,6 +19,9 @@
+
+ #include <config.h>
+ #include <string.h>
++#include <sys/types.h>
++#include <sys/select.h>
++
+
+ #ifdef DCCBOUNCE
+
diff --git a/irc/miau/files/patch-src::server.c b/irc/miau/files/patch-src::server.c
deleted file mode 100644
index 9b64799dd767..000000000000
--- a/irc/miau/files/patch-src::server.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/server.c.orig Sun May 2 22:33:54 2004
-+++ src/server.c Sun May 2 22:34:29 2004
-@@ -718,8 +718,8 @@
- pos(status.idhostname, '@') + 1;
- } else {
- /* Should we do something about this ? */
-- status.idhostname = strdup("miau");
-- status.goodhostname = 0;
-+ status.idhostname = strdup("miau@miau");
-+ status.goodhostname = 5;
- }
-
- #ifdef UPTIME