aboutsummaryrefslogtreecommitdiff
path: root/irc/p5-POE-Component-IRC-Object
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2002-07-05 13:12:16 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2002-07-05 13:12:16 +0000
commit2115bbe14a8a67ef9a570400f4f2036d1f7706a5 (patch)
treec0c56b4d1910d8bc84fc5c7a07fb4fd7db5f2bba /irc/p5-POE-Component-IRC-Object
parentc6e47e720e8064d4314a574f5cd9d1808cdb5f84 (diff)
downloadports-2115bbe14a8a67ef9a570400f4f2036d1f7706a5.tar.gz
ports-2115bbe14a8a67ef9a570400f4f2036d1f7706a5.zip
Add p5-POE-Component-IRC-Object 0.02,
a slightly simpler OO interface to POE::Component::IRC.
Notes
Notes: svn path=/head/; revision=62481
Diffstat (limited to 'irc/p5-POE-Component-IRC-Object')
-rw-r--r--irc/p5-POE-Component-IRC-Object/Makefile34
-rw-r--r--irc/p5-POE-Component-IRC-Object/distinfo1
-rw-r--r--irc/p5-POE-Component-IRC-Object/pkg-comment1
-rw-r--r--irc/p5-POE-Component-IRC-Object/pkg-descr7
-rw-r--r--irc/p5-POE-Component-IRC-Object/pkg-plist9
5 files changed, 52 insertions, 0 deletions
diff --git a/irc/p5-POE-Component-IRC-Object/Makefile b/irc/p5-POE-Component-IRC-Object/Makefile
new file mode 100644
index 000000000000..b889f92b8400
--- /dev/null
+++ b/irc/p5-POE-Component-IRC-Object/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: POE-Component-IRC-Object
+# Date created: 05 July 2002
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= POE-Component-IRC-Object
+PORTVERSION= 0.02
+CATEGORIES= irc perl5 devel
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= POE
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/POE.pm:${PORTSDIR}/devel/p5-POE \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/POE/Component/IRC.pm:${PORTSDIR}/irc/p5-POE-Component-IRC
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PLIST_SUB= EXAMPLESDIR="share/examples/${PORTNAME}"
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= POE::Component::IRC::Object.3
+
+post-install:
+.ifndef(NOPORTDOCS)
+ @${ECHO_MSG} "===> Installing examples for ${PKGNAME}"
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/example/* ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/irc/p5-POE-Component-IRC-Object/distinfo b/irc/p5-POE-Component-IRC-Object/distinfo
new file mode 100644
index 000000000000..bde11cf534fa
--- /dev/null
+++ b/irc/p5-POE-Component-IRC-Object/distinfo
@@ -0,0 +1 @@
+MD5 (POE-Component-IRC-Object-0.02.tar.gz) = aec274158f94ac9f326b5d16eb3c9def
diff --git a/irc/p5-POE-Component-IRC-Object/pkg-comment b/irc/p5-POE-Component-IRC-Object/pkg-comment
new file mode 100644
index 000000000000..073b5d9beda2
--- /dev/null
+++ b/irc/p5-POE-Component-IRC-Object/pkg-comment
@@ -0,0 +1 @@
+A slightly simpler OO interface to POE::Component::IRC
diff --git a/irc/p5-POE-Component-IRC-Object/pkg-descr b/irc/p5-POE-Component-IRC-Object/pkg-descr
new file mode 100644
index 000000000000..1a53d125ab77
--- /dev/null
+++ b/irc/p5-POE-Component-IRC-Object/pkg-descr
@@ -0,0 +1,7 @@
+An OO interface to POE::Component::IRC with facilities to dispatch the
+same method to multiple objects.
+
+WWW: http://search.cpan.org/search?dist=POE-Component-IRC-Object
+
+-- Sergey Skvortsov
+skv@FreeBSD.org
diff --git a/irc/p5-POE-Component-IRC-Object/pkg-plist b/irc/p5-POE-Component-IRC-Object/pkg-plist
new file mode 100644
index 000000000000..dbda88557268
--- /dev/null
+++ b/irc/p5-POE-Component-IRC-Object/pkg-plist
@@ -0,0 +1,9 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/POE/Component/IRC/Object/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/POE/Component/IRC/Object.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/POE/Component/IRC/Object
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/POE/Component/IRC 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/POE/Component 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/POE 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/POE 2>/dev/null || true
+%%PORTDOCS%%%%EXAMPLESDIR%%/elizabot.pl
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%