aboutsummaryrefslogtreecommitdiff
path: root/irc/p5-POE-Component-IRC-Plugin-Blowfish/Makefile
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-06 10:37:04 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-06 10:37:04 +0000
commit68d88a3079413fc2f0aecaab10968fbd42088b1a (patch)
tree208c0c6c5d228c7ab4e8d1580770e62ac95c6bb6 /irc/p5-POE-Component-IRC-Plugin-Blowfish/Makefile
parentcdc850571f52024100ca6f283a71a6df19f783e4 (diff)
downloadports-68d88a3079413fc2f0aecaab10968fbd42088b1a.tar.gz
ports-68d88a3079413fc2f0aecaab10968fbd42088b1a.zip
Notes
Diffstat (limited to 'irc/p5-POE-Component-IRC-Plugin-Blowfish/Makefile')
-rw-r--r--irc/p5-POE-Component-IRC-Plugin-Blowfish/Makefile18
1 files changed, 10 insertions, 8 deletions
diff --git a/irc/p5-POE-Component-IRC-Plugin-Blowfish/Makefile b/irc/p5-POE-Component-IRC-Plugin-Blowfish/Makefile
index 8d197c706985..2aa2831becdf 100644
--- a/irc/p5-POE-Component-IRC-Plugin-Blowfish/Makefile
+++ b/irc/p5-POE-Component-IRC-Plugin-Blowfish/Makefile
@@ -20,17 +20,19 @@ BUILD_DEPENDS= p5-POE>=0.37:${PORTSDIR}/devel/p5-POE \
RUN_DEPENDS:= ${BUILD_DEPENDS}
PLIST_SUB= EXAMPLESDIR="share/examples/${PORTNAME}"
-USES= perl5
+
+USES= perl5 shebangfix
USE_PERL5= configure
-MAN3= POE::Component::IRC::Plugin::Blowfish.3
+OPTIONS_DEFINE= EXAMPLES
+
+PORTEXAMPLES= synopsis.pl
+SHEBANG_FILES= examples/synopsis.pl
+
+.include <bsd.port.options.mk>
-NO_STAGE= yes
post-install:
-.ifndef(NOPORTEXAMPLES)
- @${ECHO_MSG} "===> Installing examples for ${PKGNAME}"
- @${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_SCRIPT} ${WRKSRC}/examples/* ${EXAMPLESDIR}
-.endif
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/examples/* ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>