aboutsummaryrefslogtreecommitdiff
path: root/irc/ratbox-respond
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2013-12-09 02:43:37 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2013-12-09 02:43:37 +0000
commit7d8c1f3a9b7fa45dd15aaad3454b809f15f58691 (patch)
treed5319700d81d19bc29543590cd40099e1ebfdf09 /irc/ratbox-respond
parent6507f2bc7a94b16786f9734e5c2a7c1a211316dd (diff)
downloadports-7d8c1f3a9b7fa45dd15aaad3454b809f15f58691.tar.gz
ports-7d8c1f3a9b7fa45dd15aaad3454b809f15f58691.zip
- NOPORTDOCS -> PORT_OPTIONS:MDOCS
- Staging - Use OPTIONS where appropriate - Rename old-style patch files
Notes
Notes: svn path=/head/; revision=335950
Diffstat (limited to 'irc/ratbox-respond')
-rw-r--r--irc/ratbox-respond/Makefile23
1 files changed, 8 insertions, 15 deletions
diff --git a/irc/ratbox-respond/Makefile b/irc/ratbox-respond/Makefile
index 03a77c25e0f5..7f59f3ef68bf 100644
--- a/irc/ratbox-respond/Makefile
+++ b/irc/ratbox-respond/Makefile
@@ -3,6 +3,7 @@
PORTNAME= ratbox-respond
PORTVERSION= 1.0
+PORTREVISION= 1
CATEGORIES= irc sysutils
MASTER_SITES= http://respond.ratbox.org/download/
EXTRACT_SUFX= .tgz
@@ -16,24 +17,16 @@ BUILD_WRKSRC= ${WRKSRC}/${PORTNAME}
USE_OPENSSL= yes
GNU_CONFIGURE= yes
-SUB_FILES= pkg-message
-
-PORTDOCS= *
+PORTDOCS= challenge.txt
PORTEXAMPLES= *
PLIST_FILES= bin/ratbox-respond bin/makekeypair
-NO_STAGE= yes
do-install:
- ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/${PORTNAME} ${PREFIX}/bin
- ${INSTALL_SCRIPT} ${WRKSRC}/makekeypair ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} challenge.txt ${DOCSDIR}
-.endif
-.if !defined(NOPORTEXAMPLES)
- @${MKDIR} ${EXAMPLESDIR}/client-scripts
- ${INSTALL_DATA} ${WRKSRC}/client-scripts/* ${EXAMPLESDIR}/client-scripts
-.endif
- @${CAT} ${PKGMESSAGE}
+ ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/makekeypair ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/challenge.txt ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/client-scripts/* ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>