aboutsummaryrefslogtreecommitdiff
path: root/irc/rbot
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2015-04-04 04:02:04 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2015-04-04 04:02:04 +0000
commit868c3fb8f1b47e2abac18440e9c34df199670d1e (patch)
treeeb9c2e27aa171ac559faf91a622f0e20f87fafb1 /irc/rbot
parent7928fd45d8f4a6d083add40e770b2bae6c3b1aa2 (diff)
downloadports-868c3fb8f1b47e2abac18440e9c34df199670d1e.tar.gz
ports-868c3fb8f1b47e2abac18440e9c34df199670d1e.zip
Update rbot to the new upstream from the 20150311 snapshot.
It now actually works with Ruby 2.0+. This requires manual migration to fix the registry files. See the UPDATING entry.
Notes
Notes: svn path=/head/; revision=383188
Diffstat (limited to 'irc/rbot')
-rw-r--r--irc/rbot/Makefile28
-rw-r--r--irc/rbot/distinfo4
-rw-r--r--irc/rbot/files/patch-lib__rbot__load-gettext.rb26
-rw-r--r--irc/rbot/pkg-plist38
4 files changed, 30 insertions, 66 deletions
diff --git a/irc/rbot/Makefile b/irc/rbot/Makefile
index 6cf34c352338..e28d500f05db 100644
--- a/irc/rbot/Makefile
+++ b/irc/rbot/Makefile
@@ -2,22 +2,29 @@
# $FreeBSD$
PORTNAME= rbot
-PORTVERSION= 0.9.15
-PORTREVISION= 2
+PORTVERSION= 20150311
+PORTREVISION= 0
+PORTEPOCH= 1
CATEGORIES= irc ruby
-MASTER_SITES= http://ruby-rbot.org/download/
-EXTRACT_SUFX= .tgz
MAINTAINER= bdrewery@FreeBSD.org
COMMENT= Ruby IRC bot similar to infobot
-RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/bdb.so:${PORTSDIR}/databases/ruby-bdb \
- rubygem-gettext>=1.93.0:${PORTSDIR}/devel/rubygem-gettext
+RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/tokyocabinet.so:${PORTSDIR}/databases/ruby-tokyocabinet \
+ rubygem-mechanize>=0:${PORTSDIR}/www/rubygem-mechanize \
+ rubygem-tzinfo>=0:${PORTSDIR}/devel/rubygem-tzinfo \
+ rubygem-oauth>=0:${PORTSDIR}/net/rubygem-oauth \
+ rubygem-oauth2>=0:${PORTSDIR}/net/rubygem-oauth2
+LIB_DEPENDS= libtokyocabinet.so:${PORTSDIR}/databases/tokyocabinet
USE_RUBY= yes
USE_RUBY_SETUP= yes
CONFIGURE_ARGS= --prefix=${PREFIX}
+USE_GITHUB= yes
+GH_ACCOUNT= ruby-${PORTNAME}
+GH_TAGNAME= 545f21791ad804a52f6b7470403a1fa5a3976f5f
+
PKGMESSAGE= ${WRKDIR}/pkg-message
SUB_FILES= pkg-message
@@ -25,15 +32,8 @@ PORTDOCS= REQUIREMENTS ChangeLog
OPTIONS_DEFINE= DOCS
-.include <bsd.port.options.mk>
-
-pre-install:
- ${RM} ${WRKSRC}/bin/svnwatch-postcommit-hook
-
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- ${INSTALL} -d ${STAGEDIR}${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
-.endif
.include <bsd.port.mk>
diff --git a/irc/rbot/distinfo b/irc/rbot/distinfo
index d1d3777627f3..3c7ef1f5f990 100644
--- a/irc/rbot/distinfo
+++ b/irc/rbot/distinfo
@@ -1,2 +1,2 @@
-SHA256 (rbot-0.9.15.tgz) = f5f41b6760ad22a7057cf81c661b93ad59152fcc94374ef2c8c0e96f821a7f0b
-SIZE (rbot-0.9.15.tgz) = 709338
+SHA256 (ruby-rbot-rbot-20150311-545f21791ad804a52f6b7470403a1fa5a3976f5f_GH0.tar.gz) = f0912663bd88316e13fb46a3afbe676eb70d65e1664cfbd52f627f6f07e71098
+SIZE (ruby-rbot-rbot-20150311-545f21791ad804a52f6b7470403a1fa5a3976f5f_GH0.tar.gz) = 752090
diff --git a/irc/rbot/files/patch-lib__rbot__load-gettext.rb b/irc/rbot/files/patch-lib__rbot__load-gettext.rb
deleted file mode 100644
index 69bb3e4d6eee..000000000000
--- a/irc/rbot/files/patch-lib__rbot__load-gettext.rb
+++ /dev/null
@@ -1,26 +0,0 @@
-commit 3342d4b9a510655d320590f7333f616355d0201d
-Author: Giuseppe Bilotta <giuseppe.bilotta@gmail.com>
-Date: Sat Jul 14 13:24:33 2012 +0200
-
- Update gettext support
-
- Somewhere along the line between 2.0.0 and 2.2.1 gettext switched from
- locale to lang for the hash key name. Support both.
-
-diff --git lib/rbot/load-gettext.rb lib/rbot/load-gettext.rb
-index ba9b09b..252e1e3 100644
---- lib/rbot/load-gettext.rb
-+++ lib/rbot/load-gettext.rb
-@@ -29,7 +29,11 @@ class ::Array
-
- include GetText
-
-- rbot_locale_path = File.join(Irc::Bot::Config.datadir, "../locale/%{locale}/LC_MESSAGES/%{name}.mo")
-+ rbot_locale_path = File.join(Irc::Bot::Config.datadir,
-+ gettext_version < [2, 2, 0] ?
-+ "../locale/%{locale}/LC_MESSAGES/%{name}.mo" :
-+ "../locale/%{lang}/LC_MESSAGES/%{name}.mo")
-+
- if gettext_version < [2, 0, 0]
- add_default_locale_path(rbot_locale_path)
- else
diff --git a/irc/rbot/pkg-plist b/irc/rbot/pkg-plist
index e33e9e116d4d..c9049f78186b 100644
--- a/irc/rbot/pkg-plist
+++ b/irc/rbot/pkg-plist
@@ -1,23 +1,22 @@
bin/rbot
-bin/rbot-remote
+bin/rbotdb
%%RUBY_SITELIBDIR%%/rbot/botuser.rb
-%%RUBY_SITELIBDIR%%/rbot/compat19.rb
-%%RUBY_SITELIBDIR%%/rbot/config-compat.rb
%%RUBY_SITELIBDIR%%/rbot/config.rb
%%RUBY_SITELIBDIR%%/rbot/core/auth.rb
%%RUBY_SITELIBDIR%%/rbot/core/basics.rb
%%RUBY_SITELIBDIR%%/rbot/core/config.rb
%%RUBY_SITELIBDIR%%/rbot/core/filters_ui.rb
%%RUBY_SITELIBDIR%%/rbot/core/irclog.rb
-%%RUBY_SITELIBDIR%%/rbot/core/remote.rb
%%RUBY_SITELIBDIR%%/rbot/core/unicode.rb
%%RUBY_SITELIBDIR%%/rbot/core/userdata.rb
+%%RUBY_SITELIBDIR%%/rbot/core/utils/agent.rb
%%RUBY_SITELIBDIR%%/rbot/core/utils/extends.rb
%%RUBY_SITELIBDIR%%/rbot/core/utils/filters.rb
%%RUBY_SITELIBDIR%%/rbot/core/utils/httputil.rb
%%RUBY_SITELIBDIR%%/rbot/core/utils/parse_time.rb
%%RUBY_SITELIBDIR%%/rbot/core/utils/utils.rb
%%RUBY_SITELIBDIR%%/rbot/core/utils/wordlist.rb
+%%RUBY_SITELIBDIR%%/rbot/core/webservice.rb
%%RUBY_SITELIBDIR%%/rbot/core/wordlist_ui.rb
%%RUBY_SITELIBDIR%%/rbot/irc.rb
%%RUBY_SITELIBDIR%%/rbot/ircbot.rb
@@ -30,17 +29,21 @@ bin/rbot-remote
%%RUBY_SITELIBDIR%%/rbot/pkgconfig.rb
%%RUBY_SITELIBDIR%%/rbot/plugins.rb
%%RUBY_SITELIBDIR%%/rbot/rbotconfig.rb
-%%RUBY_SITELIBDIR%%/rbot/registry/bdb.rb
+%%RUBY_SITELIBDIR%%/rbot/registry.rb
+%%RUBY_SITELIBDIR%%/rbot/registry/daybreak.rb
+%%RUBY_SITELIBDIR%%/rbot/registry/dbm.rb
+%%RUBY_SITELIBDIR%%/rbot/registry/sqlite.rb
%%RUBY_SITELIBDIR%%/rbot/registry/tc.rb
%%RUBY_SITELIBDIR%%/rbot/rfc2812.rb
%%RUBY_SITELIBDIR%%/rbot/timer.rb
+man/rbot.xml.gz
%%DATADIR%%/contrib/plugins/stats.rb
%%DATADIR%%/contrib/plugins/vandale.rb
%%DATADIR%%/filters/rss.rb
%%DATADIR%%/languages/dutch.lang
%%DATADIR%%/languages/english.lang
-%%DATADIR%%/languages/french.lang
%%DATADIR%%/languages/finnish.lang
+%%DATADIR%%/languages/french.lang
%%DATADIR%%/languages/german.lang
%%DATADIR%%/languages/italian.lang
%%DATADIR%%/languages/japanese.lang
@@ -56,22 +59,15 @@ bin/rbot-remote
%%DATADIR%%/plugins/chanserv.rb
%%DATADIR%%/plugins/chucknorris.rb
%%DATADIR%%/plugins/chucknorris.yml.gz
-%%DATADIR%%/plugins/debugger.rb
%%DATADIR%%/plugins/deepthoughts.rb
-%%DATADIR%%/plugins/delicious.rb
%%DATADIR%%/plugins/dice.rb
-%%DATADIR%%/plugins/dict.rb
-%%DATADIR%%/plugins/dictclient.rb
-%%DATADIR%%/plugins/digg.rb
%%DATADIR%%/plugins/eightball.rb
%%DATADIR%%/plugins/excuse.rb
%%DATADIR%%/plugins/factoids.rb
%%DATADIR%%/plugins/figlet.rb
-%%DATADIR%%/plugins/forecast.rb
%%DATADIR%%/plugins/fortune.rb
-%%DATADIR%%/plugins/freshmeat.rb
-%%DATADIR%%/plugins/geoip.rb
%%DATADIR%%/plugins/games/azgame.rb
+%%DATADIR%%/plugins/games/greed.rb
%%DATADIR%%/plugins/games/hangman.rb
%%DATADIR%%/plugins/games/quiz.rb
%%DATADIR%%/plugins/games/roshambo.rb
@@ -79,20 +75,17 @@ bin/rbot-remote
%%DATADIR%%/plugins/games/shiritori.rb
%%DATADIR%%/plugins/games/uno.rb
%%DATADIR%%/plugins/games/wheelfortune.rb
+%%DATADIR%%/plugins/geoip.rb
%%DATADIR%%/plugins/googlefight.rb
%%DATADIR%%/plugins/greet.rb
-%%DATADIR%%/plugins/grouphug.rb
%%DATADIR%%/plugins/hl2.rb
%%DATADIR%%/plugins/host.rb
%%DATADIR%%/plugins/httpd.rb.disabled
%%DATADIR%%/plugins/imdb.rb
%%DATADIR%%/plugins/insult.rb
-%%DATADIR%%/plugins/iplookup.rb
%%DATADIR%%/plugins/karma.rb
%%DATADIR%%/plugins/keywords.rb
%%DATADIR%%/plugins/lart.rb
-%%DATADIR%%/plugins/lastfm.rb
-%%DATADIR%%/plugins/lib_spotify.rb
%%DATADIR%%/plugins/linkbot.rb
%%DATADIR%%/plugins/markov.rb
%%DATADIR%%/plugins/math.rb
@@ -101,37 +94,34 @@ bin/rbot-remote
%%DATADIR%%/plugins/nickserv.rb
%%DATADIR%%/plugins/note.rb
%%DATADIR%%/plugins/nslookup.rb
+%%DATADIR%%/plugins/oxford.rb
%%DATADIR%%/plugins/plugin.header
+%%DATADIR%%/plugins/poll.rb
%%DATADIR%%/plugins/quakeauth.rb
%%DATADIR%%/plugins/quotes.rb
%%DATADIR%%/plugins/reaction.rb
%%DATADIR%%/plugins/remind.rb
-%%DATADIR%%/plugins/remotectl.rb
%%DATADIR%%/plugins/ri.rb
%%DATADIR%%/plugins/rot13.rb
%%DATADIR%%/plugins/rss.rb
%%DATADIR%%/plugins/salut.rb
%%DATADIR%%/plugins/script.rb
%%DATADIR%%/plugins/search.rb
+%%DATADIR%%/plugins/sed.rb
%%DATADIR%%/plugins/seen.rb
%%DATADIR%%/plugins/shortenurls.rb
%%DATADIR%%/plugins/slashdot.rb
%%DATADIR%%/plugins/spell.rb
-%%DATADIR%%/plugins/spotify.rb
%%DATADIR%%/plugins/theyfightcrime.rb
-%%DATADIR%%/plugins/threat.rb
%%DATADIR%%/plugins/time.rb
%%DATADIR%%/plugins/topic.rb
%%DATADIR%%/plugins/translator.rb
-%%DATADIR%%/plugins/tube.rb
%%DATADIR%%/plugins/tumblr.rb
%%DATADIR%%/plugins/twitter.rb
%%DATADIR%%/plugins/urban.rb
%%DATADIR%%/plugins/url.rb
%%DATADIR%%/plugins/usermodes.rb
-%%DATADIR%%/plugins/wall.rb
%%DATADIR%%/plugins/weather.rb
-%%DATADIR%%/plugins/wow.rb
%%DATADIR%%/plugins/wserver.rb
%%DATADIR%%/plugins/youtube.rb
%%DATADIR%%/templates/keywords.rbot