aboutsummaryrefslogtreecommitdiff
path: root/irc/simpleirc
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-12-25 19:44:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-12-25 19:44:05 +0000
commit02aedc85062ff5132c66a8b3d5ebf3465ac2fda9 (patch)
tree8486d8681957ed9f2400269767a00b38f2a575c3 /irc/simpleirc
parent13be155856ff5abd0a10441e5d980746c61d4bee (diff)
downloadports-02aedc85062ff5132c66a8b3d5ebf3465ac2fda9.tar.gz
ports-02aedc85062ff5132c66a8b3d5ebf3465ac2fda9.zip
SIMPLE IRC CLIENT alias sic
sic is an extremely simple IRC client. It consists of lesser than 250 lines of code. It is the little brother of irc/ii WWW: http://www.suckless.org/programs/sic.html PR: ports/129917 Submitted by: Dennis Herrmann <adox at mcx2.org>
Notes
Notes: svn path=/head/; revision=224760
Diffstat (limited to 'irc/simpleirc')
-rw-r--r--irc/simpleirc/Makefile29
-rw-r--r--irc/simpleirc/distinfo3
-rw-r--r--irc/simpleirc/files/patch-Makefile26
-rw-r--r--irc/simpleirc/files/patch-config.mk26
-rw-r--r--irc/simpleirc/pkg-descr6
5 files changed, 90 insertions, 0 deletions
diff --git a/irc/simpleirc/Makefile b/irc/simpleirc/Makefile
new file mode 100644
index 000000000000..301c5fe1d280
--- /dev/null
+++ b/irc/simpleirc/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: simpleirc
+# Date created: 24. Dez 2008
+# Whom: Dennis Herrmann <adox@mcx2.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= simpleirc
+PORTVERSION= 1.0
+CATEGORIES= irc
+MASTER_SITES= http://code.suckless.org/dl/tools/
+DISTNAME= sic-${PORTVERSION}
+
+MAINTAINER= adox@mcx2.org
+COMMENT= An extremly simple IRC client
+
+MAN1= simpleirc.1
+PLIST_FILES= bin/simpleirc
+PORTDOCS= README LICENSE
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${ECHO_MSG} "installing additional documentation to ${DOCSDIR}"
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_MAN} ${WRKSRC}/README ${DOCSDIR}
+ @${INSTALL_MAN} ${WRKSRC}/LICENSE ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/irc/simpleirc/distinfo b/irc/simpleirc/distinfo
new file mode 100644
index 000000000000..eec216c9cce5
--- /dev/null
+++ b/irc/simpleirc/distinfo
@@ -0,0 +1,3 @@
+MD5 (sic-1.0.tar.gz) = d73d07d5de3ea06e9e83b90d26749202
+SHA256 (sic-1.0.tar.gz) = 30a4ac3c80fe4562f0f082df3c0a6a9fa41aa21992a8e3cb2c8e41cf37328378
+SIZE (sic-1.0.tar.gz) = 4318
diff --git a/irc/simpleirc/files/patch-Makefile b/irc/simpleirc/files/patch-Makefile
new file mode 100644
index 000000000000..cb3438a9840a
--- /dev/null
+++ b/irc/simpleirc/files/patch-Makefile
@@ -0,0 +1,26 @@
+--- Makefile.orgi 2008-12-25 20:30:03.000000000 +0100
++++ Makefile 2008-12-25 20:31:47.000000000 +0100
+@@ -38,17 +38,18 @@
+ install: all
+ @echo installing executable file to ${DESTDIR}${PREFIX}/bin
+ @mkdir -p ${DESTDIR}${PREFIX}/bin
+- @cp -f sic ${DESTDIR}${PREFIX}/bin
+- @chmod 755 ${DESTDIR}${PREFIX}/bin/sic
++ @cp -f sic ${DESTDIR}${PREFIX}/bin/simpleirc
++ @chmod 755 ${DESTDIR}${PREFIX}/bin/simpleirc
+ @echo installing manual page to ${DESTDIR}${MANPREFIX}/man1
+ @mkdir -p ${DESTDIR}${MANPREFIX}/man1
+ @sed "s/VERSION/${VERSION}/g" < sic.1 > ${DESTDIR}${MANPREFIX}/man1/sic.1
+- @chmod 644 ${DESTDIR}${MANPREFIX}/man1/sic.1
++ @mv ${DESTDIR}${MANPREFIX}/man1/sic.1 ${DESTDIR}${MANPREFIX}/man1/simpleirc.1
++ @chmod 644 ${DESTDIR}${MANPREFIX}/man1/simpleirc.1
+
+ uninstall:
+ @echo removing executable file from ${DESTDIR}${PREFIX}/bin
+- @rm -f ${DESTDIR}${PREFIX}/bin/sic
++ @rm -f ${DESTDIR}${PREFIX}/bin/simpleirc
+ @echo removing manual page from ${DESTDIR}${MANPREFIX}/man1
+- @rm -f ${DESTDIR}${MANPREFIX}/man1/sic.1
++ @rm -f ${DESTDIR}${MANPREFIX}/man1/simpleirc.1
+
+ .PHONY: all options clean dist install uninstall
diff --git a/irc/simpleirc/files/patch-config.mk b/irc/simpleirc/files/patch-config.mk
new file mode 100644
index 000000000000..647966b53c2e
--- /dev/null
+++ b/irc/simpleirc/files/patch-config.mk
@@ -0,0 +1,26 @@
+--- config.mk.orig 2008-12-24 21:33:04.000000000 +0100
++++ config.mk 2008-12-24 21:34:33.000000000 +0100
+@@ -4,17 +4,17 @@
+ # Customize below to fit your system
+
+ # paths
+-PREFIX = /usr/local
+-MANPREFIX = ${PREFIX}/share/man
++PREFIX ?= /usr/local
++MANPREFIX = ${PREFIX}/man
+
+ # includes and libs
+ INCS = -I. -I/usr/include
+ LIBS = -L/usr/lib -lc
+
+ # flags
+-CPPFLAGS = -DVERSION=\"${VERSION}\" -D_GNU_SOURCE
+-CFLAGS = -std=c99 -pedantic -Wall -Os ${INCS} ${CPPFLAGS}
+-LDFLAGS = -s ${LIBS}
++CPPFLAGS += -DVERSION=\"${VERSION}\" -D_GNU_SOURCE
++CFLAGS += -std=c99 -pedantic -Wall -Os ${INCS} ${CPPFLAGS}
++LDFLAGS += -s ${LIBS}
+
+ # compiler and linker
+-CC = cc
++CC ?= cc
diff --git a/irc/simpleirc/pkg-descr b/irc/simpleirc/pkg-descr
new file mode 100644
index 000000000000..1c11f86cd27f
--- /dev/null
+++ b/irc/simpleirc/pkg-descr
@@ -0,0 +1,6 @@
+SIMPLE IRC CLIENT alias sic
+
+sic is an extremely simple IRC client. It consists of lesser
+than 250 lines of code. It is the little brother of irc/ii
+
+WWW: http://www.suckless.org/programs/sic.html