aboutsummaryrefslogtreecommitdiff
path: root/irc/unreal
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2021-01-01 23:51:48 +0000
committerMark Linimon <linimon@FreeBSD.org>2021-01-01 23:51:48 +0000
commit553b088a0505b32e910f454bc2a296fca47ac9dd (patch)
treeb95d03e698b9ef7fe36e585725c5dcfc5aee36d0 /irc/unreal
parent6b5efb1b8820c67344543e6cd051a864862f5a8f (diff)
downloadports-553b088a0505b32e910f454bc2a296fca47ac9dd.tar.gz
ports-553b088a0505b32e910f454bc2a296fca47ac9dd.zip
Mark ports that are BROKEN due to sbrk on aarch64, also BROKEN on riscv64
where appropriate. While here, pet portlint (Makevar order; whitespace). Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=559890
Diffstat (limited to 'irc/unreal')
-rw-r--r--irc/unreal/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/irc/unreal/Makefile b/irc/unreal/Makefile
index 2913308f1a31..f95cf798dcb8 100644
--- a/irc/unreal/Makefile
+++ b/irc/unreal/Makefile
@@ -13,15 +13,17 @@ COMMENT= Unreal - the next generation ircd
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
-LIB_DEPENDS= libcares.so:dns/c-ares
-
BROKEN_aarch64= Fails to link: missing sbrk
+BROKEN_riscv64= Fails to link: missing sbrk
+
+LIB_DEPENDS= libcares.so:dns/c-ares
MODULESDIR= ${PREFIX}/lib/${PORTNAME}
CONFIGDIR= ${PREFIX}/etc/${PORTNAME}
RUNDIR= /var/run/ircd
LOGDIR= /var/log/ircd
+USES= pkgconfig cpe
HAS_CONFIGURE= yes
USE_RC_SUBR= unrealircd
@@ -30,8 +32,6 @@ GROUPS= ircd
CPE_VENDOR= unrealircd
CPE_PRODUCT= unrealircd
-USES= pkgconfig cpe
-
SUB_LIST+= RUNDIR=${RUNDIR}
SUB_LIST+= USERS=${USERS}
SUB_LIST+= GROUPS=${GROUPS}