aboutsummaryrefslogtreecommitdiff
path: root/irc/unreal
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2014-05-27 23:58:42 +0000
committerMathieu Arnold <mat@FreeBSD.org>2014-05-27 23:58:42 +0000
commit9fec22bd7273aa658149e8d79c92c5b00dce78b9 (patch)
tree0c52dec2d95b3103a13e2f7f4f8e39eb93aff849 /irc/unreal
parentc1b4c17b3b00d974d50784a16ed87f7d50318b45 (diff)
downloadports-9fec22bd7273aa658149e8d79c92c5b00dce78b9.tar.gz
ports-9fec22bd7273aa658149e8d79c92c5b00dce78b9.zip
- Fix runtime when built with clang [1] [2]
- Support stage [3] - Switch to options helpers - Update patches, and rename them to follow makepatch naming maintainer timeout [1] [2] [3] -> take over maintainership PR: ports/184150 [1], ports/187117 [2], ports/189615 [3] Submitted by: Ryan Frederick [1], Jean-Sébastien Pédron [2], Ryan Frederick [3] Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=355584
Diffstat (limited to 'irc/unreal')
-rw-r--r--irc/unreal/Makefile111
-rw-r--r--irc/unreal/files/patch-Makefile.in6
-rw-r--r--irc/unreal/files/patch-configure20
-rw-r--r--irc/unreal/files/patch-configure.ac20
-rw-r--r--irc/unreal/files/patch-doc__example.conf (renamed from irc/unreal/files/patch-example.conf)10
-rw-r--r--irc/unreal/files/patch-include__config.h (renamed from irc/unreal/files/patch-config.h)18
-rw-r--r--irc/unreal/files/patch-src__ircd.c (renamed from irc/unreal/files/patch-ircd.c)9
-rw-r--r--irc/unreal/files/patch-src__modules.c (renamed from irc/unreal/files/patch-modules.c)12
-rw-r--r--irc/unreal/files/patch-src__s_conf.c (renamed from irc/unreal/files/patch-s_conf.c)8
-rw-r--r--irc/unreal/files/patch-src__url.c (renamed from irc/unreal/files/patch-url.c)8
-rw-r--r--irc/unreal/pkg-plist31
11 files changed, 117 insertions, 136 deletions
diff --git a/irc/unreal/Makefile b/irc/unreal/Makefile
index 5c319ddbb939..3d527dd5071c 100644
--- a/irc/unreal/Makefile
+++ b/irc/unreal/Makefile
@@ -3,11 +3,12 @@
PORTNAME= Unreal
PORTVERSION= 3.2.10.2
+PORTREVISION= 1
CATEGORIES= irc ipv6
MASTER_SITES= http://www.unrealircd.com/downloads/
DISTNAME= ${PORTNAME}${PORTVERSION}
-MAINTAINER= tanawts@gmail.com
+MAINTAINER= mat@FreeBSD.org
COMMENT= Unreal - the next generation ircd
LICENSE= GPLv2
@@ -56,48 +57,24 @@ ZIPLINKS_DESC= Enable ziplinks support
PREFIXAQ_DESC= Enable prefixes for chanadmin and chanowner
REMOTE_DESC= Enable remote includes
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MDOCS}
+PORTDOCS= *
DOCS= Donation doc/Authors doc/coding-guidelines \
doc/example.conf doc/tao.of.irc \
doc/translations.txt doc/unreal32docs.html \
doc/technical/005.txt doc/technical/base64.txt \
doc/technical/protoctl.txt doc/technical/token.txt \
doc/technical/vl.txt
-.endif
-
-.if ${PORT_OPTIONS:MHUB}
-CONFIGURE_ARGS+= --enable-hub
-.endif
-
-.if ${PORT_OPTIONS:MNOSPOOF}
-CONFIGURE_ARGS+= --enable-nospoof
-.endif
-
-.if ${PORT_OPTIONS:MZIPLINKS}
-CONFIGURE_ARGS+= --enable-ziplinks
-.endif
-.if ${PORT_OPTIONS:MIPV6}
-CONFIGURE_ARGS+= --enable-inet6
-.endif
-
-.if ${PORT_OPTIONS:MSSL}
-CONFIGURE_ARGS+= --enable-ssl
-# we can't use USE_OPENSSL=yes after including bsd.port.pre.mk
-.include "${PORTSDIR}/Mk/bsd.openssl.mk"
-.endif
-
-.if ${PORT_OPTIONS:MREMOTE}
-LIB_DEPENDS+= libcurl.so:${PORTSDIR}/ftp/curl
-CONFIGURE_ARGS+= --enable-libcurl=${LOCALBASE}
-.endif
-
-.if ${PORT_OPTIONS:MPREFIXAQ}
-CONFIGURE_ARGS+= --enable-prefixaq
-.endif
+HUB_CONFIGURE_ENABLE= hub
+NOSPOOF_CONFIGURE_ENABLE= nospoof
+ZIPLINKS_CONFIGURE_ENABLE= ziplinks
+IPV6_CONFIGURE_ENABLE= inet6
+SSL_CONFIGURE_ENABLE= ssl
+SSL_USE= OPENSSL=yes
+REMOTE_LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
+REMOTE_CONFIGURE_ON= --enable-libcurl=${LOCALBASE}
+REMOTE_CONFIGURE_OFF= --disable-libcurl
+PREFIXAQ_CONFIGURE_ENABLE= prefixaq
SQLMOD= ${PORTNAME}/SQLMod.tar.gz
@@ -134,52 +111,32 @@ post-patch:
.endif
@${REINPLACE_CMD} -e "/Your system does not support IPv6/ s|as_fn_error|echo|" ${WRKSRC}/configure
do-install:
- ${INSTALL} -m 0700 ${WRKSRC}/src/ircd ${PREFIX}/libexec/ircd
- ${MKDIR} ${MODULESDIR}
- ${MKDIR} ${CONFIGDIR} || true
- ${MKDIR} ${CONFIGDIR}/aliases || true
- ${MKDIR} ${EXAMPLESDIR}/aliases
- ${MKDIR} ${RUNDIR}/tmp
- ${MKDIR} ${LOGDIR}
- ${TOUCH} ${CONFIGDIR}/ircd.motd
- ${TOUCH} ${CONFIGDIR}/ircd.rules
- ${INSTALL_DATA} ${WRKSRC}/badwords.*.conf ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/help.conf ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/spamfilter.conf ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/example.conf ${EXAMPLESDIR}/unrealircd.conf
- ${INSTALL_DATA} ${WRKSRC}/aliases/*.conf ${EXAMPLESDIR}/aliases
- ${INSTALL} ${WRKSRC}/src/modules/*.so ${MODULESDIR}
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
+ ${INSTALL} -m 0700 ${WRKSRC}/src/ircd ${STAGEDIR}${PREFIX}/libexec/ircd
+ ${MKDIR} ${STAGEDIR}${MODULESDIR}
+ ${MKDIR} ${STAGEDIR}${CONFIGDIR} || true
+ ${MKDIR} ${STAGEDIR}${CONFIGDIR}/aliases || true
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/aliases
+ ${MKDIR} ${STAGEDIR}${RUNDIR}/tmp
+ ${MKDIR} ${STAGEDIR}${LOGDIR}
+ ${TOUCH} ${STAGEDIR}${CONFIGDIR}/ircd.motd
+ ${TOUCH} ${STAGEDIR}${CONFIGDIR}/ircd.rules
+ ${INSTALL_DATA} ${WRKSRC}/badwords.*.conf ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/help.conf ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/spamfilter.conf ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/example.conf ${STAGEDIR}${EXAMPLESDIR}/unrealircd.conf
+ ${INSTALL_DATA} ${WRKSRC}/aliases/*.conf ${STAGEDIR}${EXAMPLESDIR}/aliases
+ ${INSTALL} ${WRKSRC}/src/modules/*.so ${STAGEDIR}${MODULESDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
.for file in ${DOCS}
- ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
post-install:
- @[ -f ${CONFIGDIR}/aliases/aliases.conf ] || ${INSTALL_DATA} ${EXAMPLESDIR}/aliases/aliases.conf ${CONFIGDIR}/aliases
- @[ -f ${CONFIGDIR}/aliases/anope.conf ] || ${INSTALL_DATA} ${EXAMPLESDIR}/aliases/anope.conf ${CONFIGDIR}/aliases
- @[ -f ${CONFIGDIR}/aliases/auspice.conf ] || ${INSTALL_DATA} ${EXAMPLESDIR}/aliases/auspice.conf ${CONFIGDIR}/aliases
- @[ -f ${CONFIGDIR}/aliases/cygnus.conf ] || ${INSTALL_DATA} ${EXAMPLESDIR}/aliases/cygnus.conf ${CONFIGDIR}/aliases
- @[ -f ${CONFIGDIR}/aliases/epona.conf ] || ${INSTALL_DATA} ${EXAMPLESDIR}/aliases/epona.conf ${CONFIGDIR}/aliases
- @[ -f ${CONFIGDIR}/aliases/generic.conf ] || ${INSTALL_DATA} ${EXAMPLESDIR}/aliases/generic.conf ${CONFIGDIR}/aliases
- @[ -f ${CONFIGDIR}/aliases/genericstats.conf ] || ${INSTALL_DATA} ${EXAMPLESDIR}/aliases/genericstats.conf ${CONFIGDIR}/aliases
- @[ -f ${CONFIGDIR}/aliases/ircservices.conf ] || ${INSTALL_DATA} ${EXAMPLESDIR}/aliases/ircservices.conf ${CONFIGDIR}/aliases
- @[ -f ${CONFIGDIR}/aliases/operstats.conf ] || ${INSTALL_DATA} ${EXAMPLESDIR}/aliases/operstats.conf ${CONFIGDIR}/aliases
- @[ -f ${CONFIGDIR}/badwords.channel.conf ] || ${INSTALL_DATA} ${EXAMPLESDIR}/badwords.channel.conf ${CONFIGDIR}
- @[ -f ${CONFIGDIR}/badworks.message.conf ] || ${INSTALL_DATA} ${EXAMPLESDIR}/badwords.message.conf ${CONFIGDIR}
- @[ -f ${CONFIGDIR}/badwords.quit.conf ] || ${INSTALL_DATA} ${EXAMPLESDIR}/badwords.quit.conf ${CONFIGDIR}
- @[ -f ${CONFIGDIR}/help.conf ] || ${INSTALL_DATA} ${EXAMPLESDIR}/help.conf ${CONFIGDIR}
- @[ -f ${CONFIGDIR}/spamfilter.conf ] || ${INSTALL_DATA} ${EXAMPLESDIR}/spamfilter.conf ${CONFIGDIR}
- @[ -f ${CONFIGDIR}/unrealircd.conf ] || ${INSTALL_DATA} ${EXAMPLESDIR}/unrealircd.conf ${CONFIGDIR}
- @${CHOWN} -R ${USERS}:${GROUPS} ${CONFIGDIR}
- @${CHOWN} ${USERS}:${GROUPS} ${RUNDIR}
- @${CHOWN} ${USERS}:${GROUPS} ${LOGDIR}
.if defined(WITH_SQLMOD)
- @${CP} ${WRKSRC}/SQLMod/sample.conf ${CONFIGDIR}/m_sqlmod.conf
- @${CP} ${WRKSRC}/SQLMod/Changes ${DOCSDIR}/Changes.sqlmod
- @${CP} ${WRKSRC}/SQLMod/README ${DOCSDIR}/README.sqlmod
- @${CP} ${WRKSRC}/SQLMod/LICENSE ${DOCSDIR}/LICENSE.sqlmod
+ @${CP} ${WRKSRC}/SQLMod/sample.conf ${STAGEDIR}${CONFIGDIR}/m_sqlmod.conf
+ @${CP} ${WRKSRC}/SQLMod/Changes ${STAGEDIR}${DOCSDIR}/Changes.sqlmod
+ @${CP} ${WRKSRC}/SQLMod/README ${STAGEDIR}${DOCSDIR}/README.sqlmod
+ @${CP} ${WRKSRC}/SQLMod/LICENSE ${STAGEDIR}${DOCSDIR}/LICENSE.sqlmod
.endif
.include <bsd.port.mk>
diff --git a/irc/unreal/files/patch-Makefile.in b/irc/unreal/files/patch-Makefile.in
index deb4a9866507..e11fab6a920a 100644
--- a/irc/unreal/files/patch-Makefile.in
+++ b/irc/unreal/files/patch-Makefile.in
@@ -1,7 +1,5 @@
-$FreeBSD$
-
---- Makefile.in 2011-11-05 02:25:24.000000000 -0700
-+++ Makefile.in 2011-11-28 10:21:38.000000000 -0800
+--- ./Makefile.in.orig 2013-11-24 20:24:26.000000000 +0100
++++ ./Makefile.in 2014-05-23 00:34:32.000000000 +0200
@@ -38,7 +38,7 @@
CRYPTOLIB=@CRYPTOLIB@
OPENSSLINCLUDES=
diff --git a/irc/unreal/files/patch-configure b/irc/unreal/files/patch-configure
new file mode 100644
index 000000000000..380794605cc2
--- /dev/null
+++ b/irc/unreal/files/patch-configure
@@ -0,0 +1,20 @@
+--- configure 2014-02-27 14:03:45.132445608 +0100
++++ configure 2014-02-27 14:03:05.502448091 +0100
+@@ -6356,7 +6356,7 @@
+
+
+ hold_cflags=$CFLAGS
+-CFLAGS="$CFLAGS -export-dynamic"
++CFLAGS="$CFLAGS -Wl,-export-dynamic"
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking if we need the -export-dynamic flag" >&5
+ $as_echo_n "checking if we need the -export-dynamic flag... " >&6; }
+ if ${ac_cv_export_dynamic+:} false; then :
+@@ -6395,7 +6395,7 @@
+ else
+
+ if test "$ac_cv_c_compiler_gnu" = "yes"; then
+- ac_cv_pic="-fPIC -DPIC -shared"
++ ac_cv_pic="-std=gnu89 -fPIC -DPIC -shared"
+ case `uname -s` in
+ Darwin*)
+ ac_cv_pic="-bundle -flat_namespace -undefined suppress"
diff --git a/irc/unreal/files/patch-configure.ac b/irc/unreal/files/patch-configure.ac
new file mode 100644
index 000000000000..c7b3f44e17fb
--- /dev/null
+++ b/irc/unreal/files/patch-configure.ac
@@ -0,0 +1,20 @@
+--- configure.ac 2013-11-24 20:24:26.000000000 +0100
++++ configure.ac 2014-02-27 14:02:58.916469490 +0100
+@@ -107,7 +107,7 @@
+ ])])
+
+ hold_cflags=$CFLAGS
+-CFLAGS="$CFLAGS -export-dynamic"
++CFLAGS="$CFLAGS -Wl,-export-dynamic"
+ AC_CACHE_CHECK(if we need the -export-dynamic flag, ac_cv_export_dynamic, [
+ AC_TRY_LINK(, [int i];, ac_cv_export_dynamic=yes, ac_cv_export_dynamic=no)])
+ if test "$ac_cv_export_dynamic" = "no"; then
+@@ -116,7 +116,7 @@
+
+ AC_CACHE_CHECK(for compiler option to produce PIC,ac_cv_pic,[
+ if test "$ac_cv_prog_gcc" = "yes"; then
+- ac_cv_pic="-fPIC -DPIC -shared"
++ ac_cv_pic="-std=gnu89 -fPIC -DPIC -shared"
+ case `uname -s` in
+ Darwin*[)]
+ ac_cv_pic="-bundle -flat_namespace -undefined suppress"
diff --git a/irc/unreal/files/patch-example.conf b/irc/unreal/files/patch-doc__example.conf
index cb51bcb7a2cf..f4c931173b37 100644
--- a/irc/unreal/files/patch-example.conf
+++ b/irc/unreal/files/patch-doc__example.conf
@@ -1,17 +1,17 @@
---- doc/example.conf 2009-04-13 13:03:55.000000000 +0200
-+++ doc/example.conf 2009-08-18 16:36:29.000000000 +0200
+--- ./doc/example.conf.orig 2013-11-24 20:24:26.000000000 +0100
++++ ./doc/example.conf 2014-05-23 00:34:32.000000000 +0200
@@ -33,8 +33,8 @@
*/
/* FOR *NIX, uncomment the following 2lines: */
-//loadmodule "src/modules/commands.so";
-//loadmodule "src/modules/cloak.so";
-+//loadmodule "%%PREFIX%%/lib/Unreal/commands.so";
-+//loadmodule "%%PREFIX%%/lib/Unreal/cloak.so";
++loadmodule "%%PREFIX%%/lib/Unreal/commands.so";
++loadmodule "%%PREFIX%%/lib/Unreal/cloak.so";
/* FOR Windows, uncomment the following 2 lines: */
//loadmodule "modules/commands.dll";
-@@ -377,7 +377,7 @@
+@@ -379,7 +379,7 @@
* };
*/
diff --git a/irc/unreal/files/patch-config.h b/irc/unreal/files/patch-include__config.h
index 9b3844a4668c..79926fbf4061 100644
--- a/irc/unreal/files/patch-config.h
+++ b/irc/unreal/files/patch-include__config.h
@@ -1,8 +1,8 @@
---- include/config.h 2009-04-13 13:03:57.000000000 +0200
-+++ include/config.h 2009-08-18 16:16:39.000000000 +0200
-@@ -210,16 +210,16 @@
- * these are only the recommened names and paths. Change as needed.
- * You must define these to something, even if you don't really want them.
+--- ./include/config.h.orig 2013-11-24 20:24:26.000000000 +0100
++++ ./include/config.h 2014-05-23 00:34:32.000000000 +0200
+@@ -242,16 +242,16 @@
+ * line argument. These used as the default values for options absent from the user's
+ * unrealircd.conf.
*/
-#define CPATH "unrealircd.conf" /* server configuration file */
-#define MPATH "ircd.motd" /* server MOTD file */
@@ -27,14 +27,14 @@
/* CHROOTDIR
*
-@@ -245,8 +245,8 @@
- * define IRC_USER to that user name. This should only be defined if you
+@@ -277,8 +277,8 @@
+ * define IRC_USER to that user name. This should only be defined if you
* are running as root and even then perhaps not.
*/
-/* #define IRC_USER "<user name>" */
-/* #define IRC_GROUP "<group name>" */
+#define IRC_USER "%%USERS%%"
+#define IRC_GROUP "%%GROUPS%%"
-
-
+
+
/* SHOW_INVISIBLE_LUSERS
diff --git a/irc/unreal/files/patch-ircd.c b/irc/unreal/files/patch-src__ircd.c
index ddd388cb4068..8ac99ba9bfca 100644
--- a/irc/unreal/files/patch-ircd.c
+++ b/irc/unreal/files/patch-src__ircd.c
@@ -1,8 +1,6 @@
-$FreeBSD$
-
---- src/ircd.c 2011-11-05 02:25:24.000000000 -0700
-+++ src/ircd.c 2011-11-28 10:21:38.000000000 -0800
-@@ -1407,12 +1407,12 @@
+--- ./src/ircd.c.orig 2013-11-24 20:24:26.000000000 +0100
++++ ./src/ircd.c 2014-05-23 00:34:32.000000000 +0200
+@@ -1410,12 +1410,12 @@
}
#endif
#ifndef _WIN32
@@ -17,4 +15,3 @@ $FreeBSD$
#if defined(USE_LIBCURL) && defined(REMOTEINC_SPECIALCACHE)
mkdir("cache");
#endif
-
diff --git a/irc/unreal/files/patch-modules.c b/irc/unreal/files/patch-src__modules.c
index 23b3ac19b4b7..3d8301a14f62 100644
--- a/irc/unreal/files/patch-modules.c
+++ b/irc/unreal/files/patch-src__modules.c
@@ -1,6 +1,6 @@
---- src/modules.c 2009-04-13 13:03:58.000000000 +0200
-+++ src/modules.c 2009-08-20 15:32:56.000000000 +0200
-@@ -177,12 +177,12 @@
+--- ./src/modules.c.orig 2013-11-24 20:24:26.000000000 +0100
++++ ./src/modules.c 2014-05-23 00:34:33.000000000 +0200
+@@ -183,12 +183,12 @@
{
char tempbuf[PATH_MAX+1];
#ifndef _WIN32
@@ -15,7 +15,7 @@
strerror(errno));
if (!loop.ircd_booted)
exit(7);
-@@ -193,19 +193,19 @@
+@@ -199,19 +199,19 @@
{
if (!strcmp(dir->d_name, ".") || !strcmp(dir->d_name, ".."))
continue;
@@ -38,7 +38,7 @@
strcat(tempbuf, hData.cFileName);
remove(tempbuf);
}
-@@ -214,7 +214,7 @@
+@@ -220,7 +220,7 @@
{
if (!strcmp(hData.cFileName, ".") || !strcmp(hData.cFileName, ".."))
continue;
@@ -47,7 +47,7 @@
strcat(tempbuf, hData.cFileName);
remove(tempbuf);
}
-@@ -323,7 +323,7 @@
+@@ -329,7 +329,7 @@
path = path_;
diff --git a/irc/unreal/files/patch-s_conf.c b/irc/unreal/files/patch-src__s_conf.c
index ca09cc844035..64ace6cb2498 100644
--- a/irc/unreal/files/patch-s_conf.c
+++ b/irc/unreal/files/patch-src__s_conf.c
@@ -1,8 +1,6 @@
-$FreeBSD$
-
---- src/s_conf.c 2011-11-05 02:25:24.000000000 -0700
-+++ src/s_conf.c 2011-11-28 10:21:38.000000000 -0800
-@@ -9652,7 +9652,7 @@
+--- ./src/s_conf.c.orig 2013-11-24 20:24:26.000000000 +0100
++++ ./src/s_conf.c 2014-05-23 00:34:33.000000000 +0200
+@@ -9832,7 +9832,7 @@
{
char *urlfile = url_getfilename(url);
char *file_basename = unreal_getfilename(urlfile);
diff --git a/irc/unreal/files/patch-url.c b/irc/unreal/files/patch-src__url.c
index dfa3a6a4ba31..56860c894f88 100644
--- a/irc/unreal/files/patch-url.c
+++ b/irc/unreal/files/patch-src__url.c
@@ -1,6 +1,6 @@
---- src/url.c 2012-12-28 08:04:54.000000000 -0800
-+++ src/url.c 2012-12-31 18:03:14.000000000 -0800
-@@ -171,7 +171,7 @@
+--- ./src/url.c.orig 2013-11-24 20:24:26.000000000 +0100
++++ ./src/url.c 2014-05-23 00:34:33.000000000 +0200
+@@ -174,7 +174,7 @@
CURLcode res;
char *file = url_getfilename(url);
char *filename = unreal_getfilename(file);
@@ -9,7 +9,7 @@
FILE *fd;
-@@ -356,7 +356,7 @@
+@@ -359,7 +359,7 @@
{
char *file = url_getfilename(url);
char *filename = unreal_getfilename(file);
diff --git a/irc/unreal/pkg-plist b/irc/unreal/pkg-plist
index 72d9a91b2995..5b2bc4a00557 100644
--- a/irc/unreal/pkg-plist
+++ b/irc/unreal/pkg-plist
@@ -110,18 +110,6 @@ lib/Unreal/m_who.so
lib/Unreal/m_whois.so
lib/Unreal/m_whowas.so
libexec/ircd
-%%DOCSDIR%%/005.txt
-%%DOCSDIR%%/Authors
-%%DOCSDIR%%/Donation
-%%DOCSDIR%%/base64.txt
-%%DOCSDIR%%/coding-guidelines
-%%DOCSDIR%%/example.conf
-%%DOCSDIR%%/protoctl.txt
-%%DOCSDIR%%/tao.of.irc
-%%DOCSDIR%%/token.txt
-%%DOCSDIR%%/translations.txt
-%%DOCSDIR%%/unreal32docs.html
-%%DOCSDIR%%/vl.txt
%%EXAMPLESDIR%%/aliases/aliases.conf
%%EXAMPLESDIR%%/aliases/anope.conf
%%EXAMPLESDIR%%/aliases/atheme.conf
@@ -138,17 +126,18 @@ libexec/ircd
%%EXAMPLESDIR%%/help.conf
%%EXAMPLESDIR%%/spamfilter.conf
%%EXAMPLESDIR%%/unrealircd.conf
-%%SQLMOD%%%%DOCSDIR%%/Changes.sqlmod
-%%SQLMOD%%%%DOCSDIR%%/LICENSE.sqlmod
-%%SQLMOD%%%%DOCSDIR%%/README.sqlmod
%%SQLMOD%%%%ETCDIR%%/m_sqlmod.conf
%%SQLMOD%%lib/Unreal/m_sqlmod.so
-@dirrm %%DOCSDIR%%
-@dirrm %%EXAMPLESDIR%%
-@dirrm %%EXAMPLESDIR%%/aliases
-@dirrm lib/Unreal
-@dirrmtry %%ETCDIR%%
+@dirrmtry lib/Unreal
+@dirrmtry %%EXAMPLESDIR%%/aliases
+@dirrmtry %%EXAMPLESDIR%%
+@owner ircd
+@group ircd
@dirrmtry %%ETCDIR%%/aliases
+@dirrmtry %%ETCDIR%%
+@unexec rmdir "/var/log/ircd" >/dev/null 2>&1 || :
+@unexec rmdir "/var/run/ircd/tmp" >/dev/null 2>&1 || :
+@unexec rmdir "/var/run/ircd" >/dev/null 2>&1 || :
@unexec if cmp -s %D/etc/Unreal/aliases/aliases.conf %D/%%EXAMPLESDIR%%/aliases/aliases.conf; then rm -f %D/etc/Unreal/aliases/aliases.conf; fi
@exec [ -f %D/etc/Unreal/aliases/aliases.conf ] || cp %D/%%EXAMPLESDIR%%/aliases/aliases.conf %D/etc/Unreal/aliases/aliases.conf
@unexec if cmp -s %D/etc/Unreal/aliases/atheme.conf %D/%%EXAMPLESDIR%%/aliases/atheme.conf; then rm -f %D/etc/Unreal/aliases/atheme.conf; fi
@@ -181,3 +170,5 @@ libexec/ircd
@exec [ -f %D/etc/Unreal/spamfilter.conf ] || cp %D/%%EXAMPLESDIR%%/spamfilter.conf %D/etc/Unreal/spamfilter.conf
@unexec if cmp -s %D/etc/Unreal/unrealircd.conf %D/%%EXAMPLESDIR%%/unrealircd.conf; then rm -f %D/etc/Unreal/unrealircd.conf; fi
@exec [ -f %D/etc/Unreal/unrealircd.conf ] || cp %D/%%EXAMPLESDIR%%/unrealircd.conf %D/etc/Unreal/unrealircd.conf
+@owner root
+@group wheel