aboutsummaryrefslogtreecommitdiff
path: root/irc/unreal
diff options
context:
space:
mode:
authorCarlo Strub <cs@FreeBSD.org>2012-10-07 13:30:18 +0000
committerCarlo Strub <cs@FreeBSD.org>2012-10-07 13:30:18 +0000
commitbbf48f757c14abf24698259f5bfbc27df256a1f9 (patch)
tree8ff681bde3bcfdc17d90d17d57a808171ef122c3 /irc/unreal
parent0776e6b4df8cc06727476a44c67bfcf392dace90 (diff)
downloadports-bbf48f757c14abf24698259f5bfbc27df256a1f9.tar.gz
ports-bbf48f757c14abf24698259f5bfbc27df256a1f9.zip
Patch to add chown modify at the end of the install. This will correctly assign
the owner of the config, log, and run directories for the owner specified by the port (by default this is ircd:ircd) PR: ports/172184 Submitted by: Jr Aquino <tanawts@gmail.com> (maintainer)
Notes
Notes: svn path=/head/; revision=305474
Diffstat (limited to 'irc/unreal')
-rw-r--r--irc/unreal/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/irc/unreal/Makefile b/irc/unreal/Makefile
index 186558aa1937..3ad1482541a2 100644
--- a/irc/unreal/Makefile
+++ b/irc/unreal/Makefile
@@ -176,6 +176,9 @@ post-install:
@[ -f ${CONFIGDIR}/help.conf ] || ${INSTALL_DATA} ${EXAMPLESDIR}/help.conf ${CONFIGDIR}
@[ -f ${CONFIGDIR}/spamfilter.conf ] || ${INSTALL_DATA} ${EXAMPLESDIR}/spamfilter.conf ${CONFIGDIR}
@[ -f ${CONFIGDIR}/unrealircd.conf ] || ${INSTALL_DATA} ${EXAMPLESDIR}/unrealircd.conf ${CONFIGDIR}
+ @${CHOWN} -R ${USERS}:${GROUPS} ${CONFIGDIR}
+ @${CHOWN} ${USERS}:${GROUPS} ${RUNDIR}
+ @${CHOWN} ${USERS}:${GROUPS} ${LOGDIR}
.if defined(WITH_SQLMOD)
@${CP} ${WRKSRC}/SQLMod/sample.conf ${CONFIGDIR}/m_sqlmod.conf
@${CP} ${WRKSRC}/SQLMod/Changes ${DOCSDIR}/Changes.sqlmod