aboutsummaryrefslogtreecommitdiff
path: root/irc/weechat/files
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-01-27 01:04:15 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-01-27 01:04:15 +0000
commit323547c8f879fdfd655e5aedd5d6752b1b9038d9 (patch)
tree3ad4224aac23af0146b8f60f43afcc154f70d7d4 /irc/weechat/files
parentb236573620a314ed7ee5f870eb06fc1cf4bba012 (diff)
downloadports-323547c8f879fdfd655e5aedd5d6752b1b9038d9.tar.gz
ports-323547c8f879fdfd655e5aedd5d6752b1b9038d9.zip
Notes
Diffstat (limited to 'irc/weechat/files')
-rw-r--r--irc/weechat/files/patch-cmake-FindIconv_cmake12
-rw-r--r--irc/weechat/files/patch-cmake-FindRuby_cmake26
-rw-r--r--irc/weechat/files/patch-configure.in29
-rw-r--r--irc/weechat/files/patch-src-plugins-scripts-script_c168
4 files changed, 38 insertions, 197 deletions
diff --git a/irc/weechat/files/patch-cmake-FindIconv_cmake b/irc/weechat/files/patch-cmake-FindIconv_cmake
new file mode 100644
index 000000000000..726c9f026b8b
--- /dev/null
+++ b/irc/weechat/files/patch-cmake-FindIconv_cmake
@@ -0,0 +1,12 @@
+--- cmake/FindIconv.cmake.orig 2010-01-20 17:31:05.000000000 +0000
++++ cmake/FindIconv.cmake 2010-01-20 17:31:30.000000000 +0000
+@@ -30,6 +30,9 @@
+ set(ICONV_FIND_QUIETLY TRUE)
+ ENDIF(ICONV_FOUND)
+
++INCLUDE(CheckLibraryExists)
++INCLUDE(CheckFunctionExists)
++
+ FIND_PATH(ICONV_INCLUDE_PATH
+ NAMES iconv.h
+ PATHS /usr/include /usr/local/include /usr/pkg/include
diff --git a/irc/weechat/files/patch-cmake-FindRuby_cmake b/irc/weechat/files/patch-cmake-FindRuby_cmake
new file mode 100644
index 000000000000..fa8fba70ed7d
--- /dev/null
+++ b/irc/weechat/files/patch-cmake-FindRuby_cmake
@@ -0,0 +1,26 @@
+--- cmake/FindRuby.cmake.orig 2010-01-05 21:12:22.000000000 +0000
++++ cmake/FindRuby.cmake 2010-01-05 21:14:40.000000000 +0000
+@@ -35,7 +35,7 @@
+
+ IF(RUBY_EXECUTABLE)
+ EXECUTE_PROCESS(
+- COMMAND ${RUBY_EXECUTABLE} -r rbconfig -e "puts Config::CONFIG['rubyhdrdir'] || Config::CONFIG['archdir']"
++ COMMAND ${RUBY_EXECUTABLE} -r rbconfig -e "puts Config::CONFIG['topdir']"
+ OUTPUT_VARIABLE RUBY_ARCH_DIR
+ )
+
+@@ -45,12 +45,12 @@
+ )
+
+ EXECUTE_PROCESS(
+- COMMAND ${RUBY_EXECUTABLE} -r rbconfig -e "puts Config::CONFIG['libdir']"
++ COMMAND ${RUBY_EXECUTABLE} -r rbconfig -e "puts Config::TOPDIR + '/lib'"
+ OUTPUT_VARIABLE RUBY_POSSIBLE_LIB_PATH
+ )
+
+ EXECUTE_PROCESS(
+- COMMAND ${RUBY_EXECUTABLE} -r rbconfig -e "puts Config::CONFIG['rubylibdir']"
++ COMMAND ${RUBY_EXECUTABLE} -r rbconfig -e "puts Config::TOPDIR + '/lib/ruby/' + Config::CONFIG['ruby_version']"
+ OUTPUT_VARIABLE RUBY_RUBY_LIB_PATH
+ )
+
diff --git a/irc/weechat/files/patch-configure.in b/irc/weechat/files/patch-configure.in
deleted file mode 100644
index 5510d034332d..000000000000
--- a/irc/weechat/files/patch-configure.in
+++ /dev/null
@@ -1,29 +0,0 @@
---- configure.in.orig 2009-09-06 08:01:26.000000000 +0000
-+++ configure.in 2009-11-12 14:46:30.000000000 +0000
-@@ -137,6 +137,7 @@
- AC_ARG_WITH(lua-inc, [ --with-lua-inc=DIR, lua include files are in DIR (default=autodetect)],lua_inc=$withval,lua_inc='')
- AC_ARG_WITH(lua-lib, [ --with-lua-lib=DIR, lua library files are in DIR (default=autodetect)],lua_lib=$withval,lua_lib='')
- AC_ARG_WITH(lua-suffix, [ --with-lua-suffix=ARG lua is suffixed with ARG (default=autodetect)],lua_suffix=$withval,lua_suffix='')
-+AC_ARG_WITH(tclconfig, [ --with-tclconfig=DIR directory containing tcl configuration (tclConfig.sh)],tclconfig=$withval,tclconfig='')
- AC_ARG_ENABLE(doc, [ --disable-doc turn off documentation (default=built)],enable_doc=$enableval,enable_doc=yes)
- AC_ARG_WITH(debug, [ --with-debug debugging: 0=no debug, 1=debug compilation (default=1)],debug=$withval,debug=1)
-
-@@ -682,6 +683,9 @@
- AC_MSG_CHECKING(for tclConfig.sh)
- tcl_found="no"
- tcl_dirs="/lib /usr/lib /usr/tcl/lib /usr/lib/tcl8.5 /usr/lib/tcl8.4 /usr/lib/tcl8.3 /usr/local/lib /usr/local/tcl-8.5/lib /usr/local/tcl-8.4/lib /usr/local/tcl-8.3/lib /usr/local/tcl/lib /opt/lib"
-+ if test "x$tclconfig" != "x" ; then
-+ tcl_dirs="$tclconfig $tcl_dirs"
-+ fi
- for tcl_dir in $tcl_dirs ; do
- if test -f ${tcl_dir}/tclConfig.sh ; then
- . ${tcl_dir}/tclConfig.sh
-@@ -870,7 +874,7 @@
- AC_MSG_RESULT(no)
- fi
-
--CFLAGS=`echo $CFLAGS | sed 's/ -g //g'`
-+CFLAGS=`echo $CFLAGS | sed 's/ -g / /g'`
- CFLAGS=`echo $CFLAGS | sed 's/^-g //g'`
- CFLAGS=`echo $CFLAGS | sed 's/ -g$//g'`
- CFLAGS=`echo $CFLAGS | sed 's/^-g$//g'`
diff --git a/irc/weechat/files/patch-src-plugins-scripts-script_c b/irc/weechat/files/patch-src-plugins-scripts-script_c
deleted file mode 100644
index 1c935827582e..000000000000
--- a/irc/weechat/files/patch-src-plugins-scripts-script_c
+++ /dev/null
@@ -1,168 +0,0 @@
---- src/plugins/scripts/script.c.orig 2009-09-04 08:25:47.000000000 +0000
-+++ src/plugins/scripts/script.c 2009-11-16 12:08:54.000000000 +0000
-@@ -439,24 +439,15 @@
- script_search_by_full_name (struct t_plugin_script *scripts,
- const char *full_name)
- {
-- char *full_name_copy, *base_name;
-+ char *base_name;
- struct t_plugin_script *ptr_script;
-
-- full_name_copy = strdup (full_name);
--
-- if (full_name_copy)
-+ for (ptr_script = scripts; ptr_script;
-+ ptr_script = ptr_script->next_script)
- {
-- for (ptr_script = scripts; ptr_script;
-- ptr_script = ptr_script->next_script)
-- {
-- base_name = basename (ptr_script->filename);
-- if (strcmp (base_name, full_name) == 0)
-- {
-- free (full_name_copy);
-- return ptr_script;
-- }
-- }
-- free (full_name_copy);
-+ base_name = basename (ptr_script->filename);
-+ if (strcmp (base_name, full_name) == 0)
-+ return ptr_script;
- }
-
- /* script not found */
-@@ -915,7 +906,8 @@
- int (*script_load)(const char *filename),
- char **list)
- {
-- char **argv, *name, *base_name, *new_path, *autoload_path, *symlink_path;
-+ char **argv, *name, *ptr_base_name, *base_name, *new_path, *autoload_path;
-+ char *symlink_path;
- const char *dir_home, *dir_separator;
- int argc, i, length;
- struct t_plugin_script *ptr_script;
-@@ -930,67 +922,71 @@
- name = strdup (argv[i]);
- if (name)
- {
-- base_name = basename (name);
--
-- /* unload script, if script is loaded */
-- ptr_script = script_search_by_full_name (scripts, base_name);
-- if (ptr_script)
-- (*script_unload) (ptr_script);
-+ ptr_base_name = basename (name);
-+ base_name = strdup (ptr_base_name);
-+ if (base_name)
-+ {
-+ /* unload script, if script is loaded */
-+ ptr_script = script_search_by_full_name (scripts, base_name);
-+ if (ptr_script)
-+ (*script_unload) (ptr_script);
-
-- /* remove script file(s) */
-- script_remove_file (weechat_plugin, base_name, 0);
-+ /* remove script file(s) */
-+ script_remove_file (weechat_plugin, base_name, 0);
-
-- /* move file from install dir to language dir */
-- dir_home = weechat_info_get ("weechat_dir", "");
-- length = strlen (dir_home) + strlen (weechat_plugin->name) +
-- strlen (base_name) + 16;
-- new_path = malloc (length);
-- if (new_path)
-- {
-- snprintf (new_path, length, "%s/%s/%s",
-- dir_home, weechat_plugin->name, base_name);
-- if (rename (name, new_path) == 0)
-+ /* move file from install dir to language dir */
-+ dir_home = weechat_info_get ("weechat_dir", "");
-+ length = strlen (dir_home) + strlen (weechat_plugin->name) +
-+ strlen (base_name) + 16;
-+ new_path = malloc (length);
-+ if (new_path)
- {
-- /* make link in autoload dir */
-- length = strlen (dir_home) +
-- strlen (weechat_plugin->name) + 8 +
-- strlen (base_name) + 16;
-- autoload_path = malloc (length);
-- if (autoload_path)
-+ snprintf (new_path, length, "%s/%s/%s",
-+ dir_home, weechat_plugin->name, base_name);
-+ if (rename (name, new_path) == 0)
- {
-- snprintf (autoload_path, length,
-- "%s/%s/autoload/%s",
-- dir_home, weechat_plugin->name,
-- base_name);
-- dir_separator = weechat_info_get ("dir_separator", "");
-- length = 2 + strlen (dir_separator) +
-- strlen (base_name) + 1;
-- symlink_path = malloc (length);
-- if (symlink_path)
-+ /* make link in autoload dir */
-+ length = strlen (dir_home) +
-+ strlen (weechat_plugin->name) + 8 +
-+ strlen (base_name) + 16;
-+ autoload_path = malloc (length);
-+ if (autoload_path)
- {
-- snprintf (symlink_path, length, "..%s%s",
-- dir_separator, base_name);
-- symlink (symlink_path, autoload_path);
-- free (symlink_path);
-- }
-+ snprintf (autoload_path, length,
-+ "%s/%s/autoload/%s",
-+ dir_home, weechat_plugin->name,
-+ base_name);
-+ dir_separator = weechat_info_get ("dir_separator", "");
-+ length = 2 + strlen (dir_separator) +
-+ strlen (base_name) + 1;
-+ symlink_path = malloc (length);
-+ if (symlink_path)
-+ {
-+ snprintf (symlink_path, length, "..%s%s",
-+ dir_separator, base_name);
-+ symlink (symlink_path, autoload_path);
-+ free (symlink_path);
-+ }
- free (autoload_path);
-- }
-+ }
-
-- /* load script */
-- (*script_load) (new_path);
-- }
-- else
-- {
-- weechat_printf (NULL,
-- _("%s%s: failed to move script %s "
-- "to %s (%s)"),
-- weechat_prefix ("error"),
-- weechat_plugin->name,
-- name,
-- new_path,
-- strerror (errno));
-+ /* load script */
-+ (*script_load) (new_path);
-+ }
-+ else
-+ {
-+ weechat_printf (NULL,
-+ _("%s%s: failed to move script %s "
-+ "to %s (%s)"),
-+ weechat_prefix ("error"),
-+ weechat_plugin->name,
-+ name,
-+ new_path,
-+ strerror (errno));
-+ }
-+ free (new_path);
- }
-- free (new_path);
-+ free (base_name);
- }
- free (name);
- }