aboutsummaryrefslogtreecommitdiff
path: root/irc/xchat-gnome/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2006-10-14 08:54:54 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2006-10-14 08:54:54 +0000
commit29747f458a1eb2ce23b4594b09d0256dd62760b8 (patch)
tree1b71ba5d9ffdd308b6c18130f7c116f5bab5dc12 /irc/xchat-gnome/Makefile
parent7aad84f808b93baa6a7077ce0b47573b9c4c79a0 (diff)
downloadports-29747f458a1eb2ce23b4594b09d0256dd62760b8.tar.gz
ports-29747f458a1eb2ce23b4594b09d0256dd62760b8.zip
Notes
Diffstat (limited to 'irc/xchat-gnome/Makefile')
-rw-r--r--irc/xchat-gnome/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/irc/xchat-gnome/Makefile b/irc/xchat-gnome/Makefile
index 43c403c842bf..bc966333ce5a 100644
--- a/irc/xchat-gnome/Makefile
+++ b/irc/xchat-gnome/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xchat
PORTVERSION= 0.13
+PORTREVISION= 2
CATEGORIES= irc gnome ipv6
MASTER_SITES= http://releases.navi.cx/xchat-gnome/
PKGNAMESUFFIX= -gnome
@@ -18,11 +19,11 @@ COMMENT= An IRC client for GNOME 2 (development version)
LIB_DEPENDS= sexy:${PORTSDIR}/x11-toolkits/libsexy \
notify:${PORTSDIR}/devel/libnotify
-USE_X_PREFIX= yes
+USE_XLIB= yes
USE_GETTEXT= yes
USE_BZIP2= yes
USE_GMAKE= yes
-USE_GNOME= gnomehack libgnomeui gnomedocutils desktopfileutils
+USE_GNOME= gnomehack gnomeprefix libgnomeui gnomedocutils desktopfileutils
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
@@ -32,7 +33,7 @@ INSTALLS_ICONS= yes
INSTALLS_OMF= yes
.if !defined(WITHOUT_DBUS)
-LIB_DEPENDS+= dbus-1.2:${PORTSDIR}/devel/dbus
+LIB_DEPENDS+= dbus-1.3:${PORTSDIR}/devel/dbus
CONFIGURE_ARGS+= --enable-dbus
USE_GNOME+= gconf2
GCONF_SCHEMAS+= xchat_gnome_url_handler.schemas