aboutsummaryrefslogtreecommitdiff
path: root/irc/xchat
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2008-06-14 16:25:41 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2008-06-14 16:25:41 +0000
commit4339d2d670c8d1e440c806168efd88a53e81c203 (patch)
treeaa1ce8a9ab4907d0b6658ff634c4746362afca6f /irc/xchat
parentd0323fcfe581485da04112eca8dc1097d52348e4 (diff)
downloadports-4339d2d670c8d1e440c806168efd88a53e81c203.tar.gz
ports-4339d2d670c8d1e440c806168efd88a53e81c203.zip
Notes
Diffstat (limited to 'irc/xchat')
-rw-r--r--irc/xchat/Makefile3
-rw-r--r--irc/xchat/distinfo6
-rw-r--r--irc/xchat/files/patch-src_fe-gtk_fe-gtk.c22
-rw-r--r--irc/xchat/files/patch-xc284-fix-scrollbfdleak14
-rw-r--r--irc/xchat/files/patch-xc284-improvescrollback28
-rw-r--r--irc/xchat/files/patch-xc284-scrollbmkdir33
-rw-r--r--irc/xchat/pkg-plist1
7 files changed, 5 insertions, 102 deletions
diff --git a/irc/xchat/Makefile b/irc/xchat/Makefile
index e95f73544521..20ea926c0356 100644
--- a/irc/xchat/Makefile
+++ b/irc/xchat/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= xchat
-PORTVERSION= 2.8.4
-PORTREVISION= 6
+PORTVERSION= 2.8.6
CATEGORIES= irc gnome ipv6
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://xchat.org/files/source/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}/
diff --git a/irc/xchat/distinfo b/irc/xchat/distinfo
index 5628be3e9478..901a1ee75733 100644
--- a/irc/xchat/distinfo
+++ b/irc/xchat/distinfo
@@ -1,3 +1,3 @@
-MD5 (xchat-2.8.4.tar.bz2) = 66d60febc62a01bafac9bb3a35fb37ae
-SHA256 (xchat-2.8.4.tar.bz2) = f95a9a9e477128aae536669dedd79f4e7b4d469072565695289e4bbb5b36dd63
-SIZE (xchat-2.8.4.tar.bz2) = 1370883
+MD5 (xchat-2.8.6.tar.bz2) = 1f2670865d43a23a9abc596dde999aca
+SHA256 (xchat-2.8.6.tar.bz2) = 8c89dbf36304b99363a7f090d695447653102b4528ca2aa367a2abe5cff1746d
+SIZE (xchat-2.8.6.tar.bz2) = 1423645
diff --git a/irc/xchat/files/patch-src_fe-gtk_fe-gtk.c b/irc/xchat/files/patch-src_fe-gtk_fe-gtk.c
deleted file mode 100644
index 6573e33626fe..000000000000
--- a/irc/xchat/files/patch-src_fe-gtk_fe-gtk.c
+++ /dev/null
@@ -1,22 +0,0 @@
---- src/fe-gtk/fe-gtk.c.orig 2008-03-07 13:04:07.000000000 -0600
-+++ src/fe-gtk/fe-gtk.c 2008-03-07 13:05:24.000000000 -0600
-@@ -660,7 +660,7 @@
- session *sess;
- gdouble per;
- char lagtext[64];
-- char lagtip[64];
-+ char lagtip[128];
- unsigned long nowtim;
-
- if (lag == -1)
-@@ -716,8 +716,8 @@
- GSList *list = sess_list;
- struct session *sess;
- float per;
-- char tbuf[64];
-- char tip[64];
-+ char tbuf[96];
-+ char tip[160];
-
- per = (float) serv->sendq_len / 1024.0;
- if (per > 1.0)
diff --git a/irc/xchat/files/patch-xc284-fix-scrollbfdleak b/irc/xchat/files/patch-xc284-fix-scrollbfdleak
deleted file mode 100644
index 32963cbf10b0..000000000000
--- a/irc/xchat/files/patch-xc284-fix-scrollbfdleak
+++ /dev/null
@@ -1,14 +0,0 @@
-#
-# Scrollback shrinking code forgets to close().
-#
---- src/common/text.c 2007-06-13 19:59:56.000000000 +1000
-+++ src/common/text.c 2007-11-02 23:52:57.000000000 +1100
-@@ -141,6 +146,7 @@
- }
-
- *len = st.st_size;
-+ close (fh);
- return buf;
- }
-
-
diff --git a/irc/xchat/files/patch-xc284-improvescrollback b/irc/xchat/files/patch-xc284-improvescrollback
deleted file mode 100644
index b83f251ed68c..000000000000
--- a/irc/xchat/files/patch-xc284-improvescrollback
+++ /dev/null
@@ -1,28 +0,0 @@
-#
-# 1) Stops scrollback files growing too large by fixing the file-shrink code.
-# 2) Puts a "Display scrollback from previous session" into the Setup GUI
-# (logging section) so people can turn this off without typing commands.
-#
---- src/common/text.c 29 Jul 2007 05:02:36 -0000 1.90
-+++ src/common/text.c 26 Sep 2007 07:29:55 -0000
-@@ -285,6 +285,8 @@
- }
- }
-
-+ sess->scrollwritten = lines;
-+
- if (lines)
- {
- text = ctime (&stamp);
---- src/fe-gtk/setup.c 9 Sep 2007 04:57:07 -0000 1.100
-+++ src/fe-gtk/setup.c 26 Sep 2007 07:29:57 -0000
-@@ -382,7 +382,8 @@
- static const setting logging_settings[] =
- {
- {ST_HEADER, N_("Logging"),0,0,0},
-- {ST_TOGGLE, N_("Enable logging of conversations"), P_OFFINTNL(logging), 0, 0, 2},
-+ {ST_TOGGLE, N_("Display scrollback from previous session"), P_OFFINTNL(text_replay), 0, 0, 0},
-+ {ST_TOGGLE, N_("Enable logging of conversations"), P_OFFINTNL(logging), 0, 0, 2},
- {ST_ENTRY, N_("Log filename:"), P_OFFSETNL(logmask), 0, 0, sizeof prefs.logmask},
- {ST_LABEL, N_("%s=Server %c=Channel %n=Network.")},
-
diff --git a/irc/xchat/files/patch-xc284-scrollbmkdir b/irc/xchat/files/patch-xc284-scrollbmkdir
deleted file mode 100644
index 2ac328497a8b..000000000000
--- a/irc/xchat/files/patch-xc284-scrollbmkdir
+++ /dev/null
@@ -1,33 +0,0 @@
-#
-# Fix creation of ~/.xchat2/scrollback/ paths.
-#
---- src/common/text.c 15 Jun 2007 03:53:42 -0000 1.89
-+++ src/common/text.c 8 Jul 2007 08:59:02 -0000
-@@ -49,20 +49,25 @@
-
-
- static void mkdir_p (char *dir);
-+static char *log_create_filename (char *channame);
-
-
- static char *
- scrollback_get_filename (session *sess, char *buf, int max)
- {
-- char *net;
-+ char *net, *chan;
-
- net = server_get_network (sess->server, FALSE);
- if (!net)
- return NULL;
-
-- snprintf (buf, max, "%s/scrollback/%s/%s.txt", get_xdir_fs (), net, sess->channel);
-+ snprintf (buf, max, "%s/scrollback/%s/%s.txt", get_xdir_fs (), net, "");
- mkdir_p (buf);
-
-+ chan = log_create_filename (sess->channel);
-+ snprintf (buf, max, "%s/scrollback/%s/%s.txt", get_xdir_fs (), net, chan);
-+ free (chan);
-+
- return buf;
- }
-
diff --git a/irc/xchat/pkg-plist b/irc/xchat/pkg-plist
index 7cb53f2833d0..0b63ee0bcd66 100644
--- a/irc/xchat/pkg-plist
+++ b/irc/xchat/pkg-plist
@@ -29,6 +29,7 @@ share/locale/ru/LC_MESSAGES/xchat.mo
share/locale/sq/LC_MESSAGES/xchat.mo
share/locale/sr/LC_MESSAGES/xchat.mo
share/locale/sv/LC_MESSAGES/xchat.mo
+share/locale/th/LC_MESSAGES/xchat.mo
share/locale/uk/LC_MESSAGES/xchat.mo
share/locale/vi/LC_MESSAGES/xchat.mo
share/locale/zh_CN/LC_MESSAGES/xchat.mo