aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2001-12-25 04:59:19 +0000
committerPete Fritchman <petef@FreeBSD.org>2001-12-25 04:59:19 +0000
commit1a72bed384a0ba7150f9dc78d4f97a2eaac8c1c2 (patch)
tree53b0e351b1746a8ff28dece3e69c594a921e2fe8 /irc
parentda6eee1942df45cf542aa0aea2b42ed05177e28e (diff)
downloadports-1a72bed384a0ba7150f9dc78d4f97a2eaac8c1c2.tar.gz
ports-1a72bed384a0ba7150f9dc78d4f97a2eaac8c1c2.zip
Notes
Diffstat (limited to 'irc')
-rw-r--r--irc/Makefile1
-rw-r--r--irc/gruftistats/Makefile29
-rw-r--r--irc/gruftistats/distinfo1
-rw-r--r--irc/gruftistats/files/patch-Makefile.in20
-rw-r--r--irc/gruftistats/pkg-comment1
-rw-r--r--irc/gruftistats/pkg-descr12
-rw-r--r--irc/gruftistats/pkg-plist27
7 files changed, 91 insertions, 0 deletions
diff --git a/irc/Makefile b/irc/Makefile
index 3f13cb7d8d23..f2ff7aa46649 100644
--- a/irc/Makefile
+++ b/irc/Makefile
@@ -9,6 +9,7 @@
SUBDIR += dircproxy
SUBDIR += epic4
SUBDIR += ezbounce
+ SUBDIR += gruftistats
SUBDIR += infobot
SUBDIR += irc
SUBDIR += ircII
diff --git a/irc/gruftistats/Makefile b/irc/gruftistats/Makefile
new file mode 100644
index 000000000000..34c9b7ea5100
--- /dev/null
+++ b/irc/gruftistats/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: gruftistats
+# Date created: 29 October 2001
+# Whom: Matthew West <mwest@uct.ac.za>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gruftistats
+PORTVERSION= 0.2.4
+CATEGORIES= irc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= gruftistats
+
+MAINTAINER= mwest@uct.ac.za
+
+GNU_CONFIGURE= YES
+USE_GMAKE= YES
+
+.if defined(NOPORTDOCS)
+MAKE_ARGS= NOPORTDOCS=1
+.endif
+
+MAN1= gruftistats.1
+
+post-patch:
+ @${PERL} -pi -e 's,strcasestr,strcasestr_x,g' ${WRKSRC}/ircstats.h \
+ ${WRKSRC}/lib.c
+
+.include <bsd.port.mk>
diff --git a/irc/gruftistats/distinfo b/irc/gruftistats/distinfo
new file mode 100644
index 000000000000..ef4b2e45aa70
--- /dev/null
+++ b/irc/gruftistats/distinfo
@@ -0,0 +1 @@
+MD5 (gruftistats-0.2.4.tar.gz) = e3999150c38a9d563ceb759ef821ae50
diff --git a/irc/gruftistats/files/patch-Makefile.in b/irc/gruftistats/files/patch-Makefile.in
new file mode 100644
index 000000000000..c976365512d9
--- /dev/null
+++ b/irc/gruftistats/files/patch-Makefile.in
@@ -0,0 +1,20 @@
+$FreeBSD$
+
+--- Makefile.in.orig Sun Sep 16 06:57:25 2001
++++ Makefile.in Mon Dec 24 23:43:31 2001
+@@ -249,6 +249,7 @@
+ $(MAKE) $(AM_MAKEFLAGS) uninstall-man1
+
+ install-docDATA: $(doc_DATA)
++ifndef NOPORTDOCS
+ @$(NORMAL_INSTALL)
+ $(mkinstalldirs) $(DESTDIR)$(docdir)
+ @list='$(doc_DATA)'; for p in $$list; do \
+@@ -260,6 +261,7 @@
+ $(INSTALL_DATA) $$p $(DESTDIR)$(docdir)/$$p; \
+ fi; fi; \
+ done
++endif
+
+ uninstall-docDATA:
+ @$(NORMAL_UNINSTALL)
diff --git a/irc/gruftistats/pkg-comment b/irc/gruftistats/pkg-comment
new file mode 100644
index 000000000000..cdc2ea1f0b15
--- /dev/null
+++ b/irc/gruftistats/pkg-comment
@@ -0,0 +1 @@
+Produces a web page of statistics and quotes from IRC channel logs
diff --git a/irc/gruftistats/pkg-descr b/irc/gruftistats/pkg-descr
new file mode 100644
index 000000000000..cfd868312cac
--- /dev/null
+++ b/irc/gruftistats/pkg-descr
@@ -0,0 +1,12 @@
+Gruftistats is a program which reads your IRC logs and turns them into
+a web page. This has a mixture of statistics (like who talked most),
+and amusing facts (like who got kicked most).
+
+It supports a variety of log formats already, and can be extended to
+support other log formats by writing a spec file describing the
+format.
+
+WWW: http://gruftistats.sourceforge.net/
+
+--
+mwest@uct.ac.za
diff --git a/irc/gruftistats/pkg-plist b/irc/gruftistats/pkg-plist
new file mode 100644
index 000000000000..903ac37e4979
--- /dev/null
+++ b/irc/gruftistats/pkg-plist
@@ -0,0 +1,27 @@
+bin/gruftistats
+%%PORTDOCS%%share/doc/gruftistats/AUTHORS
+%%PORTDOCS%%share/doc/gruftistats/COPYING
+%%PORTDOCS%%share/doc/gruftistats/ChangeLog
+%%PORTDOCS%%share/doc/gruftistats/NEWS
+%%PORTDOCS%%share/doc/gruftistats/README
+%%PORTDOCS%%share/doc/gruftistats/README.log-formats
+%%PORTDOCS%%share/doc/gruftistats/sample.conf
+share/gruftistats/axur.lrx
+share/gruftistats/bitchx.lrx
+share/gruftistats/dancer.lrx
+share/gruftistats/eggdrop-1.4.x-mel.lrx
+share/gruftistats/eggdrop2.lrx
+share/gruftistats/grufti.lrx
+share/gruftistats/irssi-some-theme.lrx
+share/gruftistats/irssi.lrx
+share/gruftistats/pipe1h.png
+share/gruftistats/pipe1v.png
+share/gruftistats/pipe2h.png
+share/gruftistats/pipe2v.png
+share/gruftistats/pipe3h.png
+share/gruftistats/pipe3v.png
+share/gruftistats/pipe4h.png
+share/gruftistats/pipe4v.png
+share/gruftistats/xchat.lrx
+@dirrm share/gruftistats
+%%PORTDOCS%%@dirrm share/doc/gruftistats