aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-06 10:44:38 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-06 10:44:38 +0000
commit9520ebb4931841f515ac2236cd461ab1db5a3cfc (patch)
treee6bd72d98ce96bd278381f5dccf19793d1e7f874 /irc
parente387925fc190c764467c6faa05be373057c82c1d (diff)
downloadports-9520ebb4931841f515ac2236cd461ab1db5a3cfc.tar.gz
ports-9520ebb4931841f515ac2236cd461ab1db5a3cfc.zip
Notes
Diffstat (limited to 'irc')
-rw-r--r--irc/p5-POE-Component-IRC-Plugin-POE-Knee/Makefile16
-rw-r--r--irc/p5-POE-Component-IRC-Plugin-POE-Knee/pkg-plist3
2 files changed, 10 insertions, 9 deletions
diff --git a/irc/p5-POE-Component-IRC-Plugin-POE-Knee/Makefile b/irc/p5-POE-Component-IRC-Plugin-POE-Knee/Makefile
index 4efd536e0539..dac534df5930 100644
--- a/irc/p5-POE-Component-IRC-Plugin-POE-Knee/Makefile
+++ b/irc/p5-POE-Component-IRC-Plugin-POE-Knee/Makefile
@@ -17,16 +17,18 @@ BUILD_DEPENDS= p5-Math-Random>=0.69:${PORTSDIR}/math/p5-Math-Random \
RUN_DEPENDS:= ${BUILD_DEPENDS}
PLIST_SUB= EXAMPLESDIR="share/examples/${PORTNAME}"
-USES= perl5
+USES= perl5 shebangfix
USE_PERL5= configure
-MAN3= POE::Component::IRC::Plugin::POE::Knee.3
+OPTIONS_DEFINE= EXAMPLES
+
+PORTEXAMPLES= *
+SHEBANG_FILES= examples/*.pl
+
+.include <bsd.port.options.mk>
-NO_STAGE= yes
post-install:
-.ifndef(NOPORTEXAMPLES)
- @${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_SCRIPT} ${WRKSRC}/examples/* ${EXAMPLESDIR}
-.endif
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/examples/* ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>
diff --git a/irc/p5-POE-Component-IRC-Plugin-POE-Knee/pkg-plist b/irc/p5-POE-Component-IRC-Plugin-POE-Knee/pkg-plist
index 635cb6388816..b4e37c0ed141 100644
--- a/irc/p5-POE-Component-IRC-Plugin-POE-Knee/pkg-plist
+++ b/irc/p5-POE-Component-IRC-Plugin-POE-Knee/pkg-plist
@@ -1,7 +1,6 @@
%%SITE_PERL%%/POE/Component/IRC/Plugin/POE/Knee.pm
%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/IRC/Plugin/POE/Knee/.packlist
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/synopsis.pl
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
+%%PERL5_MAN3%%/POE::Component::IRC::Plugin::POE::Knee.3.gz
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/IRC/Plugin/POE/Knee
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/IRC/Plugin/POE
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/IRC/Plugin