aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2000-09-01 02:51:06 +0000
committerKevin Lo <kevlo@FreeBSD.org>2000-09-01 02:51:06 +0000
commitab510e8212963f4eb0af5f00ed7c14747796080c (patch)
tree364251c928e209077ea420cea3ce8bb8da3f63a3 /irc
parent255e02d571fcb905d43e1b75ac8163239c97f702 (diff)
downloadports-ab510e8212963f4eb0af5f00ed7c14747796080c.tar.gz
ports-ab510e8212963f4eb0af5f00ed7c14747796080c.zip
Notes
Diffstat (limited to 'irc')
-rw-r--r--irc/bitchx/Makefile43
-rw-r--r--irc/bitchx/distinfo3
-rw-r--r--irc/bitchx/pkg-plist13
3 files changed, 41 insertions, 18 deletions
diff --git a/irc/bitchx/Makefile b/irc/bitchx/Makefile
index b57e1f0b511b..101f9124b4fd 100644
--- a/irc/bitchx/Makefile
+++ b/irc/bitchx/Makefile
@@ -6,13 +6,10 @@
#
PORTNAME= BitchX
-PORTVERSION= 1.0c16
+PORTVERSION= 1.0c17
CATEGORIES= irc gnome
MASTER_SITES= ftp://ftp.bitchx.com/pub/BitchX/source/ \
ftp://ftp.bitchx.org/pub/BitchX/source/ \
- ftp://ukug.uk.freebsd.org/pub/lord_cj/
-PATCH_SITES= ftp://ftp.bitchx.org/pub/BitchX/source/
-PATCHFILES= 1.0c16-format.patch
MAINTAINER= cj@vallcom.net
@@ -20,7 +17,6 @@ MAINTAINER= cj@vallcom.net
LIB_DEPENDS= gnome.4:${PORTSDIR}/x11/gnomelibs
.endif
-PATCH_DIST_ARGS= -d ${WRKSRC}/source --forward --quiet -E ${PATCH_DIST_STRIP}
GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
WRKSRC= ${WRKDIR}/BitchX
@@ -31,8 +27,11 @@ CONFIGURE_ARGS+= --with-gtk --enable-sound
.else
CONFIGURE_ARGS+= --without-gtk
.endif
+.if defined(WITH_ESD)
+CONFIGURE_ARGS+= --with-gtk --enable-sound
+.endif
.if defined(WITH_PLUGINS)
-CONFIGURE_ARGS+= --with-plugins
+CONFIGURE_ARGS+= --with-plugins=pkga,possum,encrypt,hint,abot,acro,amp,blowfish,scan,wavplay,qmail,fserv,nap,qbx
.else
CONFIGURE_ARGS+= --without-plugins
.endif
@@ -50,21 +49,30 @@ MAKE_ENV+= INSTALL_PROGRAM="${INSTALL_PROGRAM}" \
.if !defined(WITH_GNOME)
pre-extract:
- @${ECHO} "You can add hooks for GNOME by defining WITH_GNOME"
- @${ECHO} "If you want to build the plugins define WITH_PLUGINS"
+ @${ECHO} "Define WITH_GNOME if you want to build GTK BitchX"
+.endif
+.if !defined(WITH_ESD)
+ @${ECHO} "Define WITH_ESD for ESD sound support in GTK BitchX"
+.endif
+.if !defined(WITH_PLUGINS)
+ @${ECHO} "Define WITH_PLUGINS if you wish to build the plugins"
+.endif
+.if !defined(WITH_LATIN)
+ @${ECHO} "Define WITH_LATIN if you are using an ISO-8859-1 screenfont"
+.endif
+.if defined(WITH_LATIN)
+pre-patch:
+ @${PERL} -pi -e "s!#undef LATIN1!#define LATIN1!" ${WRKSRC}/include/config.h
.endif
-
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/bx/help
${MKDIR} ${PREFIX}/share/doc/bitchx
- ${CP} -r ${WRKSRC}/bitchx-docs/* ${PREFIX}/share/bx/help
+ ${TAR} --directory ${WRKSRC}/bitchx-docs -cf - . --exclude CVS | \
+ ${TAR} --directory ${PREFIX}/share/bx/help -xf -
${INSTALL_DATA} ${WRKSRC}/doc/bxfaq.html ${PREFIX}/share/doc/bitchx
.endif
-.if defined(WITH_GNOME)
- @${ECHO} bin/gtkBitchX >> ${TMPPLIST}
- @${ECHO} bin/gtkBitchX-1.0c16 >> ${TMPPLIST}
- @${ECHO} share/bx/plugins/nicklist.so >> ${TMPPLIST}
+
.if defined(WITH_PLUGINS)
@${ECHO} share/bx/plugins/BitchX.hints >> ${TMPPLIST}
@${ECHO} share/bx/plugins/acro.so >> ${TMPPLIST}
@@ -81,11 +89,14 @@ post-install:
@${ECHO} share/bx/plugins/scan.so >> ${TMPPLIST}
@${ECHO} share/bx/plugins/wavplay.so >> ${TMPPLIST}
@${ECHO} share/bx/plugins/qbx.so >> ${TMPPLIST}
- @${ECHO} share/bx/plugins/plugins >> ${TMPPLIST}
+ @${ECHO} @dirrm share/bx/plugins >> ${TMPPLIST}
.endif
+.if defined(WITH_GNOME)
+ @${ECHO} bin/gtkBitchX >> ${TMPPLIST}
+ @${ECHO} bin/gtkBitchX-1.0c17 >> ${TMPPLIST}
.else
@${ECHO} bin/BitchX >> ${TMPPLIST}
- @${ECHO} bin/BitchX-1.0c16 >> ${TMPPLIST}
+ @${ECHO} bin/BitchX-1.0c17 >> ${TMPPLIST}
@${ECHO} bin/scr-bx >> ${TMPPLIST}
@${ECHO} share/bx/wserv >> ${TMPPLIST}
.endif
diff --git a/irc/bitchx/distinfo b/irc/bitchx/distinfo
index f5a448ff5134..fe05cde5ca6e 100644
--- a/irc/bitchx/distinfo
+++ b/irc/bitchx/distinfo
@@ -1,2 +1 @@
-MD5 (BitchX-1.0c16.tar.gz) = 4a3749c0b2da2b157eaa13b5b8856511
-MD5 (1.0c16-format.patch) = aef06ac2c892327da6397a82b8b10b3f
+MD5 (BitchX-1.0c17.tar.gz) = 4ab094ae58f0bacb14c3e480404215fd
diff --git a/irc/bitchx/pkg-plist b/irc/bitchx/pkg-plist
index 781a52888a6c..16e55977c1c5 100644
--- a/irc/bitchx/pkg-plist
+++ b/irc/bitchx/pkg-plist
@@ -598,6 +598,7 @@ share/bx/help/5_Programming/assign
share/bx/help/5_Programming/loadtcl
share/bx/help/5_Programming/saveirc
share/bx/help/5_Programming/loaddll
+share/bx/help/5_Programming/fec
share/bx/help/6_Functions/absstrlen
share/bx/help/6_Functions/addtabkey
share/bx/help/6_Functions/after
@@ -782,6 +783,13 @@ share/bx/help/6_Functions/write
share/bx/help/6_Functions/6_Functions
share/bx/help/6_Functions/writeb
share/bx/help/6_Functions/menucontrol
+share/bx/help/6_Functions/before
+share/bx/help/6_Functions/chr
+share/bx/help/6_Functions/getopt
+share/bx/help/6_Functions/ifindfirst
+share/bx/help/6_Functions/listarray
+share/bx/help/6_Functions/strchr
+share/bx/help/6_Functions/strrchr
share/bx/help/7_Docs/About_BitchX
share/bx/help/7_Docs/Arrays
share/bx/help/7_Docs/Command_Line
@@ -898,6 +906,10 @@ share/bx/help/8_Scripts/webster
share/bx/help/8_Scripts/2.8script
share/bx/help/8_Scripts/window
share/bx/help/README_FIRST
+share/bx/help/commands
+share/bx/help/findcomm
+share/bx/help/functions
+share/bx/help/out
share/bx/script/actplug.gmz
share/bx/script/bxglobal
share/bx/script/bxtcl.tcl
@@ -905,6 +917,7 @@ share/bx/script/file.tcl
share/bx/script/fserve+vfs.tar.gz
share/bx/script/menu.bx
share/bx/script/example-.bitchxrc
+share/bx/script/query.bx
share/bx/translation/ASCII
share/bx/translation/CP437
share/bx/translation/CP850