aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-08-15 17:26:17 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-08-15 17:26:17 +0000
commitafe52ead94150b64feb03710de67117f1d01ff84 (patch)
treeb6c7a261d1319c320f83dd03a3881069d8a6011b /irc
parent455ce7795fc4c02150f71e9bc5436094afc77361 (diff)
downloadports-afe52ead94150b64feb03710de67117f1d01ff84.tar.gz
ports-afe52ead94150b64feb03710de67117f1d01ff84.zip
Notes
Diffstat (limited to 'irc')
-rw-r--r--irc/xchat-ruby/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/irc/xchat-ruby/Makefile b/irc/xchat-ruby/Makefile
index 5ed19af89720..e10acf2aa636 100644
--- a/irc/xchat-ruby/Makefile
+++ b/irc/xchat-ruby/Makefile
@@ -27,27 +27,25 @@ PORTEXAMPLES= embedify.rb TimerSample.rb JFilter.rb JBanner.rb
OPTIONS_DEFINE= DOCS EXAMPLES
-.include <bsd.port.options.mk>
-
post-patch:
${REINPLACE_CMD} \
-e 's|^RUBY=.*|RUBY=${RUBY}|' \
-e 's|-lruby$$|-l${RUBY_NAME}|' \
-e 's|^ARCHDIR=.*|ARCHDIR=`$$(RUBY) ${FILESDIR}/rubypath.rb`|' \
+ -e '/^CC=/s|gcc|${CC}|' \
+ -e 's|^CFLAGS=|CFLAGS+=|' \
${WRKSRC}/Makefile
do-install:
${MKDIR} ${STAGEDIR}${PREFIX}/lib/xchat/plugins
${INSTALL_PROGRAM} ${WRKSRC}/xchat-ruby.so \
${STAGEDIR}${PREFIX}/lib/xchat/plugins/
-.if ${PORT_OPTIONS:MDOCS}
+
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${DOCSRC}/,} ${STAGEDIR}${DOCSDIR}/
-.endif
-.if ${PORT_OPTIONS:MEXAMPLES}
+
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${PORTEXAMPLES:S,^,${DOCSRC}/*/,} \
${STAGEDIR}${EXAMPLESDIR}/
-.endif
.include <bsd.port.mk>