aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorMakoto Matsushita <matusita@FreeBSD.org>2005-11-11 00:23:25 +0000
committerMakoto Matsushita <matusita@FreeBSD.org>2005-11-11 00:23:25 +0000
commitbfb2d623240b5002358b7c42a99f70561314aeda (patch)
tree1192c63e9431cd84a2c386b6e99a51f96ee3768a /irc
parentcd4d55384b5bb4e8ba7caeea86a184abbfe19fca (diff)
downloadports-bfb2d623240b5002358b7c42a99f70561314aeda.tar.gz
ports-bfb2d623240b5002358b7c42a99f70561314aeda.zip
Notes
Diffstat (limited to 'irc')
-rw-r--r--irc/Makefile1
-rw-r--r--irc/keitairc/Makefile39
-rw-r--r--irc/keitairc/distinfo3
-rw-r--r--irc/keitairc/pkg-descr10
4 files changed, 53 insertions, 0 deletions
diff --git a/irc/Makefile b/irc/Makefile
index 75d1d19f8637..f28403fd4196 100644
--- a/irc/Makefile
+++ b/irc/Makefile
@@ -54,6 +54,7 @@
SUBDIR += irssi-fish
SUBDIR += irssi-scripts
SUBDIR += irssistats
+ SUBDIR += keitairc
SUBDIR += kmyirc
SUBDIR += konversation
SUBDIR += kvirc
diff --git a/irc/keitairc/Makefile b/irc/keitairc/Makefile
new file mode 100644
index 000000000000..5553fe690e6c
--- /dev/null
+++ b/irc/keitairc/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: keitairc
+# Date created: 11 Nov 2005
+# Whom: Makoto Matsushita <matusita@FreeBSD.ORG>
+#
+# $FreeBSD$
+#
+
+PORTNAME= keitairc
+PORTVERSION= 1.29
+CATEGORIES= irc
+MASTER_SITES= http://keitairc.sourceforge.jp/
+DISTNAME= ${PORTNAME}
+EXTRACT_SUFX= #empty
+
+MAINTAINER= matusita@FreeBSD.org
+COMMENT=IRC proxy for mobilephone that have a web interface
+
+RUN_DEPENDS= ${SITE_PERL}/Jcode.pm:${PORTSDIR}/japanese/p5-Jcode \
+ ${SITE_PERL}/POE/Component/IRC.pm:${PORTSDIR}/irc/p5-POE-Component-IRC \
+ ${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI \
+ ${SITE_PERL}/HTTP/Response.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/AppConfig.pm:${PORTSDIR}/devel/p5-AppConfig
+
+PLIST_FILES= bin/keitairc
+
+NO_BUILD= YES
+NO_WRKSUBDIR= YES
+USE_REINPLACE= YES
+EXTRACT_CMD= ${CP}
+EXTRACT_BEFORE_ARGS= -p
+EXTRACT_AFTER_ARGS= ${WRKDIR}
+
+do-patch:
+ ${REINPLACE_CMD} -e "s,^#!/usr/bin/perl$$,#!${PERL}," ${WRKSRC}/keitairc
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/keitairc ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/irc/keitairc/distinfo b/irc/keitairc/distinfo
new file mode 100644
index 000000000000..a78fda641d8c
--- /dev/null
+++ b/irc/keitairc/distinfo
@@ -0,0 +1,3 @@
+MD5 (keitairc) = 8a291b82d942a08379c50357e9545028
+SHA256 (keitairc) = 3a383d868db214c2be77beb87a19e6c701ea321caaef3b27150e147dcedb1127
+SIZE (keitairc) = 15781
diff --git a/irc/keitairc/pkg-descr b/irc/keitairc/pkg-descr
new file mode 100644
index 000000000000..e48c99c269e8
--- /dev/null
+++ b/irc/keitairc/pkg-descr
@@ -0,0 +1,10 @@
+Keitairc is an simple IRC client that have a web interface designed for
+not-so-rich web client such as mobilephone. There are several features
+for mobilephone access:
+
+ - Quick: web accesskeys.
+ - Link: Convert PSID and URL strings to a link.
+ - Security: user/pass and "EZweb ID" authentication.
+ - Convenient: cookie authentication for next use.
+
+WWW: http://keitairc.sourceforge.jp/