aboutsummaryrefslogtreecommitdiff
path: root/japanese/a2ps
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2013-05-01 06:19:25 +0000
committerHiroki Sato <hrs@FreeBSD.org>2013-05-01 06:19:25 +0000
commitb0480820036106ac9445beff75d147d8afe5bdc3 (patch)
treebd66ca210bdba208b2d3eb2b9c269e2d3f392b0b /japanese/a2ps
parent918595d20764fc9520fbc1ffef9da3da6847c948 (diff)
downloadports-b0480820036106ac9445beff75d147d8afe5bdc3.tar.gz
ports-b0480820036106ac9445beff75d147d8afe5bdc3.zip
- Add paperconf(1) support for the default paper size configuration.
- Fix pathname of perl(1). - Trim old-style header. - Add LICENSE.
Notes
Notes: svn path=/head/; revision=316989
Diffstat (limited to 'japanese/a2ps')
-rw-r--r--japanese/a2ps/Makefile22
-rw-r--r--japanese/a2ps/files/patch-a2ps-j (renamed from japanese/a2ps/files/patch-aa)29
2 files changed, 34 insertions, 17 deletions
diff --git a/japanese/a2ps/Makefile b/japanese/a2ps/Makefile
index 85e0e98ceab3..41935e4d1b24 100644
--- a/japanese/a2ps/Makefile
+++ b/japanese/a2ps/Makefile
@@ -1,29 +1,35 @@
-# New ports collection makefile for: a2ps-j
-# Date created: 16 Nov 1996
-# Whom: SAITO Itsuro <saito@miv.t.u-tokyo.ac.jp>
-#
+# Created by: SAITO Itsuro <saito@miv.t.u-tokyo.ac.jp>
# $FreeBSD$
-#
PORTNAME= a2ps
PORTVERSION= 1.45
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= japanese print
MASTER_SITES= ftp://ftp.sra.co.jp/pub/lang/perl/sra-scripts/ \
${MASTER_SITE_LOCAL:S|%SUBDIR%|tota/a2ps|}
DISTNAME= ${PORTNAME}.pl-${PORTVERSION}
EXTRACT_SUFX= # empty
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= hrs@FreeBSD.org
COMMENT= Text file to postscript converter (with Japanese support)
+LICENSE= BSD
+
+RUN_DEPENDS= paperconf:${PORTSDIR}/print/libpaper
+
PLIST_FILES= bin/a2ps-j
-EXTRACT_CMD= ${CP}
+EXTRACT_CMD= ${INSTALL_SCRIPT}
EXTRACT_BEFORE_ARGS= # empty
EXTRACT_AFTER_ARGS= a2ps-j
NO_WRKSUBDIR= yes
NO_BUILD= yes
+post-patch:
+ ${REINPLACE_CMD} \
+ -e 's,%%PERL%%,${PERL},' \
+ -e 's,%%LOCALBASE%%,${LOCALBASE},' \
+ ${WRKDIR}/a2ps-j
+
do-install:
${INSTALL_SCRIPT} ${WRKDIR}/a2ps-j ${PREFIX}/bin
diff --git a/japanese/a2ps/files/patch-aa b/japanese/a2ps/files/patch-a2ps-j
index 2d8151ff15e4..f67f9da53392 100644
--- a/japanese/a2ps/files/patch-aa
+++ b/japanese/a2ps/files/patch-a2ps-j
@@ -1,12 +1,23 @@
---- a2ps-j.orig 2011-09-19 17:05:32.000000000 +0900
-+++ a2ps-j 2012-08-07 08:58:02.000000000 -0400
+--- a2ps-j.orig 2013-05-01 15:12:22.000000000 +0900
++++ a2ps-j 2013-05-01 15:12:32.000000000 +0900
@@ -1,4 +1,4 @@
-#!/usr/local/bin/perl
-+#!/usr/bin/perl
++#!%%PERL%%
;#
;# a2ps: ascii to ps
;#
-@@ -56,9 +56,12 @@
+@@ -51,14 +51,23 @@
+ @mon{@mon} = ($[ .. $#mon);
+ @day{@day} = ($[ .. $#day);
+
++my $LIBPAPER = 1;
++if ($LIBPAPER) {
++ $default_paper = `%%LOCALBASE%%/bin/paperconf -n`;
++ chomp($default_paper);
++}
++@param_letter = ( 8.50, 11.06, 0.65, 1.2, 6.85, 9.5, 0.29, 0.22, 0.12, 'letter');
+ @param_us = ( 8.50, 11.06, 0.65, 1.2, 6.85, 9.5, 0.29, 0.22, 0.12, 'letter');
+ @param_a4 = ( 8.27, 11.64, 1.20, 1.2, 6.60, 9.8, 0.29, 0.22, 0.05, 'a4');
@param_b4 = (10.15, 14.31, 1.40, 1.2, 8.50, 9.5, 0.29, 0.22, 0.08, 'b4');
sub paper {
local(*param) = 'param_' . $_[0];
@@ -20,7 +31,7 @@
}
&paper($default_paper);
-@@ -192,7 +195,8 @@
+@@ -192,7 +201,8 @@
if ($debug == 2) {
require('dumpvar.pl');
@@ -30,7 +41,7 @@
&dumpvar('main',
'width', 'height', 'lmargin', 'smargin', 'font_size',
'sheet_height', 'sheet_width', 'char_width', 'skip_column',
-@@ -208,8 +212,14 @@
+@@ -208,8 +218,14 @@
$file = shift;
if ($file && !-r $file) { warn "$file: $!\n"; next; }
if ($jisconvert) {
@@ -47,7 +58,7 @@
open(F, "-|") || &jis($file);
} else {
$file = '-' if $file eq '';
-@@ -476,10 +486,13 @@
+@@ -476,10 +492,13 @@
}
sub print_header {
@@ -63,7 +74,7 @@
local($orientation) = $portrait ? "Portrait" : "Landscape";
print <<"---";
-@@ -525,7 +538,8 @@
+@@ -525,7 +544,8 @@
printf("/lines %d def\n", $linesperpage);
printf("/columns %d def\n", $columnsperline);
$sublabel = $default_sublabel unless defined $sublabel;
@@ -73,7 +84,7 @@
if ($ascii_mag) {
printf("/doasciimag true def /asciimagsize %f def\n", $ascii_mag);
} else {
-@@ -548,7 +562,8 @@
+@@ -548,7 +568,8 @@
print "%%EndProlog\n\n";
}