aboutsummaryrefslogtreecommitdiff
path: root/japanese/anthy
diff options
context:
space:
mode:
authorMANTANI Nobutaka <nobutaka@FreeBSD.org>2020-08-24 12:52:34 +0000
committerMANTANI Nobutaka <nobutaka@FreeBSD.org>2020-08-24 12:52:34 +0000
commit2ebecfc0e444a31850a8820c268a3c4563695086 (patch)
tree1ac1d1279276acbd9def28012f7758b35d0e93ee /japanese/anthy
parentc57a1d5d28942f108c9e579af488645b8179c38d (diff)
downloadports-2ebecfc0e444a31850a8820c268a3c4563695086.tar.gz
ports-2ebecfc0e444a31850a8820c268a3c4563695086.zip
Fix breakage of anthy.el with emacs27.
PR: 248876 Submitted by: nyan
Notes
Notes: svn path=/head/; revision=546077
Diffstat (limited to 'japanese/anthy')
-rw-r--r--japanese/anthy/Makefile2
-rw-r--r--japanese/anthy/files/patch-src-util_anthy.el11
2 files changed, 12 insertions, 1 deletions
diff --git a/japanese/anthy/Makefile b/japanese/anthy/Makefile
index b3e8e8cdfd2a..f25f8c903449 100644
--- a/japanese/anthy/Makefile
+++ b/japanese/anthy/Makefile
@@ -3,7 +3,7 @@
PORTNAME= anthy
PORTVERSION= 0.4
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 1
CATEGORIES= japanese
MASTER_SITES= DEBIAN
diff --git a/japanese/anthy/files/patch-src-util_anthy.el b/japanese/anthy/files/patch-src-util_anthy.el
new file mode 100644
index 000000000000..b2052a38b369
--- /dev/null
+++ b/japanese/anthy/files/patch-src-util_anthy.el
@@ -0,0 +1,11 @@
+--- src-util/anthy.el.orig 2019-07-05 02:37:13 UTC
++++ src-util/anthy.el
+@@ -745,7 +745,7 @@
+ (if anthy-agent-process
+ (kill-process anthy-agent-process))
+ (setq anthy-agent-process proc)
+- (process-kill-without-query proc)
++ (set-process-query-on-exit-flag proc nil)
+ (if anthy-xemacs
+ (if (coding-system-p (find-coding-system 'euc-japan))
+ (set-process-coding-system proc 'euc-japan 'euc-japan))