aboutsummaryrefslogtreecommitdiff
path: root/japanese/canna-lib
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-06-28 11:51:05 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-06-28 11:51:05 +0000
commit932db7c46c9a269808dfa67ea02746b350c194d8 (patch)
tree5182ef394eeef9bff78abf27f4a3a05f7fb8ff43 /japanese/canna-lib
parentb9b5e71f19dfde1a969d42e0660cc786432b3500 (diff)
downloadports-932db7c46c9a269808dfa67ea02746b350c194d8.tar.gz
ports-932db7c46c9a269808dfa67ea02746b350c194d8.zip
New USES imake to handle the dependency on imake.
This uses accept 'env' as an argument for ports that do use their own or a different do-configure target. Modify xmkmf so it accept IMAKECPPFLAGS as default flags for imake and pass it to the called imake. Modify xorg-cf-files (the FreeBSD.cf configuration file) to allow CppCmd to be overwritten. Pass CppCmd CcCmd and CplusplusCmd via command line to each call of imake via IMAKECPPFLAGS Pass IMAKE_DEFINE with the above arguments to MAKE_ARGS so that imake spawned from Makefile generated by a previous imake also inherit the defined CppCmd CcCmd and CplusplusCmd. Make imake use devel/tradcpp all the time, so that when buidling with clang we do not depend on gcc's cpp. Make imake respect CC and CXX Make imake respect USE_GCC (if set imake will use gcc's cpp). While here: - Remove a couple of indefinite articles from comments - Trim headers - Fix a couple of ports to build with clang or use: USE_GCC=any - Fix a now useless redefinition of the extraction chain - Fix a typo in japanese/Wnn7-lib bundled imake template definitions - Fix some XMKMF execution with no env specified - Use options helper in x11/xautolock to simplify the port
Notes
Notes: svn path=/head/; revision=321957
Diffstat (limited to 'japanese/canna-lib')
-rw-r--r--japanese/canna-lib/Makefile12
1 files changed, 3 insertions, 9 deletions
diff --git a/japanese/canna-lib/Makefile b/japanese/canna-lib/Makefile
index c352ed792fae..7dcefd6fd578 100644
--- a/japanese/canna-lib/Makefile
+++ b/japanese/canna-lib/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: canna-lib
-# Date created: 7 September 2008
-# Whom: hrs
-#
+# Created by: hrs
# $FreeBSD$
-#
PORTNAME= canna
PORTVERSION= 3.7p3
@@ -17,9 +13,9 @@ DISTNAME= Canna${PORTVERSION:S/.//g}
MAINTAINER= hrs@FreeBSD.org
COMMENT= A Kana-to-Kanji conversion system, library part
+USES= imake
USE_BZIP2= yes
USE_GCC= any
-USE_IMAKE= yes
USE_LDCONFIG= yes
NO_INSTALL_MANPAGES=yes
MAKE_JOBS_UNSAFE= yes
@@ -28,12 +24,10 @@ PLIST_SUB= METAFILE="${METAFILE}" \
ALL_TARGET= canna
INSTALL_TARGET= instsgs
+XMKMF= xmkmf
METAFILE= ${DATADIR_REL}/canna-lib-dic.meta
-post-configure:
- @cd ${CONFIGURE_WRKSRC} && ${SETENV} ${MAKE_ENV} ${XMKMF}
-
post-install:
${MTREE_CMD} -cdink uname,gname,mode,nochange \
-p ${DATADIR}/dic > ${PREFIX}/${METAFILE}