aboutsummaryrefslogtreecommitdiff
path: root/japanese/cp5022x-el
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2019-03-17 17:48:43 +0000
committerHiroki Sato <hrs@FreeBSD.org>2019-03-17 17:48:43 +0000
commit5929a12a9e7da95f65701d4c8cf67a02d764aebd (patch)
tree3de697b184fb7dd23649157f5d65c21994908202 /japanese/cp5022x-el
parent9f03f6f2c90540c437d8b76a613bc63fc9a55159 (diff)
downloadports-5929a12a9e7da95f65701d4c8cf67a02d764aebd.tar.gz
ports-5929a12a9e7da95f65701d4c8cf67a02d764aebd.zip
Notes
Diffstat (limited to 'japanese/cp5022x-el')
-rw-r--r--japanese/cp5022x-el/Makefile34
-rw-r--r--japanese/cp5022x-el/distinfo3
-rw-r--r--japanese/cp5022x-el/pkg-descr24
-rw-r--r--japanese/cp5022x-el/pkg-message4
4 files changed, 65 insertions, 0 deletions
diff --git a/japanese/cp5022x-el/Makefile b/japanese/cp5022x-el/Makefile
new file mode 100644
index 000000000000..b5974d40b71c
--- /dev/null
+++ b/japanese/cp5022x-el/Makefile
@@ -0,0 +1,34 @@
+# $FreeBSD$
+
+PORTNAME= cp5022x
+PORTVERSION= 0.0.20120324
+CATEGORIES= japanese elisp
+PKGNAMESUFFIX= -el${EMACS_PKGNAMESUFFIX}
+
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= CP50220 and CP51932 coding system support for Emacsen
+
+LICENSE= GPLv3+
+
+USES= emacs
+USE_GITHUB= yes
+GH_ACCOUNT= awasira
+GH_PROJECT= cp5022x.el
+GH_TAGNAME= ea7327d
+
+PLIST_FILES= ${EMACS_SITE_LISPDIR}/cp5022x.el.gz \
+ ${EMACS_SITE_LISPDIR}/cp5022x.elc
+
+do-build:
+ cd ${BUILD_WRKSRC} && \
+ ${EMACS_CMD} -batch -q -no-site-file -no-init-file \
+ -f batch-byte-compile cp5022x.el && \
+ ${GZIP_CMD} cp5022x.el
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/${EMACS_SITE_LISPDIR} && \
+ cd ${INSTALL_WRKSRC} && \
+ ${INSTALL_DATA} cp5022x.elc cp5022x.el.gz \
+ ${STAGEDIR}${PREFIX}/${EMACS_SITE_LISPDIR}
+
+.include <bsd.port.mk>
diff --git a/japanese/cp5022x-el/distinfo b/japanese/cp5022x-el/distinfo
new file mode 100644
index 000000000000..af5fd9bb0cf2
--- /dev/null
+++ b/japanese/cp5022x-el/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1552833497
+SHA256 (awasira-cp5022x.el-0.0.20120324-ea7327d_GH0.tar.gz) = e9c96b8ad70475cb05dae56dae28d4ffaee92d036b534e42ef8c0a3e646a0912
+SIZE (awasira-cp5022x.el-0.0.20120324-ea7327d_GH0.tar.gz) = 2633
diff --git a/japanese/cp5022x-el/pkg-descr b/japanese/cp5022x-el/pkg-descr
new file mode 100644
index 000000000000..0398b292ccdf
--- /dev/null
+++ b/japanese/cp5022x-el/pkg-descr
@@ -0,0 +1,24 @@
+cp5022x.el adds supprot for encodings with platform dependent characters
+used in Microsoft Windows. It defines CP50220, CP50221, CP50222, and
+CP51932. Specifications on Emacsen are as follows:
+
+CP51932 (Microsoft euc-jp)
+Type: iso-2022 (variant of ISO-2022)
+Initial designations:
+ G0 -- ascii:ASCII (ISO646 IRV)
+ G1 -- japanese-jisx0208:JISX0208.1983/1990 Japanese Kanji: ISO-IR-87
+ G2 -- katakana-jisx0201:Katakana Part of JISX0201.1976
+ G3 -- never used
+
+CP50220 (Microsoft iso-2022-jp for mail)
+Type: iso-2022 (variant of ISO-2022)
+Initial designations:
+ G0 -- ascii:ASCII (ISO646 IRV), and also used by the following:
+ japanese-jisx0208-1978:JISX0208.1978 Japanese Kanji
+ (so called "old JIS"): ISO-IR-42
+ japanese-jisx0208:JISX0208.1983/1990 Japanese Kanji: ISO-IR-87
+ latin-jisx0201:Roman Part of JISX0201.1976
+ katakana-jisx0201:Katakana Part of JISX0201.1976
+ G1 -- never used
+ G2 -- never used
+ G3 -- never used
diff --git a/japanese/cp5022x-el/pkg-message b/japanese/cp5022x-el/pkg-message
new file mode 100644
index 000000000000..0e0345a51ee1
--- /dev/null
+++ b/japanese/cp5022x-el/pkg-message
@@ -0,0 +1,4 @@
+This elisp supports CP50220 and CP51932 as coding-system. Add the following
+line to ~/.emacs to activate it:
+
+(require 'cp5022x)