aboutsummaryrefslogtreecommitdiff
path: root/japanese/ebnetd
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1999-08-19 10:50:30 +0000
committerSatoshi Asami <asami@FreeBSD.org>1999-08-19 10:50:30 +0000
commit7810fb706b7a23be4c0ba0df0c3eac8aa3b3d172 (patch)
tree7e0475b3b0285bf94c178e763590639b372a1727 /japanese/ebnetd
parentc6cace87c28b68e3981186743ad173a70d9b6637 (diff)
downloadports-7810fb706b7a23be4c0ba0df0c3eac8aa3b3d172.tar.gz
ports-7810fb706b7a23be4c0ba0df0c3eac8aa3b3d172.zip
Notes
Diffstat (limited to 'japanese/ebnetd')
-rw-r--r--japanese/ebnetd/Makefile40
-rw-r--r--japanese/ebnetd/distinfo2
-rw-r--r--japanese/ebnetd/files/ndtpd.sh.sample15
-rw-r--r--japanese/ebnetd/pkg-descr5
-rw-r--r--japanese/ebnetd/pkg-install143
-rw-r--r--japanese/ebnetd/pkg-message11
-rw-r--r--japanese/ebnetd/pkg-plist21
7 files changed, 115 insertions, 122 deletions
diff --git a/japanese/ebnetd/Makefile b/japanese/ebnetd/Makefile
index 69d6fae290e9..2aeab8baf450 100644
--- a/japanese/ebnetd/Makefile
+++ b/japanese/ebnetd/Makefile
@@ -1,37 +1,49 @@
# New ports collection makefile for: ndtpd
-# Version required: 2.2
+# Version required: 2.3.2
# Date created: 4 Aug 1998
# Whom: Motoyuki Kasahara <m-kasahr@sra.co.jp>
#
-# $Id: Makefile,v 1.7 1999/03/15 13:00:35 taoka Exp $
+# $Id: Makefile,v 1.8 1999/06/05 22:30:04 mharo Exp $
#
-DISTNAME= ndtpd-2.2.2
-PKGNAME= ja-ndtpd-2.2.2
+DISTNAME= ndtpd-2.3.2
+PKGNAME= ja-ndtpd-2.3.2
CATEGORIES= japanese
MASTER_SITES= ftp://ftp.sra.co.jp/pub/net/ndtp/ndtpd/ \
- ftp://ftp.sra.co.jp/pub/net/ndtp/ndtpd/old/
+ ftp://ftp.sra.co.jp/pub/net/ndtp/ndtpd/old/ \
+ ftp://ftp.mei.co.jp/free/others/Dictionary/ndtp/ndtpd/
MAINTAINER= takamune@avrl.mei.co.jp
-LIB_DEPENDS= eb.2:${PORTSDIR}/japanese/eb
+LIB_DEPENDS= eb.3:${PORTSDIR}/japanese/eb
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --localstatedir=/var --with-eb --with-zlib \
+USE_LIBTOOL= yes
+CONFIGURE_ARGS= --localstatedir=${VARDIR} --with-eb --with-zlib \
--with-eb-includes=${PREFIX}/include \
--with-eb-libraries=${PREFIX}/lib
-
CONFIGURE_ENV= INSTALL_SCRIPT="${INSTALL_SCRIPT}" \
INSTALL_DATA="${INSTALL_DATA}"
+
.if !defined(PACKAGE_BUILDING)
IS_INTERACTIVE= Maybe_interactive_at_install_stage
.endif
+PLIST_SUB= VARDIR=${VARDIR} OWNER=${OWNER} GROUP=${GROUP} MODE=${MODE}
+
+# Local variables
+VARDIR= /var
+OWNER= nobody
+GROUP= nogroup
+MODE= 755
+STARTUP_SCRIPT= ndtpd.sh.sample
+INSTALL_DIR= ${INSTALL} -d -o ${OWNER} -g ${GROUP} -m ${MODE}
post-install:
-.for info in ndtpd ndtpd-ja
- install-info ${PREFIX}/info/${info}.info ${PREFIX}/info/dir
-.endfor
- @${SETENV} PKG_PREFIX=${PREFIX} IS_INTERACTIVE="${IS_INTERACTIVE}" \
- ${SH} ${PKGDIR}/INSTALL ${PKGNAME} POST-INSTALL
+ ${SED} "s,@prefix@,${PREFIX}," ${FILESDIR}/${STARTUP_SCRIPT} \
+ > ${WRKDIR}/${STARTUP_SCRIPT}
+ ${INSTALL_SCRIPT} ${WRKDIR}/${STARTUP_SCRIPT} ${PREFIX}/etc/rc.d
+ ${INSTALL_DIR} ${VARDIR}/ndtpd
+ @${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+ @${ECHO}
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/japanese/ebnetd/distinfo b/japanese/ebnetd/distinfo
index 3099e77efaa1..f7c10723d41f 100644
--- a/japanese/ebnetd/distinfo
+++ b/japanese/ebnetd/distinfo
@@ -1 +1 @@
-MD5 (ndtpd-2.2.2.tar.gz) = 9d902305fb3b4860b1a2896025651022
+MD5 (ndtpd-2.3.2.tar.gz) = c189248feffbbe5e61b2ecece3a355ea
diff --git a/japanese/ebnetd/files/ndtpd.sh.sample b/japanese/ebnetd/files/ndtpd.sh.sample
new file mode 100644
index 000000000000..17a62fc0aab8
--- /dev/null
+++ b/japanese/ebnetd/files/ndtpd.sh.sample
@@ -0,0 +1,15 @@
+#!/bin/sh -
+#
+# NDTPD: rc-file for FreeBSD.
+#
+
+### NDTPD options: ###
+ndtpd_program=@prefix@/sbin/ndtpd # path to ndtpd.
+ndtpd_enable=YES # Run ndtpd (or NO).
+ndtpd_flags= # Flags to ndtpd (if enabled).
+### End of NDTPD options: ###
+
+if [ "x${ndtpd_enable}" = xYES -a -x ${ndtpd_program} ]; then
+ echo -n " ndtpd"
+ ${ndtpd_program} ${ndtpd_flags}
+fi
diff --git a/japanese/ebnetd/pkg-descr b/japanese/ebnetd/pkg-descr
index 27f6a9a49b75..c62a145acf09 100644
--- a/japanese/ebnetd/pkg-descr
+++ b/japanese/ebnetd/pkg-descr
@@ -7,3 +7,8 @@ stands on the ISO 9660 format, you can mount the discs by the same way
as other ISO 9660 discs.
-- Motoyuki Kasahara <m-kasahr@sra.co.jp>
+
+You can get information about NDTPD from their website.
+WWW: http://www.sra.co.jp/people/m-kasahr/ndtpd/
+
+-- Kazutoki TAKAMUNE <takamune@avrl.mei.co.jp>
diff --git a/japanese/ebnetd/pkg-install b/japanese/ebnetd/pkg-install
index 615702a92151..d29231b3efb6 100644
--- a/japanese/ebnetd/pkg-install
+++ b/japanese/ebnetd/pkg-install
@@ -1,114 +1,61 @@
-#! /bin/sh
+#!/bin/sh -
+# an installation script for ndtpd
-[ "$2" = "POST-INSTALL" ] || exit 0
-[ "X${IS_INTERACTIVE}" != X ] || exit 0
+ask() {
+ local question default answer
-#
-# Make directories under /var.
-#
-[ ! -d /var/ndtpd ] && mkdir /var/ndtpd
-[ ! -d /var/ndtpd/log ] && mkdir /var/ndtpd/log
+ question=$1
+ default=$2
-#
-# Add `ndtp' to /etc/services.
-#
-sed -e 's/#.*//' -e 's/^/ /' -e 's/$/ /g' -e 's/ / /g' /etc/services \
- | grep ' ndtp ' > /dev/null 2>&1
+ if [ -z "${PACKAGE_BUILDING}" ]; then
+ read -p "${question} (y/n) [${default}]? " answer
+ [ "${answer}" ] && default=${answer}
+ fi
+ echo ${default}
+}
-if [ $? -ne 0 ] ; then
- YESNO=YET
- while [ "${YESNO}" = YET ] ; do
- if [ -z "${PACKAGE_BUILDING}" ]; then
- echo -n "May I register the \`ndtp' service name to /etc/services? ([y]/n) "
- read LINE
- else
- LINE=y
- fi
- case "X${LINE}" in
- Xy|XY|X)
- YESNO=YES
- ;;
- Xn|XN)
- YESNO=NO
- ;;
- *)
- echo "Please answer \`y' or \`n'."
- ;;
- esac
- done
+yesno() {
+ local question default
- if [ "${YESNO}" = YES ] ; then
- if grep '[ ]2010/tcp' /etc/services > /dev/null 2>&1 ; then
- cp /etc/services /etc/services.bak
- sed -e 's/\([ ]2010\/tcp\)/\1 ndtp/' /etc/services.bak \
- > /etc/services
- else
- echo 'ndtp 2010/tcp' >> /etc/services
- fi
- echo "The original file is saved as /etc/services.bak."
- echo
- fi
-fi
+ question=$1
+ default=$2
-#
-# Copy a rc-file to `${PKG_PREFIX}/etc/rc.d/ndtpd.sh'.
-#
-if [ -f ${PKG_PREFIX}/etc/rc.d/ndtpd.sh ] ; then
- YESNO=YET
- while [ "${YESNO}" = YET ] ; do
- if [ -z "${PACKAGE_BUILDING}" ]; then
- echo -n "${PKG_PREFIX}/etc/rc.d/ndtpd.sh already exists. May I overwrite it? (y/[n]) "
- read LINE
- else
- LINE=y
- fi
- case "X${LINE}" in
- Xy|XY)
- YESNO=YES
- ;;
- Xn|XN|X)
- YESNO=NO
- ;;
- *)
- echo "Please answer \`y' or \`n'."
- ;;
+ while :; do
+ case `ask "${question}" ${default}` in
+ [Yy]*) return 0;;
+ [Nn]*) return 1;;
esac
+ echo "Please answer yes or no."
done
-else
- YESNO=YES
-fi
+}
+
+[ "$2" = POST-INSTALL ] || exit 0
-if [ "${YESNO}" = YES ] ; then
- sed "s;@prefix@;${PKG_PREFIX};" > ${PKG_PREFIX}/etc/rc.d/ndtpd.sh \
- << '__END__'
-#! /bin/sh
#
-# NDTPD: rc-file for FreeBSD.
+# Add an entry for `ndtp' to /etc/services.
#
+file=/etc/services
+back=${file}.bak
+name=ndtp
+port=2010/tcp
+comment="Network Dictionary Transfer Protocol"
-### NDTPD options: ###
-ndtpd_enable="NO" # Run ndtpd (or NO).
-ndtpd_flags="" # Flags to ndtpd (if enabled).
-### End of NDTPD options: ###
-
-ndtpd="@prefix@/sbin/ndtpd"
-if [ "X${ndtpd_enable}" = X"YES" -a -f ${ndtpd} ]; then
- echo -n " ndtpd"
- ${ndtpd} ${ndtpd_flags}
-fi
-__END__
+echo "************************************************************************"
+if sed 's/#.*//' ${file} | grep -qw ${name}; then
+ echo "This system has already an entry for ${name} in ${file}."
+else
+ echo "This system has no entry for ${name} in ${file}."
+ if yesno " Would you like to add it automatically?" y; then
+ cp -f ${file} ${back}
+ echo " The original file is saved as ${back}."
- chmod 755 ${PKG_PREFIX}/etc/rc.d/ndtpd.sh
- echo
- echo "I put a rc-file to ${PKG_PREFIX}/etc/rc.d/ndtpd.sh, but ndtpd doesn't"
- echo "start through the script. If you want to start ndtpd as standalone"
- echo "daemon through the script, please turn the \`ndtpd_enable' variable"
- echo "in the script to \`YES', and set \`ndtpd_flags' to an appropriate"
- echo "value if required."
- echo ""
- echo "If you want to start ndtpd through inetd, the script is not"
- echo "required."
- echo
+ if sed 's/#.*//' ${file} | grep -qw ${port}; then
+ sed 's,^\([^#]*[ ]'${port}'\),\1 '${name}, ${back} > ${file}
+ else
+ echo "${name} ${port} #${comment}" >> ${file}
+ fi
+ fi
fi
+echo "************************************************************************"
exit 0
diff --git a/japanese/ebnetd/pkg-message b/japanese/ebnetd/pkg-message
new file mode 100644
index 000000000000..20a8420bd04e
--- /dev/null
+++ b/japanese/ebnetd/pkg-message
@@ -0,0 +1,11 @@
+************************************************************************
+ To use `ndtpd', copy a sample configuration file `ndtpd.conf.sample'
+to `ndtpd.conf' in '${PREFIX}/etc' directory, and edit it. Consult the
+"Configuration File" section of info file.
+
+ If you want to start `ndtpd' as a standalone daemon, copy a script
+`ndtpd.sh.sample' to `ndtpd.sh' in '${PREFIX}/etc/rc.d' directory, and
+exec it. Otherwise, to start as a child process of `inetd', edit the
+file `/etc/inetd.conf'. In either case, consult the "Start the Server"
+section of info file.
+************************************************************************
diff --git a/japanese/ebnetd/pkg-plist b/japanese/ebnetd/pkg-plist
index cce8ec65312b..472e54158eaa 100644
--- a/japanese/ebnetd/pkg-plist
+++ b/japanese/ebnetd/pkg-plist
@@ -1,12 +1,15 @@
-sbin/ndtpd
+etc/ndtpd.conf.sample
+etc/rc.d/ndtpd.sh.sample
+@unexec install-info --delete %D/info/ndtpd-ja.info %D/info/dir
+@unexec install-info --delete %D/info/ndtpd.info %D/info/dir
+info/ndtpd-ja.info
+info/ndtpd.info
+@exec install-info %B/ndtpd-ja.info %B/dir
+@exec install-info %B/ndtpd.info %B/dir
+libexec/ndtpstat
sbin/ndtpcheck
sbin/ndtpcontrol
+sbin/ndtpd
sbin/ndtpdaily
-libexec/ndtpstat
-etc/ndtpd.sample
-@unexec install-info --delete %D/info/ndtpd.info %D/info/dir
-@unexec install-info --delete %D/info/ndtpd-ja.info %D/info/dir
-info/ndtpd.info
-info/ndtpd-ja.info
-@exec install-info %D/info/ndtpd.info %D/info/dir
-@exec install-info %D/info/ndtpd-ja.info %D/info/dir
+@exec install -d -o %%OWNER%% -g %%GROUP%% -m %%MODE%% %%VARDIR%%/ndtpd
+@unexec rm -rf %%VARDIR%%/ndtpd