aboutsummaryrefslogtreecommitdiff
path: root/japanese/eijiro-fpw
diff options
context:
space:
mode:
authorSatoshi Taoka <taoka@FreeBSD.org>2000-12-21 06:27:31 +0000
committerSatoshi Taoka <taoka@FreeBSD.org>2000-12-21 06:27:31 +0000
commit52d76f653cc7ec645fa88b129f2f85837f48395c (patch)
tree0f2353b83306b69f6cae0ccbd4be6da24341d6bb /japanese/eijiro-fpw
parente2d6082a718a775eb79529627e5c0853479f014a (diff)
downloadports-52d76f653cc7ec645fa88b129f2f85837f48395c.tar.gz
ports-52d76f653cc7ec645fa88b129f2f85837f48395c.zip
Notes
Diffstat (limited to 'japanese/eijiro-fpw')
-rw-r--r--japanese/eijiro-fpw/Makefile57
-rw-r--r--japanese/eijiro-fpw/distinfo1
-rw-r--r--japanese/eijiro-fpw/files/patch-aa12
-rw-r--r--japanese/eijiro-fpw/pkg-comment1
-rw-r--r--japanese/eijiro-fpw/pkg-descr16
-rw-r--r--japanese/eijiro-fpw/pkg-plist7
6 files changed, 94 insertions, 0 deletions
diff --git a/japanese/eijiro-fpw/Makefile b/japanese/eijiro-fpw/Makefile
new file mode 100644
index 000000000000..ea9c0ed5e3ce
--- /dev/null
+++ b/japanese/eijiro-fpw/Makefile
@@ -0,0 +1,57 @@
+# New ports collection makefile for: EIJIRO Dictionary - JIS X 4081 version
+# Date created: 2000.11.28
+# Whom: Satoshi Taoka <taoka@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= eijiro-fpw
+PORTVERSION= 1.0b
+CATEGORIES= japanese
+MASTER_SITES= http://openlab.ring.gr.jp/edict/fpw/dist/eijiro/
+DISTNAME= ${PORTNAME}${PORTVERSION}-src
+
+MAINTAINER= taoka@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/share/doc/freepwing/fpwutils.mk:${PORTSDIR}/japanese/freepwing \
+ catdump:${PORTSDIR}/japanese/epwutil \
+ nkf:${PORTSDIR}/japanese/nkf \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Jcode.pm:${PORTSDIR}/japanese/p5-Jcode
+
+RESTRICTED= "The original dictionary is not free"
+USE_GMAKE= yes
+WRKSRC= ${WRKDIR}/eijiro-fpw${PORTVERSION}
+DICT_PATH?= /cdrom
+SRCFILE?= EIJI37??.TXT
+MAKE_ENV= PORT_SRCFILE=${DICT_PATH}/${SRCFILE}
+
+post-extract:
+ @if [ ! -f ${DICT_PATH}/${SRCFILE} ]; then \
+ ${ECHO} "###################################################"; \
+ ${ECHO} "I cannot find a file ${DICT_PATH}/${SRCFILE}"; \
+ ${ECHO} "Specify the Eijiro Dictionary file with the full path"; \
+ ${ECHO} "and excecute the following command again:"; \
+ ${ECHO} " make DICT_PATH=${DICT_PATH} SRCFILE=${SRCFILE}"; \
+ ${ECHO} ""; \
+ ${ECHO} "Notice: DICT_PATH must be a full path to the file."; \
+ ${ECHO} "###################################################"; \
+ ${FALSE}; \
+ fi
+ ${CP} ${LOCALBASE}/share/doc/freepwing/fpwutils.mk ${WRKSRC}
+
+post-build:
+ cd ${WRKSRC}; nkf -eSd catalogs.sjis > catalogs.txt; \
+ catdump -u catalogs.txt catalogs
+
+do-install:
+ ${MKDIR} ${PREFIX}/share/dict/eijiro-fpw/eijiro/data
+ ${INSTALL_DATA} ${WRKSRC}/honmon ${PREFIX}/share/dict/eijiro-fpw/eijiro/data
+ ${INSTALL_DATA} ${WRKSRC}/catalogs ${PREFIX}/share/dict/eijiro-fpw
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/eijiro-fpw
+.for i in readme.sjis
+ ${INSTALL_DATA} ${WRKSRC}/$i ${PREFIX}/share/doc/eijiro-fpw
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/japanese/eijiro-fpw/distinfo b/japanese/eijiro-fpw/distinfo
new file mode 100644
index 000000000000..d4681c3e8b85
--- /dev/null
+++ b/japanese/eijiro-fpw/distinfo
@@ -0,0 +1 @@
+MD5 (eijiro-fpw1.0b-src.tar.gz) = fd4da7feb5d7211d651c84ffbe3cc416
diff --git a/japanese/eijiro-fpw/files/patch-aa b/japanese/eijiro-fpw/files/patch-aa
new file mode 100644
index 000000000000..ff9830eae0dc
--- /dev/null
+++ b/japanese/eijiro-fpw/files/patch-aa
@@ -0,0 +1,12 @@
+--- ../orig/eijiro-fpw1.0b/Makefile Sun Oct 8 23:40:55 2000
++++ Makefile Thu Dec 21 12:03:11 2000
+@@ -17,7 +17,8 @@
+ #
+ EIJIROVER = 37
+ SRCDIR = .
+-SRCFILE := $(wildcard ${SRCDIR}/EIJI${EIJIROVER}??.TXT)
++#SRCFILE := $(wildcard ${SRCDIR}/EIJI${EIJIROVER}??.TXT)
++SRCFILE=${PORT_SRCFILE}
+ #SRCFILE = test.txt
+
+ #
diff --git a/japanese/eijiro-fpw/pkg-comment b/japanese/eijiro-fpw/pkg-comment
new file mode 100644
index 000000000000..56800d954391
--- /dev/null
+++ b/japanese/eijiro-fpw/pkg-comment
@@ -0,0 +1 @@
+EIJIRO English - Japanese Dictionary (EPWING V1 format)
diff --git a/japanese/eijiro-fpw/pkg-descr b/japanese/eijiro-fpw/pkg-descr
new file mode 100644
index 000000000000..b9a3b844bf2a
--- /dev/null
+++ b/japanese/eijiro-fpw/pkg-descr
@@ -0,0 +1,16 @@
+Eijiro is a dictionary compiled by E.D.P. For details, such as how to
+obtain the whole data, visit EDP's Web site.
+
+WWW: http://member.nifty.ne.jp/eijiro/
+
+-- E.D.P.
+
+Data in this port are converted from the original dictionary into JIS
+X 4081 format (that is a subset of EPWING V1) by FreePWING. So this
+can be used by EPWING viewers on Unix and the other OS (e.g. Windows
+or MacOS).
+
+o URL for this converted dictionary:
+WWW: http://openlab.ring.gr.jp/edict/fpw/
+
+-- S.TAOKA
diff --git a/japanese/eijiro-fpw/pkg-plist b/japanese/eijiro-fpw/pkg-plist
new file mode 100644
index 000000000000..bdc939216a30
--- /dev/null
+++ b/japanese/eijiro-fpw/pkg-plist
@@ -0,0 +1,7 @@
+share/dict/eijiro-fpw/eijiro/data/honmon
+share/dict/eijiro-fpw/catalogs
+@dirrm share/dict/eijiro-fpw/eijiro/data
+@dirrm share/dict/eijiro-fpw/eijiro
+@dirrm share/dict/eijiro-fpw
+share/doc/eijiro-fpw/readme.sjis
+@dirrm share/doc/eijiro-fpw