aboutsummaryrefslogtreecommitdiff
path: root/japanese/fcitx-skk
diff options
context:
space:
mode:
authorXin LI <delphij@FreeBSD.org>2015-03-31 07:08:00 +0000
committerXin LI <delphij@FreeBSD.org>2015-03-31 07:08:00 +0000
commit1e0f9c5aadd2d4f1f7f5a237c4daaafd77235e75 (patch)
tree78917bf49ceac628433c2677aa29dda7b28d1619 /japanese/fcitx-skk
parent2a2483840ac023d506d79431f88ef146a146edc2 (diff)
downloadports-1e0f9c5aadd2d4f1f7f5a237c4daaafd77235e75.tar.gz
ports-1e0f9c5aadd2d4f1f7f5a237c4daaafd77235e75.zip
Major update to libpinyin, fcitx and their add ons:
- New port: chinese/brise Rime schema repository - Update chinese/fcitx to 4.2.8.5. - Update chinese/fcitx-chewing to 0.2.2. - Update chinese/fcitx-cloudpinyin to 0.3.4. - Update chinese/fcitx-configtool to 0.4.8. - Update chinese/fcitx-libpinyin to 0.3.1. - Update chinese/fcitx-rime to 0.3.1. - Update chinese/fcitx-sunpinyin to 0.4.1. - Update chinese/fcitx-table-extra to 0.3.7. - Add LICENSE and update website (mainly move off Google Code) for various ports. - Update chinese/libpinyin to 1.1.0. - Update chinese/librime to 1.1. - Update chinese/opencc to 0.4.3. - Update japanese/fcitx-anthy to 0.2.1. - New port: japanese/fcitx-skk SKK support for Fcitx - Update korean/fcitx-hangul to 0.3.0. - Update textproc/fcitx-m17n to 0.2.3. PR: ports/198743 Submitted by: maintainer, hiroto.kagotani@gmail.com, delphij
Notes
Notes: svn path=/head/; revision=382798
Diffstat (limited to 'japanese/fcitx-skk')
-rw-r--r--japanese/fcitx-skk/Makefile37
-rw-r--r--japanese/fcitx-skk/distinfo2
-rw-r--r--japanese/fcitx-skk/files/patch-gui__CMakeLists.txt8
-rw-r--r--japanese/fcitx-skk/files/patch-src__CMakeLists.txt8
-rw-r--r--japanese/fcitx-skk/pkg-descr3
-rw-r--r--japanese/fcitx-skk/pkg-plist13
6 files changed, 71 insertions, 0 deletions
diff --git a/japanese/fcitx-skk/Makefile b/japanese/fcitx-skk/Makefile
new file mode 100644
index 000000000000..5f466f8a2ce8
--- /dev/null
+++ b/japanese/fcitx-skk/Makefile
@@ -0,0 +1,37 @@
+# $FreeBSD$
+
+PORTNAME= fcitx-skk
+PORTVERSION= 0.1.1
+CATEGORIES= japanese
+MASTER_SITES= http://download.fcitx-im.org/${PORTNAME}/
+DIST_SUBDIR= fcitx
+
+MAINTAINER= hiroto.kagotani@gmail.com
+COMMENT= SKK support for Fcitx
+
+LICENSE= GPLv3
+
+RUN_DEPENDS= ${LOCALBASE}/share/skk/SKK-JISYO.L:${PORTSDIR}/japanese/skk-jisyo
+LIB_DEPENDS= libfcitx-config.so:${PORTSDIR}/chinese/fcitx \
+ libskk.so:${PORTSDIR}/japanese/libskk
+
+USES= tar:xz compiler:c++11-lang cmake gettext pkgconfig
+INSTALLS_ICONS= yes
+CMAKE_ARGS+= -DSKK_DEFAULT_PATH=${LOCALBASE}/share/skk/SKK-JISYO.L
+
+OPTIONS_DEFINE= QT4
+OPTIONS_DEFAULT=QT4
+QT4_DESC= Enable Qt for GUI configuration
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MQT4}
+USE_QT4= qmake_build moc_build rcc_build uic_build gui
+USE_LDCONFIG= ${PREFIX}/lib/fcitx/qt
+PLIST_SUB+= QT4=""
+.else
+CMAKE_ARGS+= -DENABLE_QT=OFF
+PLIST_SUB+= QT4="@comment "
+.endif
+
+.include <bsd.port.mk>
diff --git a/japanese/fcitx-skk/distinfo b/japanese/fcitx-skk/distinfo
new file mode 100644
index 000000000000..97069bef250d
--- /dev/null
+++ b/japanese/fcitx-skk/distinfo
@@ -0,0 +1,2 @@
+SHA256 (fcitx/fcitx-skk-0.1.1.tar.xz) = 023a1d9b075c02c7e394a689e7b2452a1df1e062b2953892aed7c694fb55591c
+SIZE (fcitx/fcitx-skk-0.1.1.tar.xz) = 31136
diff --git a/japanese/fcitx-skk/files/patch-gui__CMakeLists.txt b/japanese/fcitx-skk/files/patch-gui__CMakeLists.txt
new file mode 100644
index 000000000000..66ccbef34728
--- /dev/null
+++ b/japanese/fcitx-skk/files/patch-gui__CMakeLists.txt
@@ -0,0 +1,8 @@
+--- ./gui/CMakeLists.txt.orig 2013-10-28 01:07:26.000000000 +0900
++++ ./gui/CMakeLists.txt 2014-03-20 13:44:23.000000000 +0900
+@@ -47,4 +47,4 @@
+ ${LIBSKK_LIBRARIES}
+ )
+
+-install(TARGETS fcitx-skk-config DESTINATION ${FCITX4_ADDON_INSTALL_DIR}/qt)
++install(TARGETS fcitx-skk-config DESTINATION ${FCITX4_ADDON_INSTALL_DESTDIR}/qt)
diff --git a/japanese/fcitx-skk/files/patch-src__CMakeLists.txt b/japanese/fcitx-skk/files/patch-src__CMakeLists.txt
new file mode 100644
index 000000000000..2d74a96758b7
--- /dev/null
+++ b/japanese/fcitx-skk/files/patch-src__CMakeLists.txt
@@ -0,0 +1,8 @@
+--- ./src/CMakeLists.txt.orig 2013-10-28 01:07:26.000000000 +0900
++++ ./src/CMakeLists.txt 2014-03-20 13:45:23.000000000 +0900
+@@ -15,4 +15,4 @@
+
+ configure_file(${CMAKE_CURRENT_SOURCE_DIR}/dictionary_list.in ${CMAKE_CURRENT_BINARY_DIR}/dictionary_list @ONLY)
+
+-install(FILES ${CMAKE_CURRENT_BINARY_DIR}/dictionary_list rule DESTINATION "${FCITX4_PREFIX}/share/fcitx/skk")
++install(FILES ${CMAKE_CURRENT_BINARY_DIR}/dictionary_list rule DESTINATION "share/fcitx/skk")
diff --git a/japanese/fcitx-skk/pkg-descr b/japanese/fcitx-skk/pkg-descr
new file mode 100644
index 000000000000..36c6db9a5d7a
--- /dev/null
+++ b/japanese/fcitx-skk/pkg-descr
@@ -0,0 +1,3 @@
+fcitx-skk provides SKK as a back-end to the Fcitx IM framework.
+
+WWW: https://fcitx-im.org/wiki/Fcitx
diff --git a/japanese/fcitx-skk/pkg-plist b/japanese/fcitx-skk/pkg-plist
new file mode 100644
index 000000000000..64c35b3783b6
--- /dev/null
+++ b/japanese/fcitx-skk/pkg-plist
@@ -0,0 +1,13 @@
+share/fcitx/imicon/skk.png
+share/icons/hicolor/64x64/apps/fcitx-skk.png
+share/locale/de/LC_MESSAGES/fcitx-skk.mo
+share/locale/ja/LC_MESSAGES/fcitx-skk.mo
+share/locale/vi/LC_MESSAGES/fcitx-skk.mo
+share/locale/zh_CN/LC_MESSAGES/fcitx-skk.mo
+lib/fcitx/fcitx-skk.so
+%%QT4%%lib/fcitx/qt/libfcitx-skk-config.so
+share/fcitx/addon/fcitx-skk.conf
+share/fcitx/configdesc/fcitx-skk.desc
+share/fcitx/inputmethod/skk.conf
+share/fcitx/skk/dictionary_list
+share/fcitx/skk/rule