aboutsummaryrefslogtreecommitdiff
path: root/japanese/fcitx5-anthy/Makefile
diff options
context:
space:
mode:
authorGuangyuan Yang <ygy@FreeBSD.org>2020-12-29 14:58:55 +0000
committerGuangyuan Yang <ygy@FreeBSD.org>2020-12-29 14:58:55 +0000
commit784693f56c9c8899036fc4aa340be19676b514c8 (patch)
tree57d3ceb2bb056eb915f7f25ff148aea78c8807cb /japanese/fcitx5-anthy/Makefile
parent0109871be7f4defa811d2e308db09de0ee44b2c5 (diff)
Notes
Diffstat (limited to 'japanese/fcitx5-anthy/Makefile')
-rw-r--r--japanese/fcitx5-anthy/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/japanese/fcitx5-anthy/Makefile b/japanese/fcitx5-anthy/Makefile
new file mode 100644
index 000000000000..298ee195c8b7
--- /dev/null
+++ b/japanese/fcitx5-anthy/Makefile
@@ -0,0 +1,24 @@
+# Created by: Ka Ho Ng <khng300@gmail.com>
+# $FreeBSD$
+
+PORTNAME= fcitx5-anthy
+DISTVERSION= 5.0.1
+CATEGORIES= japanese textproc
+
+MAINTAINER= khng300@gmail.com
+COMMENT= Anthy support for Fcitx5
+
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/LICENSES/GPL-2.0-or-later.txt
+
+LIB_DEPENDS= libanthy.so:japanese/anthy \
+ libFcitx5Core.so:textproc/fcitx5
+
+USES= compiler:c++17-lang gettext-tools cmake kde:5 pkgconfig
+
+USE_GITHUB= yes
+GH_ACCOUNT= fcitx
+
+USE_KDE= ecm
+
+.include <bsd.port.mk>