aboutsummaryrefslogtreecommitdiff
path: root/japanese/font-ume
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2015-09-13 23:36:45 +0000
committerHiroki Sato <hrs@FreeBSD.org>2015-09-13 23:36:45 +0000
commit0b3da8c79c80795126e216954b18291047315961 (patch)
treecb890cbf02753a51263acc8e2df899b6dbcf79be /japanese/font-ume
parentc716728e4a1cae2ad6028534945293e137836147 (diff)
Fix fonts.dir by using fonts:fc and style consistency.
Notes
Notes: svn path=/head/; revision=396873
Diffstat (limited to 'japanese/font-ume')
-rw-r--r--japanese/font-ume/Makefile10
-rw-r--r--japanese/font-ume/files/pkg-install.in6
2 files changed, 7 insertions, 9 deletions
diff --git a/japanese/font-ume/Makefile b/japanese/font-ume/Makefile
index ce17b469591f..deb82db93c59 100644
--- a/japanese/font-ume/Makefile
+++ b/japanese/font-ume/Makefile
@@ -2,7 +2,7 @@
PORTNAME= ume
PORTVERSION= 0.0.470
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= japanese x11-fonts
MASTER_SITES= SOURCEFORGE_JP/${PORTNAME}-font/22212
PKGNAMEPREFIX= ja-font-
@@ -11,7 +11,8 @@ DISTNAME= umefont_${PORTVERSION:E}
MAINTAINER= hrs@FreeBSD.org
COMMENT= Ume Japanese TrueType fonts
-USES= fonts tar:xz
+USES= fonts:fc tar:xz
+FONTNAME= TTF
NO_BUILD= yes
PKGINSTALL= ${WRKDIR}/pkg-install
PKGDEINSTALL= ${WRKDIR}/pkg-install
@@ -19,11 +20,8 @@ SUB_FILES= pkg-install
DATADIR= ${PREFIX}/share/font-${PORTNAME}
PORTDOCS= license.html
-FONTNAME= TTF
OPTIONS_DEFINE= DOCS
-.include <bsd.port.options.mk>
-
do-install:
${MKDIR} ${STAGEDIR}${DATADIR}
${INSTALL_DATA} ${WRKSRC}/*.ttf ${STAGEDIR}${DATADIR}
@@ -39,6 +37,8 @@ do-install:
${STAGEDIR}${PREFIX}/etc/fonts/conf.d/20-unhint-${PORTNAME}.conf
${LN} -s -f ../conf.avail/62-fonts-${PORTNAME}.conf \
${STAGEDIR}${PREFIX}/etc/fonts/conf.d/62-fonts-${PORTNAME}.conf
+
+post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
diff --git a/japanese/font-ume/files/pkg-install.in b/japanese/font-ume/files/pkg-install.in
index b3c4b942061e..24562c0807fc 100644
--- a/japanese/font-ume/files/pkg-install.in
+++ b/japanese/font-ume/files/pkg-install.in
@@ -1,8 +1,6 @@
#!/bin/sh
# $FreeBSD$
-FONTSDIR=%%FONTSDIR%%/
-
catfontsdir ()
{
while read _IN
@@ -80,7 +78,7 @@ nfonts ()
case "$2" in
POST-INSTALL)
- cd ${FONTSDIR}
+ cd %%FONTSDIR%%
touch fonts.dir
exec < fonts.dir; rm -f fonts.dir
(catfontsdir; addentries) > fonts.dir
@@ -90,7 +88,7 @@ POST-INSTALL)
chmod 0444 fonts.dir
;;
DEINSTALL)
- cd ${FONTSDIR}
+ cd %%FONTSDIR%%
exec < fonts.dir; rm -f fonts.dir
catfontsdir > fonts.dir
_num=`nfonts fonts.dir`