aboutsummaryrefslogtreecommitdiff
path: root/japanese/ibus-mozc/Makefile
diff options
context:
space:
mode:
authorDaichi GOTO <daichi@FreeBSD.org>2011-12-12 17:43:50 +0000
committerDaichi GOTO <daichi@FreeBSD.org>2011-12-12 17:43:50 +0000
commit50c0c232c7a9f40961fac8ff9ff9af227b349da1 (patch)
tree875760435835c3204c78b33b1999b509f58975de /japanese/ibus-mozc/Makefile
parent64383248c87dd603bedeb1573647ff975d0b6745 (diff)
downloadports-50c0c232c7a9f40961fac8ff9ff9af227b349da1.tar.gz
ports-50c0c232c7a9f40961fac8ff9ff9af227b349da1.zip
Notes
Diffstat (limited to 'japanese/ibus-mozc/Makefile')
-rw-r--r--japanese/ibus-mozc/Makefile128
1 files changed, 7 insertions, 121 deletions
diff --git a/japanese/ibus-mozc/Makefile b/japanese/ibus-mozc/Makefile
index 3b8769965da8..7d59d4ffb6b8 100644
--- a/japanese/ibus-mozc/Makefile
+++ b/japanese/ibus-mozc/Makefile
@@ -5,131 +5,17 @@
# $FreeBSD$
#
-PORTNAME= ibus-mozc
-PORTVERSION= 1.3.911.102
-PORTREVISION= 0
-CATEGORIES= japanese
-MASTER_SITES= http://mozc.googlecode.com/files/
-DISTNAME= mozc-${PORTVERSION}
-DISTFILES= ${DISTNAME}.tar.bz2
-
-MAINTAINER= daichi@FreeBSD.org
+PKGNAMEPREFIX= ja-ibus-
COMMENT= Mozc engine for IBus
+DATADIR= ${PREFIX}/share/ibus-${PORTNAME}
-BUILD_DEPENDS= gsed:${PORTSDIR}/textproc/gsed \
- ${LOCALBASE}/bin/grep:${PORTSDIR}/textproc/gnugrep \
- gyp:${PORTSDIR}/devel/py-gyp-devel
-LIB_DEPENDS= curl.6:${PORTSDIR}/ftp/curl \
- gtest.0:${PORTSDIR}/devel/googletest \
- ibus.2:${PORTSDIR}/textproc/ibus \
- protobuf.7:${PORTSDIR}/devel/protobuf \
- zinnia.0:${PORTSDIR}/japanese/zinnia
-RUN_DEPENDS= mozc_server:${PORTSDIR}/japanese/mozc-server \
- mozc_tool:${PORTSDIR}/japanese/mozc-tool \
- mozc_server_start:${PORTSDIR}/japanese/mozc-additions \
- ${PYTHON_SITELIBDIR}/gtk-2.0/pynotify/_pynotify.so:${PORTSDIR}/devel/py-notify \
- xdg-open:${PORTSDIR}/devel/xdg-utils
-
-PROJECTHOST= ibus
-USE_ICONV= yes
-USE_GNOME= pygtk2
-USE_GMAKE= yes
-USE_PYTHON= yes
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 800107
-BROKEN= Does not compile on FreeBSD 7.X
-.endif
-
-.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
-BROKEN= Does not compile: segfault
-.endif
-
-# workaround for a gcc4.2.1's namespace bug
-.if (${OSVERSION} < 1000000 && ${OSVERSION} > 9000000) || ${OSVERSION} < 802503
-BUILD_DEPENDS+= gcc42:${PORTSDIR}/lang/gcc42
-CC= gcc42
-CXX= g++42
-.endif
-
-.if defined(WITH_DEBUG_CODE)
-BUILD_MODE= Debug
-.else
-BUILD_MODE= Release
-.endif
-
-LOCALBASE_REPLACE_FILES= \
- ${WRKSRC}/build_mozc.py \
- ${WRKSRC}/gyp/common.gypi \
- ${WRKSRC}/unix/ibus/gen_mozc_xml.py \
- ${WRKSRC}/unix/ibus/mozc.xml \
- ${WRKSRC}/unix/ibus/path_util.cc \
- ${WRKSRC}/base/util.cc \
- ${WRKSRC}/base/process.cc \
- ${WRKSRC}/handwriting/zinnia_handwriting.cc
-
-post-patch:
- @for FILE in ${LOCALBASE_REPLACE_FILES}; \
- do \
- ${SED} -i .bak -e "s/@@LOCALBASE@@/${LOCALBASE:S/\//\\\//g}/g" \
- $${FILE}; \
- done;
-
-do-build:
- @cd ${WRKSRC}/; \
- export BUILD_COMMAND=${GMAKE}; \
- export CC=${CC}; export CFLAGS="${CFLAGS}"; \
- export CXX=${CXX}; export CXXFLAGS="${CXXFLAGS}"; \
- export LDFLAGS="-L${LOCALBASE}/lib"; \
- ${PYTHON_CMD} build_mozc.py gyp --gypdir=${LOCALBASE}/bin; \
- ${PYTHON_CMD} build_mozc.py build_tools \
- -c ${BUILD_MODE}; \
- ${PYTHON_CMD} build_mozc.py build \
- -c ${BUILD_MODE} \
- unix/ibus/ibus.gyp:ibus_mozc
+MASTERDIR= ${.CURDIR}/../../japanese/mozc-server
+PKGMESSAGE= ${.CURDIR}/pkg-message
-do-install:
- @${INSTALL} -o 0 -g 0 -m 555 \
- ${WRKSRC}/out_linux/${BUILD_MODE}/ibus_mozc \
- ${LOCALBASE}/libexec/ibus-engine-mozc
- @${INSTALL} -o 0 -g 0 -m 444 \
- ${WRKSRC}/unix/ibus/mozc.xml \
- ${LOCALBASE}/share/ibus/component/mozc.xml
- @${MKDIR} ${LOCALBASE}/share/ibus-mozc/icons
- @${INSTALL} -o 0 -g 0 -m 444 \
- ${WRKSRC}/data/images/unix/ui-alpha_full.png \
- ${LOCALBASE}/share/ibus-mozc/icons/alpha_full.png
- @${INSTALL} -o 0 -g 0 -m 444 \
- ${WRKSRC}/data/images/unix/ui-alpha_half.png \
- ${LOCALBASE}/share/ibus-mozc/icons/alpha_half.png
- @${INSTALL} -o 0 -g 0 -m 444 \
- ${WRKSRC}/data/images/unix/ui-dictionary.png \
- ${LOCALBASE}/share/ibus-mozc/icons/dictionary.png
- @${INSTALL} -o 0 -g 0 -m 444 \
- ${WRKSRC}/data/images/unix/ui-direct.png \
- ${LOCALBASE}/share/ibus-mozc/icons/direct.png
- @${INSTALL} -o 0 -g 0 -m 444 \
- ${WRKSRC}/data/images/unix/ui-hiragana.png \
- ${LOCALBASE}/share/ibus-mozc/icons/hiragana.png
- @${INSTALL} -o 0 -g 0 -m 444 \
- ${WRKSRC}/data/images/unix/ui-katakana_full.png \
- ${LOCALBASE}/share/ibus-mozc/icons/katakana_full.png
- @${INSTALL} -o 0 -g 0 -m 444 \
- ${WRKSRC}/data/images/unix/ui-katakana_half.png \
- ${LOCALBASE}/share/ibus-mozc/icons/katakana_half.png
- @${INSTALL} -o 0 -g 0 -m 444 \
- ${WRKSRC}/data/images/unix/ime_product_icon_opensource-32.png \
- ${LOCALBASE}/share/ibus-mozc/icons/product_logo.png
- @${INSTALL} -o 0 -g 0 -m 444 \
- ${WRKSRC}/data/images/unix/ui-properties.png \
- ${LOCALBASE}/share/ibus-mozc/icons/properties.png
- @${INSTALL} -o 0 -g 0 -m 444 \
- ${WRKSRC}/data/images/unix/ui-tool.png \
- ${LOCALBASE}/share/ibus-mozc/icons/tool.png
+BUILD_MOZC_LIST= ibus_mozc
post-install:
@${CAT} ${PKGMESSAGE}
- @${ECHO} To display this message again, type ${PKG_INFO} -D ${PKGNAME}
+ @${ECHO_CMD} To display this message again, type ${PKG_INFO} -D ${PKGNAME}
-.include <bsd.port.post.mk>
+.include "${MASTERDIR}/Makefile"