aboutsummaryrefslogtreecommitdiff
path: root/japanese/ibus-mozc
diff options
context:
space:
mode:
authorDaichi GOTO <daichi@FreeBSD.org>2010-06-26 08:21:35 +0000
committerDaichi GOTO <daichi@FreeBSD.org>2010-06-26 08:21:35 +0000
commit7f15184358bfb55e5f262d9e98d210bd97ef8bcc (patch)
tree1667603510e3806900125fdfb7d0efc17ceaa7b1 /japanese/ibus-mozc
parent9ab4927e63c68013e405bf728c529f9c53908ad2 (diff)
downloadports-7f15184358bfb55e5f262d9e98d210bd97ef8bcc.tar.gz
ports-7f15184358bfb55e5f262d9e98d210bd97ef8bcc.zip
Update to 0.11.383.102
- japanese/ibus-mozc port has been separated into 5 ports to cope with upcoming new port japanese/scim-mozc. o japanese/mozc-server o japanese/mozc-tool o japanese/mozc-additions o japanese/ibus-mozc o devel/py-gyp-devel Notice: You must deinstall ibus-mozc before do portupgrade or portmaster. Uninstall ibus-mozc and install new ibus-moz. e.g. # cd /usr/ports/japanese/ibus-mozc/ # make deinstall # portsnap fetch update # cd /usr/ports/japanese/ibus-mozc/ # make install clean Feature safe: yes
Notes
Notes: svn path=/head/; revision=257012
Diffstat (limited to 'japanese/ibus-mozc')
-rw-r--r--japanese/ibus-mozc/Makefile101
-rw-r--r--japanese/ibus-mozc/distinfo15
-rw-r--r--japanese/ibus-mozc/files/patch-src_base_iconv.cc4
-rw-r--r--japanese/ibus-mozc/files/patch-src_base_mutex.h4
-rw-r--r--japanese/ibus-mozc/files/patch-src_base_process.cc4
-rw-r--r--japanese/ibus-mozc/files/patch-src_base_util.cc8
-rw-r--r--japanese/ibus-mozc/files/patch-src_build_mozc.py17
-rw-r--r--japanese/ibus-mozc/files/patch-src_gyp_common.gypi16
-rw-r--r--japanese/ibus-mozc/files/patch-src_ipc_unix_ipc.cc4
-rw-r--r--japanese/ibus-mozc/files/patch-src_unix_ibus_mozc.xml13
-rw-r--r--japanese/ibus-mozc/files/patch-src_unix_ibus_mozc_engine.cc6
-rw-r--r--japanese/ibus-mozc/files/patch-src_unix_ibus_path_util.cc6
-rw-r--r--japanese/ibus-mozc/pkg-plist13
13 files changed, 58 insertions, 153 deletions
diff --git a/japanese/ibus-mozc/Makefile b/japanese/ibus-mozc/Makefile
index c7492e377910..49eafe6df113 100644
--- a/japanese/ibus-mozc/Makefile
+++ b/japanese/ibus-mozc/Makefile
@@ -6,36 +6,32 @@
#
PORTNAME= ibus-mozc
-PORTVERSION= 0.11.365.102
-PORTREVISION= 1
+PORTVERSION= 0.11.383.102
CATEGORIES= japanese
MASTER_SITES= http://people.freebsd.org/~daichi/distfiles/
DISTNAME= mozc-${PORTVERSION}
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
- mozc_build_tools-r827${EXTRACT_SUFX} \
- ibus-mozc-freebsd-addition-${PORTVERSION}${EXTRACT_SUFX}
+DISTFILES= ${DISTNAME}.tar.bz2
MAINTAINER= daichi@freebsd.org
COMMENT= Mozc engine for IBus
-BUILD_DEPENDS= gsed:${PORTSDIR}/textproc/gsed
-LIB_DEPENDS= ibus.2:${PORTSDIR}/textproc/ibus \
- curl.6:${PORTSDIR}/ftp/curl \
- protobuf.6:${PORTSDIR}/devel/protobuf \
- gtest.0:${PORTSDIR}/devel/googletest
-RUN_DEPENDS= xdg-open:${PORTSDIR}/devel/xdg-utils \
- ${PYTHON_SITELIBDIR}/gtk-2.0/pynotify/_pynotify.so:${PORTSDIR}/devel/py-notify
-
-WRKSRC= ${WRKDIR}/mozc
-WRKADDITIONSRC= ${WRKDIR}/ibus-mozc-freebsd-addition-${PORTVERSION}
-WRKUTDICSRC= ${WRKDIR}/mozcdic-ut-20100612
+BUILD_DEPENDS= gsed:${PORTSDIR}/textproc/gsed \
+ gyp:${PORTSDIR}/devel/py-gyp-devel
+LIB_DEPENDS= curl.6:${PORTSDIR}/ftp/curl \
+ gtest.0:${PORTSDIR}/devel/googletest \
+ ibus.2:${PORTSDIR}/textproc/ibus \
+ protobuf.6:${PORTSDIR}/devel/protobuf
+RUN_DEPENDS= mozc_server:${PORTSDIR}/japanese/mozc-server \
+ mozc_tool:${PORTSDIR}/japanese/mozc-tool \
+ mozc_server_start:${PORTSDIR}/japanese/mozc-additions \
+ ${PYTHON_SITELIBDIR}/gtk-2.0/pynotify/_pynotify.so:${PORTSDIR}/devel/py-notify \
+ xdg-open:${PORTSDIR}/devel/xdg-utils
PROJECTHOST= ibus
+USE_ICONV= yes
USE_GNOME= pygtk2
USE_GMAKE= yes
USE_PYTHON= yes
-USE_QT_VER= 4
-QT_COMPONENTS= gui dbus qmake_build moc_build uic_build rcc_build
.include <bsd.port.pre.mk>
@@ -43,38 +39,12 @@ QT_COMPONENTS= gui dbus qmake_build moc_build uic_build rcc_build
BROKEN= Does not compile on FreeBSD 7.X
.endif
-.if defined(WITH_DIC_UT)
-WITH_DIC_UT_MEISHI=yes
-WITH_DIC_UT_JINMEI=yes
-.endif
-
-.if defined(WITH_DIC_UT_FULL)
-WITH_DIC_UT_MEISHI=yes
-WITH_DIC_UT_JINMEI=yes
-WITH_DIC_UT_KAOMOJI=yes
-WITH_DIC_UT_EDICTKATAKANAGO=yes
-WITH_DIC_UT_ZIPCODE=yes
-WITH_DIC_UT_JIGYOSHO=yes
-WITH_DIC_UT_GCANNAKIHONMEISHI=yes
-.endif
-
-.if defined(WITH_DIC_UT_MEISHI) || \
- defined(WITH_DIC_UT_JINMEI) || \
- defined(WITH_DIC_UT_KAOMOJI) || \
- defined(WITH_DIC_UT_EDICTKATAKANAGO) || \
- defined(WITH_DIC_UT_ZIPCODE) || \
- defined(WITH_DIC_UT_JIGYOSHO) || \
- defined(WITH_DIC_UT_GCANNAKIHONMEISHI)
-DISTFILES+= mozcdic-ut-20100612.tar.bz2
-.endif
-
REPLACE_FILES= ${WRKSRC}/build_mozc.py \
${WRKSRC}/gyp/common.gypi \
${WRKSRC}/unix/ibus/mozc.xml \
${WRKSRC}/unix/ibus/path_util.cc \
${WRKSRC}/base/util.cc \
${WRKSRC}/base/process.cc \
- ${WRKADDITIONSRC}/Makefile
post-patch:
@for FILE in ${REPLACE_FILES}; \
@@ -82,61 +52,22 @@ post-patch:
${SED} -i .bak -e "s/@@LOCALBASE@@/${LOCALBASE:S/\//\\\//g}/g" \
$${FILE}; \
done;
- @${CP} -R ${WRKDIR}/mozc_build_tools ${WRKSRC}
-.if defined(WITH_DIC_UT_MEISHI)
- ${CAT} ${WRKUTDICSRC}/mozcdic-ut-meisi-20100612.txt \
- >> ${WRKSRC}/data/dictionary/dictionary1.txt
-.endif
-.if defined(WITH_DIC_UT_JINMEI)
- ${CAT} ${WRKUTDICSRC}/mozcdic-ut-jinmei-20100609.txt \
- >> ${WRKSRC}/data/dictionary/dictionary1.txt
-.endif
-.if defined(WITH_DIC_UT_KAOMOJI)
- ${CAT} ${WRKUTDICSRC}/kaomoji/mozcdic-ut-kaomoji-20100611.txt \
- >> ${WRKSRC}/data/dictionary/dictionary1.txt
-.endif
-.if defined(WITH_DIC_UT_EDICTKATAKANAGO)
- ${CAT} ${WRKUTDICSRC}/edict-katakanago/mozcdic-ut-edict-katakanago-20100609.txt \
- >> ${WRKSRC}/data/dictionary/dictionary1.txt
-.endif
-.if defined(WITH_DIC_UT_ZIPCODE)
- ${CAT} ${WRKUTDICSRC}/mozcdic-ut-zipcode-20100601.txt \
- >> ${WRKSRC}/data/dictionary/dictionary1.txt
-.endif
-.if defined(WITH_DIC_UT_JIGYOSHO)
- ${CAT} ${WRKUTDICSRC}/mozcdic-ut-jinmei-20100609.txt \
- >> ${WRKSRC}/data/dictionary/dictionary1.txt
-.endif
-.if defined(WITH_DIC_UT_GCANNAKIHONMEISHI)
- ${CAT} ${WRKUTDICSRC}/mozcdic-ut-gcanna-kihonmeisi-20100612.txt \
- >> ${WRKSRC}/data/dictionary/dictionary1.txt
-.endif
do-build:
@cd ${WRKSRC}/; \
- ${PYTHON_CMD} build_mozc.py gyp; \
+ ${PYTHON_CMD} build_mozc.py gyp --gypdir=${LOCALBASE}/bin; \
${SED} -i .bak -e "s/sed/gsed/g" Makefile; \
${PYTHON_CMD} build_mozc.py build_tools -c Release; \
${PYTHON_CMD} build_mozc.py build -c Release \
- unix/ibus/ibus.gyp:ibus_mozc \
- server/server.gyp:mozc_server \
- gui/gui.gyp:mozc_tool
+ unix/ibus/ibus.gyp:ibus_mozc
do-install:
- @${MKDIR} ${LOCALBASE}/share/ibus-mozc/server
- @${INSTALL} -o 0 -g 0 -m 555 \
- ${WRKSRC}/out/Release/mozc_server \
- ${LOCALBASE}/share/ibus-mozc/server/mozc_server
- @${INSTALL} -o 0 -g 0 -m 555 \
- ${WRKSRC}/out/Release/mozc_tool \
- ${LOCALBASE}/share/ibus-mozc/server/mozc_tool
@${INSTALL} -o 0 -g 0 -m 555 \
${WRKSRC}/out/Release/ibus_mozc \
${LOCALBASE}/libexec/ibus-engine-mozc
@${INSTALL} -o 0 -g 0 -m 444 \
${WRKSRC}/unix/ibus/mozc.xml \
${LOCALBASE}/share/ibus/component/mozc.xml
- @cd ${WRKADDITIONSRC}; make install
post-install:
@${CAT} ${PKGMESSAGE}
diff --git a/japanese/ibus-mozc/distinfo b/japanese/ibus-mozc/distinfo
index 2628cce684f2..3f51e9eb66e5 100644
--- a/japanese/ibus-mozc/distinfo
+++ b/japanese/ibus-mozc/distinfo
@@ -1,12 +1,3 @@
-MD5 (mozc-0.11.365.102.tar.gz) = 24b5faa4dc8cd37ee02e914b0d20cc18
-SHA256 (mozc-0.11.365.102.tar.gz) = 91f8d2081a705452012f4e94bc4215872e1465deaa46bad38814668c50511eb7
-SIZE (mozc-0.11.365.102.tar.gz) = 47786830
-MD5 (mozc_build_tools-r827.tar.gz) = 3727faae1268afbe1b740f93db55f933
-SHA256 (mozc_build_tools-r827.tar.gz) = 16f5d25f83a1ed127c7a5ce1192840b6d64435b62991d6bb4815c1549fb91e1c
-SIZE (mozc_build_tools-r827.tar.gz) = 434262
-MD5 (ibus-mozc-freebsd-addition-0.11.365.102.tar.gz) = 552a4d4a9e473bff7db20ba25005e6b8
-SHA256 (ibus-mozc-freebsd-addition-0.11.365.102.tar.gz) = 04a526ae11c3188910d6ab1c40f15a389301da2a747df67e6488113ce6dfa0c4
-SIZE (ibus-mozc-freebsd-addition-0.11.365.102.tar.gz) = 3068
-MD5 (mozcdic-ut-20100612.tar.bz2) = 65787929cc45a648bf91a44635604a46
-SHA256 (mozcdic-ut-20100612.tar.bz2) = d18da85c4a704dffafd892dffd9af2bcb68a4068e615d36ac38320bc721a6b6c
-SIZE (mozcdic-ut-20100612.tar.bz2) = 4334391
+MD5 (mozc-0.11.383.102.tar.bz2) = 42e7b57f617b470528dc00be28ccaf28
+SHA256 (mozc-0.11.383.102.tar.bz2) = 69e8a4daf2165d9e2918af1e7a1a26262099ab453578d8c7456301aa8df047a2
+SIZE (mozc-0.11.383.102.tar.bz2) = 34539981
diff --git a/japanese/ibus-mozc/files/patch-src_base_iconv.cc b/japanese/ibus-mozc/files/patch-src_base_iconv.cc
index 7f2f5b122cf5..5a928e254b27 100644
--- a/japanese/ibus-mozc/files/patch-src_base_iconv.cc
+++ b/japanese/ibus-mozc/files/patch-src_base_iconv.cc
@@ -1,5 +1,5 @@
---- base/iconv.cc.org 2010-06-11 18:01:03.000000000 +0900
-+++ base/iconv.cc 2010-06-12 10:02:20.315839057 +0900
+--- base/iconv.cc.org 2010-06-17 15:59:08.032915669 +0900
++++ base/iconv.cc 2010-06-26 14:52:20.086054034 +0900
@@ -52,7 +52,7 @@
size_t olen_org = olen;
iconv(ic, 0, &ilen, 0, &olen); // reset iconv state
diff --git a/japanese/ibus-mozc/files/patch-src_base_mutex.h b/japanese/ibus-mozc/files/patch-src_base_mutex.h
index d5bf95f853f5..4249feff64fc 100644
--- a/japanese/ibus-mozc/files/patch-src_base_mutex.h
+++ b/japanese/ibus-mozc/files/patch-src_base_mutex.h
@@ -1,5 +1,5 @@
---- base/mutex.h.org 2010-06-11 18:01:03.000000000 +0900
-+++ base/mutex.h 2010-06-12 10:02:50.414966599 +0900
+--- base/mutex.h.org 2010-06-17 15:59:08.032915669 +0900
++++ base/mutex.h 2010-06-26 14:42:34.171132724 +0900
@@ -87,7 +87,7 @@
#endif
diff --git a/japanese/ibus-mozc/files/patch-src_base_process.cc b/japanese/ibus-mozc/files/patch-src_base_process.cc
index 9d03245ec4f1..9832c2f21642 100644
--- a/japanese/ibus-mozc/files/patch-src_base_process.cc
+++ b/japanese/ibus-mozc/files/patch-src_base_process.cc
@@ -1,5 +1,5 @@
---- base/process.cc.org 2010-06-11 18:01:03.000000000 +0900
-+++ base/process.cc 2010-06-12 10:03:39.662872618 +0900
+--- base/process.cc.org 2010-06-17 15:59:08.038677016 +0900
++++ base/process.cc 2010-06-26 15:14:15.207482874 +0900
@@ -195,7 +195,7 @@
#endif
diff --git a/japanese/ibus-mozc/files/patch-src_base_util.cc b/japanese/ibus-mozc/files/patch-src_base_util.cc
index a5f0b5f99725..b338a19eb60e 100644
--- a/japanese/ibus-mozc/files/patch-src_base_util.cc
+++ b/japanese/ibus-mozc/files/patch-src_base_util.cc
@@ -1,11 +1,11 @@
---- base/util.cc.org 2010-06-11 18:01:03.000000000 +0900
-+++ base/util.cc 2010-06-12 10:04:16.922969013 +0900
-@@ -1489,7 +1489,7 @@
+--- base/util.cc.org 2010-06-17 15:59:08.035797879 +0900
++++ base/util.cc 2010-06-26 15:18:24.444371641 +0900
+@@ -1493,7 +1493,7 @@
#endif // OS_MACOSX
#ifdef OS_LINUX
- return "/usr/lib/mozc";
-+ return "@@LOCALBASE@@/share/ibus-mozc/server";
++ return "@@LOCALBASE@@/bin";
#endif // OS_LINUX
}
diff --git a/japanese/ibus-mozc/files/patch-src_build_mozc.py b/japanese/ibus-mozc/files/patch-src_build_mozc.py
index 2aee74bfd72e..ba044b1cad4a 100644
--- a/japanese/ibus-mozc/files/patch-src_build_mozc.py
+++ b/japanese/ibus-mozc/files/patch-src_build_mozc.py
@@ -1,6 +1,6 @@
---- build_mozc.py.org 2010-06-11 18:01:03.000000000 +0900
-+++ build_mozc.py 2010-06-12 10:05:39.176190512 +0900
-@@ -67,7 +67,7 @@
+--- build_mozc.py.org 2010-06-17 15:59:08.104932923 +0900
++++ build_mozc.py 2010-06-26 14:43:42.504687128 +0900
+@@ -68,7 +68,7 @@
def IsLinux():
"""Returns true if the platform is Linux."""
@@ -9,16 +9,7 @@
def GetGeneratorName():
-@@ -356,7 +356,7 @@
- default='Win32',
- help='specify the target plaform: [Win32|x64]')
- # default Qt dir to support the current build procedure for Debian.
-- default_qtdir = '/usr/local/Trolltech/Qt-4.5.2'
-+ default_qtdir = '@@LOCALBASE@@/lib/qt4/'
- if IsWindows():
- default_qtdir = None
- parser.add_option('--qtdir', dest='qtdir',
-@@ -387,7 +387,7 @@
+@@ -403,7 +403,7 @@
(unused_gyp_file_name, target_name) = ParseTarget(target)
target_names.append(target_name)
diff --git a/japanese/ibus-mozc/files/patch-src_gyp_common.gypi b/japanese/ibus-mozc/files/patch-src_gyp_common.gypi
index 8e637be0cfac..6bd13450d867 100644
--- a/japanese/ibus-mozc/files/patch-src_gyp_common.gypi
+++ b/japanese/ibus-mozc/files/patch-src_gyp_common.gypi
@@ -1,11 +1,15 @@
---- gyp/common.gypi.org 2010-06-11 18:00:39.000000000 +0900
-+++ gyp/common.gypi 2010-06-12 10:06:52.655552554 +0900
-@@ -420,6 +420,8 @@
- '-lssl',
+--- gyp/common.gypi.org 2010-06-17 15:59:08.053080522 +0900
++++ gyp/common.gypi 2010-06-26 14:48:00.645671527 +0900
+@@ -371,6 +371,12 @@
'-lz',
+ '<@(extra_linux_libs)',
],
-+ 'include_dirs': [ '@@LOCALBASE@@/include' ],
-+ 'ldflags': [ '-L@@LOCALBASE@@/lib' ],
++ 'include_dirs': [
++ '@@LOCALBASE@@/include'
++ ],
++ 'ldflags': [
++ '-L@@LOCALBASE@@/lib'
++ ],
'conditions': [
['chromeos==1', {
'defines': [
diff --git a/japanese/ibus-mozc/files/patch-src_ipc_unix_ipc.cc b/japanese/ibus-mozc/files/patch-src_ipc_unix_ipc.cc
index 6c18ebd6aa34..f0e5dfc02654 100644
--- a/japanese/ibus-mozc/files/patch-src_ipc_unix_ipc.cc
+++ b/japanese/ibus-mozc/files/patch-src_ipc_unix_ipc.cc
@@ -1,5 +1,5 @@
---- ipc/unix_ipc.cc.org 2010-06-11 18:01:03.000000000 +0900
-+++ ipc/unix_ipc.cc 2010-06-12 10:21:51.905675963 +0900
+--- ipc/unix_ipc.cc.org 2010-06-17 15:59:08.061722403 +0900
++++ ipc/unix_ipc.cc 2010-06-26 14:57:03.788901462 +0900
@@ -41,7 +41,7 @@
#include <sys/time.h>
#include <sys/types.h>
diff --git a/japanese/ibus-mozc/files/patch-src_unix_ibus_mozc.xml b/japanese/ibus-mozc/files/patch-src_unix_ibus_mozc.xml
index cc26cb581a02..4a8d10e24709 100644
--- a/japanese/ibus-mozc/files/patch-src_unix_ibus_mozc.xml
+++ b/japanese/ibus-mozc/files/patch-src_unix_ibus_mozc.xml
@@ -1,16 +1,17 @@
---- unix/ibus/mozc.xml.org 2010-06-11 18:00:39.000000000 +0900
-+++ unix/ibus/mozc.xml 2010-06-12 10:22:30.668862555 +0900
-@@ -3,6 +3,7 @@
+--- unix/ibus/mozc.xml.org 2010-06-17 15:59:08.044438083 +0900
++++ unix/ibus/mozc.xml 2010-06-26 16:28:56.093569793 +0900
+@@ -2,12 +2,12 @@
+ <component>
<name>com.google.IBus.Mozc</name>
<description>Mozc Component</description>
- <exec>/usr/libexec/ibus-engine-mozc --ibus</exec>
+- <exec>/usr/libexec/ibus-engine-mozc --ibus</exec>
+ <exec>@@LOCALBASE@@/libexec/ibus-engine-mozc --ibus</exec>
<!-- TODO(mazda): Generate the version number -->
<version>0.0.0.0</version>
<author>Google Inc.</author>
-@@ -10,4 +11,5 @@
+ <license>New BSD</license>
<homepage>http://code.google.com/p/mozc/</homepage>
<textdomain>ibus-mozc</textdomain>
- <engines exec="/usr/libexec/ibus-engine-mozc --xml" />
+- <engines exec="/usr/libexec/ibus-engine-mozc --xml" />
+ <engines exec="@@LOCALBASE@@/libexec/ibus-engine-mozc --xml" />
</component>
diff --git a/japanese/ibus-mozc/files/patch-src_unix_ibus_mozc_engine.cc b/japanese/ibus-mozc/files/patch-src_unix_ibus_mozc_engine.cc
index d338366bec65..b5457112eecb 100644
--- a/japanese/ibus-mozc/files/patch-src_unix_ibus_mozc_engine.cc
+++ b/japanese/ibus-mozc/files/patch-src_unix_ibus_mozc_engine.cc
@@ -1,6 +1,6 @@
---- unix/ibus/mozc_engine.cc.org 2010-06-11 18:00:39.000000000 +0900
-+++ unix/ibus/mozc_engine.cc 2010-06-12 13:19:26.188760964 +0900
-@@ -59,7 +59,7 @@
+--- unix/ibus/mozc_engine.cc.org 2010-06-17 15:59:08.047320852 +0900
++++ unix/ibus/mozc_engine.cc 2010-06-26 16:32:23.046397317 +0900
+@@ -66,7 +66,7 @@
// Icon path for MozcTool
// TODO(taku): currently, unknown icon is displayed.
diff --git a/japanese/ibus-mozc/files/patch-src_unix_ibus_path_util.cc b/japanese/ibus-mozc/files/patch-src_unix_ibus_path_util.cc
index 824dd8e4fa9e..a29f67dc80a3 100644
--- a/japanese/ibus-mozc/files/patch-src_unix_ibus_path_util.cc
+++ b/japanese/ibus-mozc/files/patch-src_unix_ibus_path_util.cc
@@ -1,5 +1,5 @@
---- unix/ibus/path_util.cc.org 2010-06-11 18:00:39.000000000 +0900
-+++ unix/ibus/path_util.cc 2010-06-12 10:23:37.582580151 +0900
+--- unix/ibus/path_util.cc.org 2010-06-17 15:59:08.044438083 +0900
++++ unix/ibus/path_util.cc 2010-06-26 16:38:18.218403536 +0900
@@ -30,14 +30,14 @@
#include "unix/ibus/path_util.h"
@@ -13,7 +13,7 @@
string GetIconPath(const string &icon_file) {
- return kInstalledDirectory + string("/") + icon_file;
-+ return kInstalledDirectory + string("/icons/") + icon_file;
++ return string("@@LOCALBASE@@/share/mozc-additions/icons/") + icon_file;
}
} // namespace ibus
diff --git a/japanese/ibus-mozc/pkg-plist b/japanese/ibus-mozc/pkg-plist
index 4a45a460b5c0..71654651e432 100644
--- a/japanese/ibus-mozc/pkg-plist
+++ b/japanese/ibus-mozc/pkg-plist
@@ -1,15 +1,2 @@
-bin/ibus-daemon_restart
-bin/mozc_server_restart
-bin/mozc_server_start
-bin/mozc_server_stop
-bin/mozc_tool_config
-bin/mozc_tool_dictionary
libexec/ibus-engine-mozc
share/ibus/component/mozc.xml
-share/ibus-mozc/icons/product_icon.png
-share/ibus-mozc/icons/toolicon_setting.png
-share/ibus-mozc/server/mozc_tool
-share/ibus-mozc/server/mozc_server
-@dirrm share/ibus-mozc/icons
-@dirrm share/ibus-mozc/server
-@dirrm share/ibus-mozc