aboutsummaryrefslogtreecommitdiff
path: root/japanese/im-ja
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-06-06 16:05:55 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-06-06 16:05:55 +0000
commit48ffaafcd563ac4948401f2f68227a54c695928a (patch)
tree151ebea05e76fe86c4d7d9353f10252c8c21c581 /japanese/im-ja
parent2ba2995f5b933faa0c16bdd10db0cab7f79101fd (diff)
downloadports-48ffaafcd563ac4948401f2f68227a54c695928a.tar.gz
ports-48ffaafcd563ac4948401f2f68227a54c695928a.zip
Notes
Diffstat (limited to 'japanese/im-ja')
-rw-r--r--japanese/im-ja/Makefile34
1 files changed, 18 insertions, 16 deletions
diff --git a/japanese/im-ja/Makefile b/japanese/im-ja/Makefile
index 727f602c9075..77e0d22ddf25 100644
--- a/japanese/im-ja/Makefile
+++ b/japanese/im-ja/Makefile
@@ -10,10 +10,12 @@ MASTER_SITES= http://im-ja.sourceforge.net/
MAINTAINER= ports@FreeBSD.org
COMMENT= A Japanese input module for GTK2
-OPTIONS+= ANTHY "Use Anthy" on
-OPTIONS+= CANNA "Use Canna" on
-OPTIONS+= WNN "Use FreeWnn" on
-OPTIONS+= GNOMEPANEL "Build GNOME Panel Applet" off
+OPTIONS_DEFINE= ANTHY CANNA WNN GNOMEPANEL
+OPTIONS_DEFAULT= ANTHY CANNA WNN
+ANTHY_DESC= Use Anthy
+CANNA_DESC= Use Canna
+WNN_DESC= Use FreeWnn
+GNOMEPANEL_DESC= Build GNOME Panel Applet
USES= pathfix
USE_GNOME= gconf2 gnomeprefix intlhack libglade2
@@ -27,27 +29,27 @@ GCONF_SCHEMAS= im-ja.schemas
CPPFLAGS+= -I${LOCALBASE}/include -DNO_MALLOC_H
LDFLAGS+= -L${LOCALBASE}/lib
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITHOUT_ANTHY)
-CONFIGURE_ARGS+= --disable-anthy
-.else
+.if ${PORT_OPTIONS:MANTHY}
LIB_DEPENDS+= anthy.1:${PORTSDIR}/japanese/anthy
+.else
+CONFIGURE_ARGS+= --disable-anthy
.endif
-.if defined(WITHOUT_CANNA)
-CONFIGURE_ARGS+= --disable-canna
-.else
+.if ${PORT_OPTIONS:MCANNA}
LIB_DEPENDS+= RKC.1:${PORTSDIR}/japanese/canna-lib
+.else
+CONFIGURE_ARGS+= --disable-canna
.endif
-.if defined(WITHOUT_WNN)
-CONFIGURE_ARGS+= --disable-wnn
-.else
+.if ${PORT_OPTIONS:MWNN}
LIB_DEPENDS+= wnn.0:${PORTSDIR}/japanese/FreeWnn-lib
+.else
+CONFIGURE_ARGS+= --disable-wnn
.endif
-.if defined(WITH_GNOMEPANEL)
+.if ${PORT_OPTIONS:MGNOMEPANEL}
USE_GNOME+= gnomepanel
PLIST_SUB+= GNOMEPANEL=""
.else
@@ -69,4 +71,4 @@ post-install:
${LOCALBASE}/bin/gtk-query-immodules-2.0 > \
${LOCALBASE}/etc/gtk-2.0/gtk.immodules
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>