aboutsummaryrefslogtreecommitdiff
path: root/japanese/jargon-fpw
diff options
context:
space:
mode:
authorSatoshi Taoka <taoka@FreeBSD.org>2000-06-23 18:31:05 +0000
committerSatoshi Taoka <taoka@FreeBSD.org>2000-06-23 18:31:05 +0000
commit0e86e94165e707fd10bf0b416f7f4a1d6369e654 (patch)
tree14b999f36ab5670cdcf096b290f1fecb714e4bd0 /japanese/jargon-fpw
parentdcda47e2260347370012e59889010dbf2ae39c4d (diff)
downloadports-0e86e94165e707fd10bf0b416f7f4a1d6369e654.tar.gz
ports-0e86e94165e707fd10bf0b416f7f4a1d6369e654.zip
The famous jargon file (EPWING V1 format)
Notes
Notes: svn path=/head/; revision=29826
Diffstat (limited to 'japanese/jargon-fpw')
-rw-r--r--japanese/jargon-fpw/Makefile62
-rw-r--r--japanese/jargon-fpw/distinfo2
-rw-r--r--japanese/jargon-fpw/pkg-comment1
-rw-r--r--japanese/jargon-fpw/pkg-descr8
-rw-r--r--japanese/jargon-fpw/pkg-plist10
5 files changed, 83 insertions, 0 deletions
diff --git a/japanese/jargon-fpw/Makefile b/japanese/jargon-fpw/Makefile
new file mode 100644
index 000000000000..185b88009f33
--- /dev/null
+++ b/japanese/jargon-fpw/Makefile
@@ -0,0 +1,62 @@
+# New ports collection makefile for: The Jargon File - JIS X 4081 format version
+# Date created: 00/06/19
+# Whom: Satoshi Taoka <taoka@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= jargon-fpw
+PORTVERSION= ${JG_VER}.${JGFPW_VER}
+CATEGORIES= japanese
+MASTER_SITES= http://plaza27.mbn.or.jp/~satomii/soft/archive/ \
+ http://www.tuxedo.org/~esr/jargon/
+DISTNAME= jarg-fpw${JGFPW_VER}-src
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
+ jargon-${JG_VER}.tar.gz
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
+
+MAINTAINER= taoka@FreeBSD.org
+
+BUILD_DEPENDS= fpwmake:${PORTSDIR}/japanese/freepwing \
+ catdump:${PORTSDIR}/japanese/epwutil \
+ nkf:${PORTSDIR}/japanese/nkf
+
+WRKSRC= ${WRKDIR}/jarg-fpw${JGFPW_VER}
+USE_GMAKE= yes
+JGFPW_VER= 1.1
+JG_VER= 4.2.0
+FJG_VER= 420
+
+post-extract:
+ cd ${WRKSRC}; \
+ ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} \
+ ${_DISTDIR}/jargon-${JG_VER}.tar.gz \
+ ${EXTRACT_AFTER_ARGS}
+ ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} \
+ ${WRKSRC}/jargon-${JG_VER}/jarg${FJG_VER}.gz \
+ > ${WRKSRC}/jarg${FJG_VER}
+
+post-patch:
+ ${MV} ${WRKSRC}/catalogs.txt ${WRKSRC}/catalogs.txt.org
+ nkf -ed ${WRKSRC}/catalogs.txt.org > ${WRKSRC}/catalogs.txt
+ ${MV} ${WRKSRC}/gaiji/halfchar.txt ${WRKSRC}/gaiji/halfchar.txt.org
+ nkf -ed ${WRKSRC}/gaiji/halfchar.txt.org > ${WRKSRC}/gaiji/halfchar.txt
+
+do-build:
+ cd ${WRKSRC}; \
+ fpwmake -f ${MAKEFILE}; \
+ fpwmake -f ${MAKEFILE} catalogs
+
+do-install:
+ ${MKDIR} ${PREFIX}/share/dict/jargon-fpw/jargon/data
+ ${INSTALL_DATA} ${WRKSRC}/honmon ${PREFIX}/share/dict/jargon-fpw/jargon/data
+ ${MKDIR} ${PREFIX}/share/dict/jargon-fpw/jargon/gaiji
+ ${INSTALL_DATA} ${WRKSRC}/gai16h ${PREFIX}/share/dict/jargon-fpw/jargon/gaiji
+ ${INSTALL_DATA} ${WRKSRC}/catalogs ${PREFIX}/share/dict/jargon-fpw
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/jargon-fpw
+ ${INSTALL_DATA} ${WRKSRC}/readme.1st ${PREFIX}/share/doc/jargon-fpw
+ ${INSTALL_DATA} ${WRKSRC}/readme.txt ${PREFIX}/share/doc/jargon-fpw
+.endif
+
+.include <bsd.port.mk>
diff --git a/japanese/jargon-fpw/distinfo b/japanese/jargon-fpw/distinfo
new file mode 100644
index 000000000000..91193777881b
--- /dev/null
+++ b/japanese/jargon-fpw/distinfo
@@ -0,0 +1,2 @@
+MD5 (jarg-fpw1.1-src.tar.gz) = cbd5381b019434c7f50b80e5a98b13c8
+MD5 (jargon-4.2.0.tar.gz) = 2dc5deede894a837ec69db7380eea786
diff --git a/japanese/jargon-fpw/pkg-comment b/japanese/jargon-fpw/pkg-comment
new file mode 100644
index 000000000000..7cda9c0a9bf3
--- /dev/null
+++ b/japanese/jargon-fpw/pkg-comment
@@ -0,0 +1 @@
+The famous jargon file (EPWING V1 format)
diff --git a/japanese/jargon-fpw/pkg-descr b/japanese/jargon-fpw/pkg-descr
new file mode 100644
index 000000000000..df1237f9df7c
--- /dev/null
+++ b/japanese/jargon-fpw/pkg-descr
@@ -0,0 +1,8 @@
+This is the Jargon File, a comprehensive compendium of hacker slang
+illuminating many aspects of hackish tradition, folklore, and humor.
+Furthermore it is a dictionary converted from the original one into
+JIS X 4081 format (that is a subset of EPWING V1) by FreePWING. So it
+can be used by EPWING viewer on Unix and the other OS (e.g. Windows or
+MacOS). URL for this converted dictionary is
+
+WWW: http://www.sra.co.jp/people/m-kasahr/freepwing/books.html
diff --git a/japanese/jargon-fpw/pkg-plist b/japanese/jargon-fpw/pkg-plist
new file mode 100644
index 000000000000..471ba1f76bb3
--- /dev/null
+++ b/japanese/jargon-fpw/pkg-plist
@@ -0,0 +1,10 @@
+share/dict/jargon-fpw/jargon/data/honmon
+share/dict/jargon-fpw/jargon/gaiji/gai16h
+share/dict/jargon-fpw/catalogs
+share/doc/jargon-fpw/readme.1st
+share/doc/jargon-fpw/readme.txt
+@dirrm share/dict/jargon-fpw/jargon/data
+@dirrm share/dict/jargon-fpw/jargon/gaiji
+@dirrm share/dict/jargon-fpw/jargon
+@dirrm share/dict/jargon-fpw
+@dirrm share/doc/jargon-fpw