aboutsummaryrefslogtreecommitdiff
path: root/japanese/jcode.pl
diff options
context:
space:
mode:
authorMANTANI Nobutaka <nobutaka@FreeBSD.org>2018-04-30 13:12:56 +0000
committerMANTANI Nobutaka <nobutaka@FreeBSD.org>2018-04-30 13:12:56 +0000
commit3c189b47869a86315cb757d9018d135b9cfcb6d8 (patch)
treec674689d596f928b495d65c0c4c96d98183382d9 /japanese/jcode.pl
parent257236585265c3fcac55a7d30a77bd1024d24157 (diff)
downloadports-3c189b47869a86315cb757d9018d135b9cfcb6d8.tar.gz
ports-3c189b47869a86315cb757d9018d135b9cfcb6d8.zip
- Fix license information.
- Regenerate patch by 'make makepatch' to fix portlint warning. - Add NO_ARCH. PR: 222535 Submitted by: Yasuhiro KIMURA <yasu@utahime.org>
Notes
Notes: svn path=/head/; revision=468697
Diffstat (limited to 'japanese/jcode.pl')
-rw-r--r--japanese/jcode.pl/Makefile6
-rw-r--r--japanese/jcode.pl/files/LICENSE15
-rw-r--r--japanese/jcode.pl/files/patch-jcode.pl12
3 files changed, 26 insertions, 7 deletions
diff --git a/japanese/jcode.pl/Makefile b/japanese/jcode.pl/Makefile
index a981665d7cfe..3b1d8bd69069 100644
--- a/japanese/jcode.pl/Makefile
+++ b/japanese/jcode.pl/Makefile
@@ -12,12 +12,16 @@ EXTRACT_SUFX= # none
MAINTAINER= ports@FreeBSD.org
COMMENT= Perl library for Japanese character code conversion
-LICENSE= BSD
+LICENSE= JCODE.PL
+LICENSE_NAME= License of jcode.pl
+LICENSE_FILE= ${FILESDIR}/LICENSE
+LICENSE_PERMS= ${_LICENSE_PERMS_DEFAULT}
USES= perl5
USE_PERL5= run
NO_WRKSUBDIR= yes
NO_BUILD= yes
+NO_ARCH= yes
EXTRACT_CMD= ${CP}
EXTRACT_BEFORE_ARGS= # none
EXTRACT_AFTER_ARGS= ${WRKSRC}/${PORTNAME}
diff --git a/japanese/jcode.pl/files/LICENSE b/japanese/jcode.pl/files/LICENSE
new file mode 100644
index 000000000000..55442c344d9a
--- /dev/null
+++ b/japanese/jcode.pl/files/LICENSE
@@ -0,0 +1,15 @@
+(Following sentences are from jcode.pl-2.13.)
+
+Copyright (c) 1995-2000 Kazumasa Utashiro <utashiro@iij.ad.jp>
+Internet Initiative Japan Inc.
+3-13 Kanda Nishiki-cho, Chiyoda-ku, Tokyo 101-0054, Japan
+
+Copyright (c) 1992,1993,1994 Kazumasa Utashiro
+Software Research Associates, Inc.
+
+Use and redistribution for ANY PURPOSE are granted as long as all
+copyright notices are retained. Redistribution with modification
+is allowed provided that you make your modified version obviously
+distinguishable from the original one. THIS SOFTWARE IS PROVIDED
+BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES ARE
+DISCLAIMED.
diff --git a/japanese/jcode.pl/files/patch-jcode.pl b/japanese/jcode.pl/files/patch-jcode.pl
index 6d9cd45a0813..ed4d11861d57 100644
--- a/japanese/jcode.pl/files/patch-jcode.pl
+++ b/japanese/jcode.pl/files/patch-jcode.pl
@@ -1,7 +1,7 @@
---- jcode.pl.orig 2010-07-28 14:46:52.000000000 +0900
-+++ jcode.pl 2010-07-28 14:51:52.000000000 +0900
-@@ -681,7 +681,7 @@
-
+--- jcode.pl.orig 2017-09-23 14:20:47 UTC
++++ jcode.pl
+@@ -681,7 +681,7 @@ sub __z2h_jis {
+
sub z2h_euc {
local(*s, $n) = @_;
- &init_z2h_euc unless defined %z2h_euc;
@@ -9,8 +9,8 @@
$s =~ s/($re_euc_c|$re_euc_kana)/
$z2h_euc{$1} ? ($n++, $z2h_euc{$1}) : $1
/geo;
-@@ -690,7 +690,7 @@
-
+@@ -690,7 +690,7 @@ sub z2h_euc {
+
sub z2h_sjis {
local(*s, $n) = @_;
- &init_z2h_sjis unless defined %z2h_sjis;