aboutsummaryrefslogtreecommitdiff
path: root/japanese/jvim3
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2002-01-29 11:08:52 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2002-01-29 11:08:52 +0000
commit0b1020495087240f21a4fa421e92e457fc065310 (patch)
treea9275c6a984cfec29d075da9a46c02652d31293e /japanese/jvim3
parent656da512bff3c98531096fb649085c714a884a31 (diff)
downloadports-0b1020495087240f21a4fa421e92e457fc065310.tar.gz
ports-0b1020495087240f21a4fa421e92e457fc065310.zip
Use ${ECHO_CMD} instead of ${ECHO} where you mean the echo command;
the ECHO macro is set to "echo" by default, but it is set to "true" if make(1) is invoked with the -s option while ECHO_CMD is always set to the echo command. Use command macros where appropriate.
Notes
Notes: svn path=/head/; revision=53956
Diffstat (limited to 'japanese/jvim3')
-rw-r--r--japanese/jvim3/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/japanese/jvim3/Makefile b/japanese/jvim3/Makefile
index 2eff169563cc..dc209c40e56e 100644
--- a/japanese/jvim3/Makefile
+++ b/japanese/jvim3/Makefile
@@ -82,8 +82,8 @@ FEPLIBS+= -L${LOCALBASE}/lib -ljd -lcrypt
#
.if defined(INPUT_METHOD)
# Make a value of INPUT_METHOD
-## 'echo' and 'sed' in the next line cannot replace by '${ECHO}' and '${SED}'
-INPUT_METHOD!= echo ${INPUT_METHOD} | sed -e 's/^/-/' -e 's/ /+/g'
+## 'sed' in the next line cannot be replaced with '${SED}'
+INPUT_METHOD!= ${ECHO_CMD} ${INPUT_METHOD} | sed -e 's/^/-/' -e 's/ /+/g'
FEPOPT+= -DFEPCTRL
.if !defined(DIRECT_CANNA)
# For ONEW library
@@ -91,8 +91,8 @@ BUILD_DEPENDS+= ${LOCALBASE}/lib/libonew${INPUT_METHOD}.a:${PORTSDIR}/japanese/o
FEPOPT+= -DONEW
# If we use ONEW libray, then -lonew-* needs appear
# before the other libraries in ${FEPLIBS}.
-### 'sed' and 'echo' in the next line cannot replace by '${SED}' and ${ECHO}
-FEPLIBS!= echo ${FEPLIBS} | sed 's%^%-lonew${INPUT_METHOD} %'
+$## 'sed' in the next line cannot be replaced with '${SED}'
+FEPLIBS!= ${ECHO_CMD} ${FEPLIBS} | sed 's%^%-lonew${INPUT_METHOD} %'
FEPOBJS= feponew.o
###
.endif
@@ -123,9 +123,9 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/grep/grep ${PREFIX}/bin/jgrep
.if defined(INPUT_METHOD)
.if defined(DIRECT_CANNA)
- ${ECHO} "set fepctrl" > ${PREFIX}/etc/jvim3rc
+ ${ECHO_CMD} "set fepctrl" > ${PREFIX}/etc/jvim3rc
.else
- ${ECHO} "set fepctrl onewredraw" > ${PREFIX}/etc/jvim3rc
+ ${ECHO_CMD} "set fepctrl onewredraw" > ${PREFIX}/etc/jvim3rc
.endif
.endif
.if !defined(NOPORTDOCS)