aboutsummaryrefslogtreecommitdiff
path: root/japanese/jvim3
diff options
context:
space:
mode:
authorSatoshi Taoka <taoka@FreeBSD.org>2000-09-08 04:34:56 +0000
committerSatoshi Taoka <taoka@FreeBSD.org>2000-09-08 04:34:56 +0000
commita77a3c279b281e7aa45d0545404cacd1bfe885dd (patch)
treec8615695f9378417f7e0f158ca124a7779df1625 /japanese/jvim3
parent3f75a53ded20959017d22bd6df45551855caf843 (diff)
downloadports-a77a3c279b281e7aa45d0545404cacd1bfe885dd.tar.gz
ports-a77a3c279b281e7aa45d0545404cacd1bfe885dd.zip
(1) {chinese,korean,japanese}/Wnn (Wnn 4.2) was updated as follows:
(a) Its name was changed from Wnn to FreeWnn because Wnn6 which is a commercial software exits (b) Its license was changed to GPL. (c) The method to configure was changed from imake to GNU configure. (d) Relatively to the original Wnn, the Wnn in the ports tree were modified by me a lot. Most of the modifications were adopted into FreeWnn. (c) Header and library files are installed into ${LOCALBASE}/{lib,include} instead of ${X11BASE}/{lib,include}. (2) FreeWnn is divided into two ports FreeWnn-lib and FreeWnn-server in chinese, korean and japanese categories. The former is for libwnn and header files to compile client commands, and the files used in client commands. The latter is for a server to convert KANA to KANJI (Chinese character), and dictionaries and files used by the server.
Notes
Notes: svn path=/head/; revision=32414
Diffstat (limited to 'japanese/jvim3')
-rw-r--r--japanese/jvim3/Makefile17
1 files changed, 9 insertions, 8 deletions
diff --git a/japanese/jvim3/Makefile b/japanese/jvim3/Makefile
index e532e7f3d473..c4d27846df16 100644
--- a/japanese/jvim3/Makefile
+++ b/japanese/jvim3/Makefile
@@ -27,6 +27,8 @@ WRKSRC= ${WRKDIR}/vim
MAKEFILE= makjunix.mak
MAN1= jvim3.1
+.include <bsd.port.pre.mk>
+
JPATCH= jvim.2.1beta.tar.gz
PLIST_SUB= VERSION=${PORTVERSION}
PORT_DOCDIR= ${PREFIX}/share/doc/ja-jvim-${PORTVERSION}
@@ -55,16 +57,15 @@ INPUT_METHOD+= canna
LIB_DEPENDS+= canna.1:${PORTSDIR}/japanese/Canna
FEPLIBS+= -lcanna
.endif
-.if defined(WNN4)
-INPUT_METHOD+= wnn4
-BUILD_DEPENDS+= ${X11BASE}/lib/libjd.a:${PORTSDIR}/japanese/Wnn
-RUN_DEPENDS+= ${LOCALBASE}/lib/wnn/ja_JP/rk/2B_ROMKANA:${PORTSDIR}/japanese/Wnn
-FEPLIBS+= -L${X11BASE}/lib -ljd -lcrypt
+.if defined(FREEWNN)
+INPUT_METHOD+= freewnn
+LIB_DEPENDS+= jd.0:${PORTSDIR}/japanese/FreeWnn-lib
+FEPLIBS+= -L${LOCALBASE}/lib -ljd -lcrypt
.elif defined(WNN6)
INPUT_METHOD+= wnn6
-BUILD_DEPENDS+= ${X11BASE}/lib/libjd.a:${PORTSDIR}/japanese/Wnn
+LIB_DEPENDS+= jd.0:${PORTSDIR}/japanese/FreeWnn-lib
RUN_DEPENDS+= ${LOCALBASE}/lib/wnn/ja_JP/rk.wnn6/2B_ROMKANA:${PORTSDIR}/japanese/onew${INPUT_METHOD}
-FEPLIBS+= -L${X11BASE}/lib -ljd -lcrypt
+FEPLIBS+= -L${LOCALBASE}/lib -ljd -lcrypt
.endif
.endif # DIRECT_CANNA
#
@@ -117,4 +118,4 @@ do-install:
.endif
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>