aboutsummaryrefslogtreecommitdiff
path: root/japanese/kon2-16dot
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2019-11-25 23:25:52 +0000
committerBrooks Davis <brooks@FreeBSD.org>2019-11-25 23:25:52 +0000
commitf2ab4428432c7278a3dfc65dd19ae1a0e21e9b2f (patch)
tree52dbe489ef07375a512911ffcd740da2bf5bfaed /japanese/kon2-16dot
parent349193f6e0668b51b63df6aee192eed9a6930e18 (diff)
downloadports-f2ab4428432c7278a3dfc65dd19ae1a0e21e9b2f.tar.gz
ports-f2ab4428432c7278a3dfc65dd19ae1a0e21e9b2f.zip
Fix build with src r354909 applied.
The referenced change made NO_INSTALLLIB, NO_MAN, and NO_PROFILE into errors causing these ports that declare them and use the FreeBSD make infrastructure as part of their build to fail. When the offending variables occur in a BSD Makefile, NO_MAN becomes MAN= and NO_INSTALLLIB and NO_PROFILE become MK_INSTALLLIB=no and MK_PROFILE=no respectively. When declared in the environment they become WITHOUT_<FOO>.
Notes
Notes: svn path=/head/; revision=518434
Diffstat (limited to 'japanese/kon2-16dot')
-rw-r--r--japanese/kon2-16dot/files/patch-font_Makefile.FreeBSD22
-rw-r--r--japanese/kon2-16dot/files/patch-src_Makefile.FreeBSD13
2 files changed, 22 insertions, 13 deletions
diff --git a/japanese/kon2-16dot/files/patch-font_Makefile.FreeBSD b/japanese/kon2-16dot/files/patch-font_Makefile.FreeBSD
index 33d67d6ffc34..ca7eab56e89e 100644
--- a/japanese/kon2-16dot/files/patch-font_Makefile.FreeBSD
+++ b/japanese/kon2-16dot/files/patch-font_Makefile.FreeBSD
@@ -1,18 +1,26 @@
---- font/Makefile.FreeBSD.orig 1997-01-25 19:08:44.000000000 +0900
-+++ font/Makefile.FreeBSD 2014-01-31 11:01:37.000000000 +0900
-@@ -11,6 +11,7 @@
+--- font/Makefile.FreeBSD.orig 1997-01-25 10:08:44.000000000 +0000
++++ font/Makefile.FreeBSD 2019-11-22 22:25:17.725974000 +0000
+@@ -4,13 +4,12 @@
+ CFLAGS+= -I${.CURDIR}/../include
+ CLEANFILES= Makefile
+
+-NOMAN= YES
+-
+ .if exists(${.CURDIR}/../.config)
+ .include "${.CURDIR}/../.config"
.endif
PROG= fld
-+NO_MAN= yes
++MAN=
.if exists(${.OBJDIR}/../lib)
LIBOBJ= -L${.OBJDIR}/../lib
-@@ -20,4 +21,7 @@
+@@ -19,5 +18,8 @@
+ .endif
LDADD= ${LIBOBJ} -lgon
-
++
+install: ${PROG}
+ /usr/bin/install -s ${PROG} ${BINDIR}
-+
+
.include <bsd.prog.mk>
diff --git a/japanese/kon2-16dot/files/patch-src_Makefile.FreeBSD b/japanese/kon2-16dot/files/patch-src_Makefile.FreeBSD
index 951777eb3315..8452bc071322 100644
--- a/japanese/kon2-16dot/files/patch-src_Makefile.FreeBSD
+++ b/japanese/kon2-16dot/files/patch-src_Makefile.FreeBSD
@@ -1,5 +1,5 @@
---- src/Makefile.FreeBSD.orig 1997-01-30 10:29:25.000000000 +0900
-+++ src/Makefile.FreeBSD 2014-01-31 10:53:18.000000000 +0900
+--- src/Makefile.FreeBSD.orig 1997-01-30 01:29:25.000000000 +0000
++++ src/Makefile.FreeBSD 2019-11-22 22:25:55.221854000 +0000
@@ -1,12 +1,17 @@
# FreeBSD makefile for kon
# Tatsumi Hosokawa <hosokawa@jp.FreeBSD.org>
@@ -18,15 +18,16 @@
+.endif
LIBS+= -L${.CURDIR}/display -L${.CURDIR}/../lib -ldisplay -lgon
-NOMAN= YES
-+MK_MAN= no
++MAN=
CFLAGS+= -I${.CURDIR}/../include
CLEANFILES= Makefile
-@@ -28,4 +33,7 @@
+@@ -27,5 +32,8 @@
+ .if exists(${.CURDIR}/../.config)
.include "${.CURDIR}/../.config"
.endif
-
++
+install: ${PROG}
+ /usr/bin/install -s ${PROG} ${BINDIR}
-+
+
.include <bsd.prog.mk>