aboutsummaryrefslogtreecommitdiff
path: root/japanese/latex2html
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1999-05-03 04:04:20 +0000
committerSteve Price <steve@FreeBSD.org>1999-05-03 04:04:20 +0000
commit27119f9454bcf6ea32d2fd09b9d20882c1a0950f (patch)
tree74923032cebc34abea7dc4b90fc78de13297d523 /japanese/latex2html
parented2845b7a3856e2ed4432cf45919eb736c80e703 (diff)
downloadports-27119f9454bcf6ea32d2fd09b9d20882c1a0950f.tar.gz
ports-27119f9454bcf6ea32d2fd09b9d20882c1a0950f.zip
Notes
Diffstat (limited to 'japanese/latex2html')
-rw-r--r--japanese/latex2html/Makefile75
-rw-r--r--japanese/latex2html/distinfo2
-rw-r--r--japanese/latex2html/pkg-comment1
-rw-r--r--japanese/latex2html/pkg-descr7
-rw-r--r--japanese/latex2html/pkg-plist287
5 files changed, 372 insertions, 0 deletions
diff --git a/japanese/latex2html/Makefile b/japanese/latex2html/Makefile
new file mode 100644
index 000000000000..2dccbb24eadb
--- /dev/null
+++ b/japanese/latex2html/Makefile
@@ -0,0 +1,75 @@
+# New ports collection makefile for: ja-latex2html
+# Version required: 98.1jpatch-2.1
+# Date created: 3 Apr 1999
+# Whom: Sugimoto Sadahiro <ixtl@utmc.or.jp>
+#
+# $Id$
+#
+# Default image format is GIF.
+# If you prefer PNG to GIF, define USE_PNG (`make -DUSE_PNG`).
+
+DISTNAME= latex2html-98.1p1
+PKGNAME= ja-latex2html-98.1j2.1
+CATEGORIES= japanese textproc
+MASTER_SITES= http://www-dsed.llnl.gov/files/programs/unix/latex2html/sources/ \
+ ftp://ftp.mpn.com/pub/nikos/latex2html-mirror/sources/ \
+ http://www.topstudio.co.jp/~kmuto/software/latex2html/patch/98-1/
+DISTFILES= latex2html-98.1p1.tar.gz latex2html-98.1jpatch-2.1.tar.gz
+
+MAINTAINER= ixtl@utmc.or.jp
+
+RUN_DEPENDS= ${PREFIX}/bin/latex:${PORTSDIR}/print/latex \
+ ${PREFIX}/bin/dvips:${PORTSDIR}/print/dvips \
+ ${PREFIX}/bin/gs:${PORTSDIR}/print/ghostscript5 \
+ ${X11BASE}/bin/anytopnm:${PORTSDIR}/graphics/netpbm
+
+.ifdef USE_PNG
+RUN_DEPENDS += ${X11BASE}/bin/pnmtopng:${PORTSDIR}/graphics/pnmtopng
+.endif
+
+WRKSRC= ${WRKDIR}/latex2html
+USE_PERL5= yes
+NO_BUILD= yes
+
+L2HDIR= ${PREFIX}/share/jlatex2html
+
+post-patch:
+ @${PATCH} ${PATCH_ARGS} -o ${WRKDIR}/jlatex2html < ${WRKDIR}/jlatex2html.dif
+ @${PATCH} ${PATCH_ARGS} -o ${WRKDIR}/jlatex2html.config \
+ < ${WRKDIR}/jlatex2html.config.dif
+ @for file in latex2html/configure-pstoimg latex2html/texexpand \
+ latex2html/pstoimg latex2html/pstoimg_nopipes \
+ jlatex2html.config jlatex2html; do \
+ ${PERL} -pi.org -e \
+ "s|LATEX2HTMLDIR\s*=.*;|LATEX2HTMLDIR='${L2HDIR}';|; s|^use lib.*;|use lib '${L2HDIR}';|;" \
+ ${WRKDIR}/$$file; \
+ done
+.ifdef USE_PNG
+ @${PERL} -pi -e "s|IMAGE_TYPE=.*;|IMAGE_TYPE='png';|" \
+ ${WRKDIR}/jlatex2html.config
+.endif
+
+do-install:
+ @${MKDIR} ${L2HDIR}
+ @${INSTALL_DATA} ${FILESDIR}/local.pm ${L2HDIR}
+ @ for dir in makeseg IndicTeX-HTML cweb2html docs example icons.gif icons.png styles tests versions; do \
+ ${CP} -R ${WRKSRC}/$$dir ${L2HDIR}; \
+ done
+ @ for prog in Override.pm configure-pstoimg install-test makemap pstoimg\
+ pstoimg_nopipes texexpand; do \
+ ${INSTALL_SCRIPT} ${WRKSRC}/$$prog ${L2HDIR}; \
+ done
+ @ for file in FAQ MANIFEST README README.dvips dot.latex2html-init; do \
+ ${INSTALL_DATA} ${WRKSRC}/$$file ${L2HDIR}; \
+ done
+ @${MKDIR} ${PREFIX}/share/texmf/tex/latex/jlatex2html
+ @${INSTALL_DATA} ${WRKSRC}/texinputs/* ${PREFIX}/share/texmf/tex/latex/jlatex2html
+ @${INSTALL_SCRIPT} ${WRKDIR}/jlatex2html ${PREFIX}/bin
+ @${INSTALL_SCRIPT} ${WRKDIR}/jlatex2html ${L2HDIR}
+ @${INSTALL_DATA} ${WRKDIR}/jlatex2html.config ${L2HDIR}
+ @ for dir in styles versions; do \
+ ${MKDIR} ${L2HDIR}/$$dir; \
+ ${INSTALL_DATA} ${WRKDIR}/$$dir/* ${L2HDIR}/$$dir; \
+ done
+
+.include <bsd.port.mk>
diff --git a/japanese/latex2html/distinfo b/japanese/latex2html/distinfo
new file mode 100644
index 000000000000..6559c61a345a
--- /dev/null
+++ b/japanese/latex2html/distinfo
@@ -0,0 +1,2 @@
+MD5 (latex2html-98.1p1.tar.gz) = b424fa1e63a5fe7f19365a9050742292
+MD5 (latex2html-98.1jpatch-2.1.tar.gz) = 24e1ad23803c6a3d57a029c36f32e282
diff --git a/japanese/latex2html/pkg-comment b/japanese/latex2html/pkg-comment
new file mode 100644
index 000000000000..3d31e93f3073
--- /dev/null
+++ b/japanese/latex2html/pkg-comment
@@ -0,0 +1 @@
+Japanese latex2html with latex2html-98.1jpatch-2.1 patch
diff --git a/japanese/latex2html/pkg-descr b/japanese/latex2html/pkg-descr
new file mode 100644
index 000000000000..2519d954ccf9
--- /dev/null
+++ b/japanese/latex2html/pkg-descr
@@ -0,0 +1,7 @@
+Japanese latex2html with latex2html-98.1jpatch-2.1 patch
+
+This program can be used to convert LaTeX to HTML. It has many configuration
+options configurable by editing a configuration file. It can handle equations
+and postscript images as well.
+
+Package Maintainer: Sugimoto Sadahiro <ixtl@utmc.or.jp>
diff --git a/japanese/latex2html/pkg-plist b/japanese/latex2html/pkg-plist
new file mode 100644
index 000000000000..660faedf722b
--- /dev/null
+++ b/japanese/latex2html/pkg-plist
@@ -0,0 +1,287 @@
+share/jlatex2html/local.pm
+share/jlatex2html/makeseg/makeseg
+share/jlatex2html/makeseg/makeseg.tex
+share/jlatex2html/IndicTeX-HTML/hindi.sty
+share/jlatex2html/IndicTeX-HTML/telugu.perl
+share/jlatex2html/IndicTeX-HTML/tibetan.sty
+share/jlatex2html/IndicTeX-HTML/malyalam.perl
+share/jlatex2html/IndicTeX-HTML/gujarati.perl
+share/jlatex2html/IndicTeX-HTML/oriya.perl
+share/jlatex2html/IndicTeX-HTML/gurmukhi.perl
+share/jlatex2html/IndicTeX-HTML/telugu.sty
+share/jlatex2html/IndicTeX-HTML/sanskrit.sty
+share/jlatex2html/IndicTeX-HTML/sinhlese.sty
+share/jlatex2html/IndicTeX-HTML/README
+share/jlatex2html/IndicTeX-HTML/oriya.sty
+share/jlatex2html/IndicTeX-HTML/bengali.sty
+share/jlatex2html/IndicTeX-HTML/kannada.perl
+share/jlatex2html/IndicTeX-HTML/sinhlese.perl
+share/jlatex2html/IndicTeX-HTML/hindi.perl
+share/jlatex2html/IndicTeX-HTML/gujrathi.perl
+share/jlatex2html/IndicTeX-HTML/devnagri.perl
+share/jlatex2html/IndicTeX-HTML/bengali.perl
+share/jlatex2html/IndicTeX-HTML/indica.perl
+share/jlatex2html/IndicTeX-HTML/tibetan.perl
+share/jlatex2html/IndicTeX-HTML/tamil.perl
+share/jlatex2html/IndicTeX-HTML/malyalam.sty
+share/jlatex2html/IndicTeX-HTML/tamil.sty
+share/jlatex2html/IndicTeX-HTML/gujrathi.sty
+share/jlatex2html/IndicTeX-HTML/gujarati.sty
+share/jlatex2html/IndicTeX-HTML/gurmukhi.sty
+share/jlatex2html/IndicTeX-HTML/kannada.sty
+share/jlatex2html/IndicTeX-HTML/devnagri.sty
+share/jlatex2html/IndicTeX-HTML/indica.sty
+share/jlatex2html/IndicTeX-HTML/sanskrit.perl
+share/jlatex2html/cweb2html/wcltx.bib
+share/jlatex2html/cweb2html/linkex1.w
+share/jlatex2html/cweb2html/cweb2html
+share/jlatex2html/cweb2html/htcweb.tex
+share/jlatex2html/cweb2html/htcweb.sty
+share/jlatex2html/cweb2html/makemake.pl
+share/jlatex2html/cweb2html/README
+share/jlatex2html/cweb2html/Makefile
+share/jlatex2html/cweb2html/cweb.perl
+share/jlatex2html/cweb2html/htcweb.perl
+share/jlatex2html/cweb2html/wcltx.w
+share/jlatex2html/cweb2html/linkex2.w
+share/jlatex2html/docs/changebar/update.txt
+share/jlatex2html/docs/changebar/manifest.txt
+share/jlatex2html/docs/changebar/00readme.txt
+share/jlatex2html/docs/changebar/changebar.idx
+share/jlatex2html/docs/changebar/changebar.ins
+share/jlatex2html/docs/changebar/changebar.bug
+share/jlatex2html/docs/changebar/changebar.dtx
+share/jlatex2html/docs/changebar/00Contents
+share/jlatex2html/docs/changebar/catalog.txt
+share/jlatex2html/docs/changebar/chbar.sh
+share/jlatex2html/docs/hthtml/readme.hthtml
+share/jlatex2html/docs/hthtml/Makefile
+share/jlatex2html/docs/hthtml/hthtml.tex
+share/jlatex2html/docs/hthtml/hthtml.sty
+share/jlatex2html/docs/psfiles/eqarrB15.ps
+share/jlatex2html/docs/psfiles/eqn15.ps
+share/jlatex2html/docs/psfiles/eform.ps
+share/jlatex2html/docs/psfiles/HTMLtab.ps
+share/jlatex2html/docs/psfiles/figure.ps
+share/jlatex2html/docs/psfiles/eform2.ps
+share/jlatex2html/docs/psfiles/table.ps
+share/jlatex2html/docs/psfiles/eqarrB2.ps
+share/jlatex2html/docs/psfiles/eqarrB1.ps
+share/jlatex2html/docs/psfiles/dn.gif
+share/jlatex2html/docs/psfiles/eqn1.ps
+share/jlatex2html/docs/psfiles/eqn2.ps
+share/jlatex2html/docs/psfiles/eqarrA2.ps
+share/jlatex2html/docs/psfiles/eqarrA1.ps
+share/jlatex2html/docs/psfiles/eqarrA15.ps
+share/jlatex2html/docs/psfiles/up.gif
+share/jlatex2html/docs/manual.bbl
+share/jlatex2html/docs/manual.ind
+share/jlatex2html/docs/manhtml.tex
+share/jlatex2html/docs/changebar.sty
+share/jlatex2html/docs/credits.tex
+share/jlatex2html/docs/l2hfiles.dat
+share/jlatex2html/docs/Makefile
+share/jlatex2html/docs/justify.sty
+share/jlatex2html/docs/hypextra.tex
+share/jlatex2html/docs/manual.cb
+share/jlatex2html/docs/overview.tex
+share/jlatex2html/docs/htmllist.sty
+share/jlatex2html/docs/support.tex
+share/jlatex2html/docs/licence.tex
+share/jlatex2html/docs/l2hidx.ist
+share/jlatex2html/docs/features.tex
+share/jlatex2html/docs/html.sty
+share/jlatex2html/docs/url.sty
+share/jlatex2html/docs/l2hglo.ist
+share/jlatex2html/docs/problems.tex
+share/jlatex2html/docs/l2hman.sty
+share/jlatex2html/docs/appendix.tex
+share/jlatex2html/docs/userman.tex
+share/jlatex2html/docs/manual.index
+share/jlatex2html/docs/manual.tex
+share/jlatex2html/docs/manual.gls
+share/jlatex2html/example/sec1.tex
+share/jlatex2html/example/report.tex
+share/jlatex2html/example/sec2.tex
+share/jlatex2html/example/Makefile
+share/jlatex2html/icons.gif/previous_motif.gif
+share/jlatex2html/icons.gif/icons.html
+share/jlatex2html/icons.gif/blueball.gif
+share/jlatex2html/icons.gif/redball.gif
+share/jlatex2html/icons.gif/purpleball.gif
+share/jlatex2html/icons.gif/change_begin_right.gif
+share/jlatex2html/icons.gif/greenball.gif
+share/jlatex2html/icons.gif/previous_group_motif.gif
+share/jlatex2html/icons.gif/image.gif
+share/jlatex2html/icons.gif/contents.xbm
+share/jlatex2html/icons.gif/change_delete.gif
+share/jlatex2html/icons.gif/orangeball.gif
+share/jlatex2html/icons.gif/next_group_motif.gif
+share/jlatex2html/icons.gif/change_end_right.gif
+share/jlatex2html/icons.gif/invis_anchor.xbm
+share/jlatex2html/icons.gif/next_group_motif_gr.gif
+share/jlatex2html/icons.gif/previous_group_motif_gr.gif
+share/jlatex2html/icons.gif/up_motif.gif
+share/jlatex2html/icons.gif/cross_ref_motif.gif
+share/jlatex2html/icons.gif/contents_motif.gif
+share/jlatex2html/icons.gif/whiteball.gif
+share/jlatex2html/icons.gif/previous_motif_gr.gif
+share/jlatex2html/icons.gif/change_delete_right.gif
+share/jlatex2html/icons.gif/pinkball.gif
+share/jlatex2html/icons.gif/change_end.gif
+share/jlatex2html/icons.gif/foot_motif.gif
+share/jlatex2html/icons.gif/up_motif_gr.gif
+share/jlatex2html/icons.gif/next_motif_gr.gif
+share/jlatex2html/icons.gif/yellowball.gif
+share/jlatex2html/icons.gif/index_motif.gif
+share/jlatex2html/icons.gif/next_motif.gif
+share/jlatex2html/icons.gif/change_begin.gif
+share/jlatex2html/icons.png/previous_motif.png
+share/jlatex2html/icons.png/blueball.png
+share/jlatex2html/icons.png/redball.png
+share/jlatex2html/icons.png/purpleball.png
+share/jlatex2html/icons.png/greenball.png
+share/jlatex2html/icons.png/previous_group_motif.png
+share/jlatex2html/icons.png/image.png
+share/jlatex2html/icons.png/change_delete.png
+share/jlatex2html/icons.png/orangeball.png
+share/jlatex2html/icons.png/next_group_motif.png
+share/jlatex2html/icons.png/next_group_motif_gr.png
+share/jlatex2html/icons.png/previous_group_motif_gr.png
+share/jlatex2html/icons.png/up_motif.png
+share/jlatex2html/icons.png/cross_ref_motif.png
+share/jlatex2html/icons.png/contents_motif.png
+share/jlatex2html/icons.png/whiteball.png
+share/jlatex2html/icons.png/previous_motif_gr.png
+share/jlatex2html/icons.png/pinkball.png
+share/jlatex2html/icons.png/change_end.png
+share/jlatex2html/icons.png/foot_motif.png
+share/jlatex2html/icons.png/up_motif_gr.png
+share/jlatex2html/icons.png/next_motif_gr.png
+share/jlatex2html/icons.png/yellowball.png
+share/jlatex2html/icons.png/index_motif.png
+share/jlatex2html/icons.png/next_motif.png
+share/jlatex2html/icons.png/change_begin.png
+share/jlatex2html/styles/CJK.perl
+share/jlatex2html/styles/alltt.perl
+share/jlatex2html/styles/amsmath.perl
+share/jlatex2html/styles/chemsym.perl
+share/jlatex2html/styles/seminar.perl
+share/jlatex2html/styles/makeidx.perl
+share/jlatex2html/styles/amsbook.perl
+share/jlatex2html/styles/latexsym.perl
+share/jlatex2html/styles/changebar.perl
+share/jlatex2html/styles/havard.perl
+share/jlatex2html/styles/justify.perl
+share/jlatex2html/styles/natbib.perl
+share/jlatex2html/styles/colordvi.perl
+share/jlatex2html/styles/letter.perl
+share/jlatex2html/styles/inputenc.perl
+share/jlatex2html/styles/floatfig.perl
+share/jlatex2html/styles/floatflt.perl
+share/jlatex2html/styles/german.perl
+share/jlatex2html/styles/amsart.perl
+share/jlatex2html/styles/amssymb.perl
+share/jlatex2html/styles/amstex.perl
+share/jlatex2html/styles/rgb.txt
+share/jlatex2html/styles/report.perl
+share/jlatex2html/styles/wrapfig.perl
+share/jlatex2html/styles/xspace.perl
+share/jlatex2html/styles/more_amsmath.perl
+share/jlatex2html/styles/enumerate.perl
+share/jlatex2html/styles/crayola.txt
+share/jlatex2html/styles/graphics.perl
+share/jlatex2html/styles/graphicx.perl
+share/jlatex2html/styles/multicol.perl
+share/jlatex2html/styles/germanb.perl
+share/jlatex2html/styles/htmllist.perl
+share/jlatex2html/styles/heqn.perl
+share/jlatex2html/styles/html.perl
+share/jlatex2html/styles/hthtml.perl
+share/jlatex2html/styles/slides.perl
+share/jlatex2html/styles/article.perl
+share/jlatex2html/styles/amsfonts.perl
+share/jlatex2html/styles/verbatim.perl
+share/jlatex2html/styles/texdefs.perl
+share/jlatex2html/styles/francais.perl
+share/jlatex2html/styles/french.perl
+share/jlatex2html/styles/book.perl
+share/jlatex2html/styles/xy.perl
+share/jlatex2html/styles/frames.perl
+share/jlatex2html/styles/babel.perl
+share/jlatex2html/styles/harvard.perl
+share/jlatex2html/styles/epsfig.perl
+share/jlatex2html/styles/epsbox.perl
+share/jlatex2html/styles/nharvard.perl
+share/jlatex2html/styles/verbatimfiles.perl
+share/jlatex2html/styles/supertabular.perl
+share/jlatex2html/styles/longtable.perl
+share/jlatex2html/styles/color.perl
+share/jlatex2html/tests/jcl-verb.tex
+share/jlatex2html/tests/pages.tex
+share/jlatex2html/tests/pages1.eps
+share/jlatex2html/tests/jcl-env.tex
+share/jlatex2html/tests/jcl-pag.tex
+share/jlatex2html/tests/rrm-col.tex
+share/jlatex2html/versions/lang.pl
+share/jlatex2html/versions/html3_2.pl
+share/jlatex2html/versions/html2_2.pl
+share/jlatex2html/versions/html3_0.pl
+share/jlatex2html/versions/html4_0.pl
+share/jlatex2html/versions/html3_1.pl
+share/jlatex2html/versions/html2_1.pl
+share/jlatex2html/versions/latin6.pl
+share/jlatex2html/versions/latin4.pl
+share/jlatex2html/versions/latin5.pl
+share/jlatex2html/versions/latin2.pl
+share/jlatex2html/versions/latin3.pl
+share/jlatex2html/versions/latin1.pl
+share/jlatex2html/versions/i18n.pl
+share/jlatex2html/versions/unicode.pl
+share/jlatex2html/versions/table.pl
+share/jlatex2html/versions/math.pl
+share/jlatex2html/configure-pstoimg
+share/jlatex2html/install-test
+share/jlatex2html/makemap
+share/jlatex2html/pstoimg
+share/jlatex2html/pstoimg_nopipes
+share/jlatex2html/texexpand
+share/jlatex2html/FAQ
+share/jlatex2html/MANIFEST
+share/jlatex2html/Override.pm
+share/jlatex2html/README
+share/jlatex2html/README.dvips
+share/jlatex2html/dot.latex2html-init
+share/texmf/tex/latex/jlatex2html/floatflt.ins
+share/texmf/tex/latex/jlatex2html/frames.sty
+share/texmf/tex/latex/jlatex2html/heqn.sty
+share/texmf/tex/latex/jlatex2html/hthtml.sty
+share/texmf/tex/latex/jlatex2html/html.sty
+share/texmf/tex/latex/jlatex2html/htmllist.sty
+share/texmf/tex/latex/jlatex2html/justify.sty
+share/texmf/tex/latex/jlatex2html/ldump.sty
+share/texmf/tex/latex/jlatex2html/url.sty
+share/texmf/tex/latex/jlatex2html/verbatimfiles.sty
+bin/jlatex2html
+share/jlatex2html/styles/ascmac.perl
+share/jlatex2html/styles/japanese.perl
+share/jlatex2html/styles/jarticle.perl
+share/jlatex2html/styles/jbook.perl
+share/jlatex2html/styles/jreport.perl
+share/jlatex2html/jlatex2html.config
+share/jlatex2html/jlatex2html
+@dirrm share/jlatex2html/makeseg
+@dirrm share/jlatex2html/IndicTeX-HTML
+@dirrm share/jlatex2html/cweb2html
+@dirrm share/jlatex2html/docs/changebar
+@dirrm share/jlatex2html/docs/hthtml
+@dirrm share/jlatex2html/docs/psfiles
+@dirrm share/jlatex2html/docs
+@dirrm share/jlatex2html/example
+@dirrm share/jlatex2html/icons.gif
+@dirrm share/jlatex2html/icons.png
+@dirrm share/jlatex2html/styles
+@dirrm share/jlatex2html/tests
+@dirrm share/jlatex2html/versions
+@dirrm share/texmf/tex/latex/jlatex2html
+@dirrm share/jlatex2html