aboutsummaryrefslogtreecommitdiff
path: root/japanese/libslang
diff options
context:
space:
mode:
authorSatoshi Taoka <taoka@FreeBSD.org>1999-09-07 04:20:14 +0000
committerSatoshi Taoka <taoka@FreeBSD.org>1999-09-07 04:20:14 +0000
commit55f7f0b20127fddcf737b2afb3f209896aa327e4 (patch)
tree801b06fed756bf62b438ef4ca46bea2a77b9902f /japanese/libslang
parentece909b0d12d3a70e8e6b1ac6eff38d295db154b (diff)
downloadports-55f7f0b20127fddcf737b2afb3f209896aa327e4.tar.gz
ports-55f7f0b20127fddcf737b2afb3f209896aa327e4.zip
Updated to 1.3.8j067
PR: 13592 Submitted by: IWASHITA Yoji <shuna@pop16.odn.ne.jp>
Notes
Notes: svn path=/head/; revision=21348
Diffstat (limited to 'japanese/libslang')
-rw-r--r--japanese/libslang/Makefile16
-rw-r--r--japanese/libslang/distinfo2
-rw-r--r--japanese/libslang/files/patch-aa91
-rw-r--r--japanese/libslang/files/patch-ac12
-rw-r--r--japanese/libslang/files/patch-ad57
-rw-r--r--japanese/libslang/pkg-plist39
6 files changed, 109 insertions, 108 deletions
diff --git a/japanese/libslang/Makefile b/japanese/libslang/Makefile
index 7d317673a968..6cb484a8eef4 100644
--- a/japanese/libslang/Makefile
+++ b/japanese/libslang/Makefile
@@ -1,13 +1,13 @@
# New ports collection makefile for: ja-S-lang library
-# Version required: 1.2.2_j055
-# Date created: 22 April 1999
+# Version required: 1.3.8_j067
+# Date created: 3 September 1999
# Whom: IWASHITA Yoji <shuna@pop16.odn.ne.jp>
#
-# $FreeBSD$
+# $Id$
#
-DISTNAME= slang1.2.2_j055
-PKGNAME= ja-libslang-1.2.2.j055
+DISTNAME= slang-1.3.8__J067
+PKGNAME= ja-libslang-1.3.8.j067
CATEGORIES= japanese devel
MASTER_SITES= http://home.sprintmail.com/~kikutani/slang/
@@ -16,14 +16,10 @@ MAINTAINER= mega@minz.org
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --includedir=${PREFIX}/include/slang
ALL_TARGET= all elf
-INSTALL_TARGET= install install-elf
-WRKSRC= ${WRKDIR}/slang
+INSTALL_TARGET= install-elf
post-install:
${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
- ${ECHO} "===> Installing documents in ${PREFIX}/share/doc/slang"
- @${MKDIR} ${PREFIX}/share/doc/slang
- ${CP} -R ${WRKSRC}/doc/* ${PREFIX}/share/doc/slang
${CP} ${WRKSRC}/slang-j.doc ${PREFIX}/share/doc/slang
.include <bsd.port.mk>
diff --git a/japanese/libslang/distinfo b/japanese/libslang/distinfo
index 94064676d7de..8ab2656e41b0 100644
--- a/japanese/libslang/distinfo
+++ b/japanese/libslang/distinfo
@@ -1 +1 @@
-MD5 (slang1.2.2_j055.tar.gz) = 0e80f4200b920d0cf07d9d03d58f76bf
+MD5 (slang-1.3.8__J067.tar.gz) = 3e1d4b4d35d479091fb3f6a876433d8b
diff --git a/japanese/libslang/files/patch-aa b/japanese/libslang/files/patch-aa
index 7a63728e219e..1bae81a23617 100644
--- a/japanese/libslang/files/patch-aa
+++ b/japanese/libslang/files/patch-aa
@@ -1,12 +1,10 @@
-*** configure.orig Mon Apr 13 12:57:32 1998
---- configure Wed Apr 21 11:05:02 1999
+*** configure.orig Wed Jul 14 05:30:30 1999
+--- configure Fri Sep 3 04:10:29 1999
***************
-*** 1489,1519 ****
-
- echo $ac_n "checking SLANG_VERSION""... $ac_c" 1>&6
- echo "configure:1492: checking SLANG_VERSION" >&5
-! slang_version=`grep "^#define *SLANG_VERSION " $srcdir/src/slang.h |
-! awk '{ print $3 }'`
+*** 2025,2038 ****
+ echo "configure:2026: checking SLANG_VERSION" >&5
+ slang_version=`grep "^#define *SLANG_VERSION " $srcdir/src/slang.h |
+ awk '{ print $3 }'`
! slang_major_version=`echo $slang_version |
! awk '{ print int($1/10000) }'`
! slang_minor_version=`echo $slang_version $slang_major_version |
@@ -14,10 +12,21 @@
! slang_mminor_version=`echo $slang_version $slang_major_version $slang_minor_version |
! awk '{ print ($1 - $2*10000 - $3*100) }'`
!
-! slang_minor_version=$slang_minor_version.$slang_mminor_version
- echo "$ac_t""$slang_major_version.$slang_minor_version" 1>&6
-
+! slang_minor_version="$slang_minor_version.$slang_mminor_version"
+ slang_version="$slang_major_version.$slang_minor_version"
+ echo "$ac_t""$slang_version" 1>&6
+
+--- 2025,2032 ----
+ echo "configure:2026: checking SLANG_VERSION" >&5
+ slang_version=`grep "^#define *SLANG_VERSION " $srcdir/src/slang.h |
+ awk '{ print $3 }'`
+! slang_major_version=2
+! slang_minor_version=1
+ slang_version="$slang_major_version.$slang_minor_version"
+ echo "$ac_t""$slang_version" 1>&6
+***************
+*** 2040,2054 ****
@@ -33,15 +42,7 @@
ELF_LINK_CMD="\$(ELF_LINK)"
fi
---- 1489,1511 ----
-
- echo $ac_n "checking SLANG_VERSION""... $ac_c" 1>&6
- echo "configure:1492: checking SLANG_VERSION" >&5
-! slang_major_version=2
-! slang_minor_version=0
- echo "$ac_t""$slang_major_version.$slang_minor_version" 1>&6
-
-
+--- 2034,2048 ----
@@ -58,21 +59,41 @@
fi
***************
-*** 2033,2048 ****
+*** 2569,2586 ****
+
+
+ echo ""
+! echo "Configuration complete. You may need to edit src/Makefile."
+! echo "You are compiling SLANG with the following compiler configuration:"
+! echo " CC =" "$CC"
+! echo " CFLAGS =" "$CFLAGS"
+! echo " LDFLAGS =" "$LDFLAGS $DYNAMIC_LINK_FLAGS"
+! echo ""
+! echo " ELF_CC =" "$ELF_CC"
+! echo " ELF_LINK =" "$ELF_LINK"
+! echo "ELF_CFLAGS=" "$ELF_CFLAGS"
+! echo ""
+ echo "Installation Prefix:" "$prefix"
+ echo ""
+! echo "See also src/sl-feat.h for various features."
+! echo "Type 'make' to build normal library."
+! echo "On ELF systems, type 'make elf' to create ELF shared library."
+--- 2563,2580 ----
echo ""
-- echo "Configuration complete. You may need to edit src/Makefile."
-- echo "You are compiling SLANG with the following compiler configuration:"
-- echo " CC =" "$CC"
-- echo " CFLAGS =" "$CFLAGS"
-- echo " LDFLAGS =" "$LDFLAGS"
-- echo ""
-- echo " ELF_CC =" "$ELF_CC"
-- echo " ELF_LINK =" "$ELF_LINK"
-- echo "ELF_CFLAGS=" "$ELF_CFLAGS"
-- echo ""
-- echo "See also src/sl-feat.h for various features."
-- echo "Type 'make' to build normal library."
-- echo "On ELF systems, type 'make elf' to create ELF shared library."
---- 2025,2027 ----
+! #echo "Configuration complete. You may need to edit src/Makefile."
+! #echo "You are compiling SLANG with the following compiler configuration:"
+! #echo " CC =" "$CC"
+! #echo " CFLAGS =" "$CFLAGS"
+! #echo " LDFLAGS =" "$LDFLAGS $DYNAMIC_LINK_FLAGS"
+! #echo ""
+! #echo " ELF_CC =" "$ELF_CC"
+! #echo " ELF_LINK =" "$ELF_LINK"
+! #echo "ELF_CFLAGS=" "$ELF_CFLAGS"
+! #echo ""
+ echo "Installation Prefix:" "$prefix"
+ echo ""
+! #echo "See also src/sl-feat.h for various features."
+! #echo "Type 'make' to build normal library."
+! #echo "On ELF systems, type 'make elf' to create ELF shared library."
diff --git a/japanese/libslang/files/patch-ac b/japanese/libslang/files/patch-ac
index a1a784991261..a10a10967c64 100644
--- a/japanese/libslang/files/patch-ac
+++ b/japanese/libslang/files/patch-ac
@@ -1,17 +1,17 @@
-*** autoconf/Makefile.in.orig Mon Apr 13 12:57:32 1998
---- autoconf/Makefile.in Thu Apr 22 03:32:46 1999
+*** autoconf/Makefile.in.orig Wed Jul 14 05:30:30 1999
+--- autoconf/Makefile.in Fri Sep 3 03:54:21 1999
***************
*** 10,16 ****
cd src; $(MAKE) all
elf:
cd src; $(MAKE) elf
- @echo Use make install-elf to install it.
+ runtests:
+ cd src/test; $(MAKE)
demos:
- cd demo; $(MAKE)
- clean:
--- 10,15 ----
***************
-*** 21,35 ****
+*** 23,37 ****
cd src; $(MAKE) install
install-elf:
cd src; $(MAKE) install-elf
@@ -27,4 +27,4 @@
#
distclean:
/bin/rm -f *~ Makefile config.status config.log config.cache files.pck
---- 20,27 ----
+--- 22,29 ----
diff --git a/japanese/libslang/files/patch-ad b/japanese/libslang/files/patch-ad
index 99be7feaa171..a4c26a605c03 100644
--- a/japanese/libslang/files/patch-ad
+++ b/japanese/libslang/files/patch-ad
@@ -1,8 +1,25 @@
-*** src/Makefile.in.orig Wed Nov 25 23:02:20 1998
---- src/Makefile.in Thu Apr 22 03:04:38 1999
+*** src/Makefile.in.orig Mon Jul 19 21:28:29 1999
+--- src/Makefile.in Fri Sep 3 04:26:09 1999
***************
-*** 68,74 ****
---- 68,78 ----
+*** 36,42 ****
+ exec_prefix = @exec_prefix@
+ install_lib_dir = @libdir@
+ install_include_dir = @includedir@
+! install_doc_dir = $(prefix)/doc/slang/@slang_version@
+ DOC_FILES = ../changes.txt ../COPY* ../doc/slangdoc.html ../doc/text/*.txt
+ #---------------------------------------------------------------------------
+ # Misc commands (safe to leave these untouched)
+--- 36,42 ----
+ exec_prefix = @exec_prefix@
+ install_lib_dir = @libdir@
+ install_include_dir = @includedir@
+! install_doc_dir = $(prefix)/share/doc/slang
+ DOC_FILES = ../changes.txt ../COPY* ../doc/slangdoc.html ../doc/text/*.txt
+ #---------------------------------------------------------------------------
+ # Misc commands (safe to leave these untouched)
+***************
+*** 74,80 ****
+--- 74,84 ----
ELFLIB = lib$(THIS_LIB).so#
ELFLIB_MAJOR = $(ELFLIB).$(ELF_MAJOR_VERSION)#
@@ -15,26 +32,12 @@
ELFDIR_ELF_LIB = $(ELFDIR)/$(ELFLIB_MAJOR_MINOR)#
***************
-*** 126,136 ****
- $(MKINSDIR) $(install_include_dir)
- $(install_lib_dir):
- $(MKINSDIR) $(install_lib_dir)
-! install-elf: install elf $(install_lib_dir) $(install_include_dir) $(ELFDIR_ELF_LIB)
- $(INSTALL_DATA) $(SRCDIR)/slang.h $(install_include_dir)
- $(INSTALL_DATA) $(SRCDIR)/slcurses.h $(install_include_dir)
-! -$(RM) $(install_lib_dir)/$(ELFLIB)
-! -$(RM) $(install_lib_dir)/$(ELFLIB_MAJOR)
- @echo installing $(ELFLIB_MAJOR_MINOR) in $(install_lib_dir)
- $(INSTALL_DATA) $(ELFDIR_ELF_LIB) $(install_lib_dir)
- @echo creating symbolic links to $(ELFLIB_MAJOR_MINOR)
---- 130,139 ----
- $(MKINSDIR) $(install_include_dir)
- $(install_lib_dir):
- $(MKINSDIR) $(install_lib_dir)
-! install-elf: elf $(install_lib_dir) $(install_include_dir) $(ELFDIR_ELF_LIB)
- $(INSTALL_DATA) $(SRCDIR)/slang.h $(install_include_dir)
- $(INSTALL_DATA) $(SRCDIR)/slcurses.h $(install_include_dir)
-! $(INSTALL_DATA) $(SRCDIR)/slkanji.h $(install_include_dir)
- @echo installing $(ELFLIB_MAJOR_MINOR) in $(install_lib_dir)
- $(INSTALL_DATA) $(ELFDIR_ELF_LIB) $(install_lib_dir)
- @echo creating symbolic links to $(ELFLIB_MAJOR_MINOR)
+*** 106,111 ****
+--- 110,116 ----
+ $(ELFDIR_ELF_LIB): $(ELFDIR) $(CONFIG_H) $(ELFOBJS)
+ -$(RM) $(ELFDIR_ELF_LIB)
+ cd $(ELFDIR); $(ELF_LINK_CMD) -o $(ELFLIB_MAJOR_MINOR) $(OFILES) $(ELF_DEP_LIBS)
++ cd $(ELFDIR); strip $(ELFLIB_MAJOR_MINOR)
+ cd $(ELFDIR); $(RM) $(ELFLIB); $(LN) $(ELFLIB_MAJOR_MINOR) $(ELFLIB)
+ @echo ""
+ @echo $(ELFLIB_MAJOR_MINOR) created in $(ELFDIR).
diff --git a/japanese/libslang/pkg-plist b/japanese/libslang/pkg-plist
index b873bc0d89d8..8ee30b3c63c4 100644
--- a/japanese/libslang/pkg-plist
+++ b/japanese/libslang/pkg-plist
@@ -8,34 +8,15 @@ include/slang/slang.h
include/slang/slcurses.h
include/slang/slkanji.h
@dirrm include/slang
+share/doc/slang/COPYING
+share/doc/slang/COPYING.ART
+share/doc/slang/COPYING.GPL
+share/doc/slang/COPYRIGHT
+share/doc/slang/changes.txt
+share/doc/slang/cref.txt
+share/doc/slang/cslang.txt
+share/doc/slang/slang.txt
+share/doc/slang/slangdoc.html
+share/doc/slang/slangfun.txt
share/doc/slang/slang-j.doc
-share/doc/slang/README
-share/doc/slang/OLD/help/README
-share/doc/slang/OLD/help/makefile.djg
-share/doc/slang/OLD/help/makefile.os2
-share/doc/slang/OLD/help/makefile.unx
-share/doc/slang/OLD/help/slang.hlp
-share/doc/slang/OLD/help/slhelp.c
-@dirrm share/doc/slang/OLD/help
-@dirrm share/doc/slang/OLD
-share/doc/slang/internal/rpn.txt
-@dirrm share/doc/slang/internal
-share/doc/slang/text/cref.txt
-share/doc/slang/text/cslang.txt
-share/doc/slang/text/slang.txt
-share/doc/slang/text/slangfun.txt
-@dirrm share/doc/slang/text
-share/doc/slang/tm/tools/Makefile
-share/doc/slang/tm/tools/sl2tm.c
-share/doc/slang/tm/tools/tm2txt.c
-@dirrm share/doc/slang/tm/tools
-share/doc/slang/tm/Makefile
-share/doc/slang/tm/copyright.tm
-share/doc/slang/tm/cref.tm
-share/doc/slang/tm/cslang.tm
-share/doc/slang/tm/fixtex.sl
-share/doc/slang/tm/preface.tm
-share/doc/slang/tm/slang.tm
-share/doc/slang/tm/slangfun.tm
-@dirrm share/doc/slang/tm
@dirrm share/doc/slang