aboutsummaryrefslogtreecommitdiff
path: root/japanese/lynx-current
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>1998-11-19 15:04:32 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>1998-11-19 15:04:32 +0000
commita3cd793e8386ac88a3a4a239e09145368ae957a6 (patch)
tree0e5bb1950978066ac627d85efb47e985a090e3ba /japanese/lynx-current
parent7c29948d003f2d470351a276967a6c178061f9a2 (diff)
downloadports-a3cd793e8386ac88a3a4a239e09145368ae957a6.tar.gz
ports-a3cd793e8386ac88a3a4a239e09145368ae957a6.zip
Update to 2.8.2dev.2.
Submitted by: Shigeyuki FUKUSHIMA <shige@kuis.kyoto-u.ac.jp>
Notes
Notes: svn path=/head/; revision=14682
Diffstat (limited to 'japanese/lynx-current')
-rw-r--r--japanese/lynx-current/Makefile21
-rw-r--r--japanese/lynx-current/distinfo2
-rw-r--r--japanese/lynx-current/files/patch-ai24
3 files changed, 38 insertions, 9 deletions
diff --git a/japanese/lynx-current/Makefile b/japanese/lynx-current/Makefile
index dc1017fa1595..deb2daef44dd 100644
--- a/japanese/lynx-current/Makefile
+++ b/japanese/lynx-current/Makefile
@@ -1,27 +1,32 @@
# New ports collection makefile for: ja-lynx-current
-# Version required: 2.8.1dev.X
+# Version required: 2.8.2dev.X
# Date created: 10 August 1998
# Whom: Shigeyuki FUKUSHIMA <shige@kuis.kyoto-u.ac.jp>
#
-# $Id: Makefile,v 1.3 1998/10/06 22:29:29 asami Exp $
+# $Id: Makefile,v 1.4 1998/11/14 16:57:42 kuriyama Exp $
#
-DISTNAME= lynx2.8.2dev.1
-PKGNAME= ja-lynx-2.8.2.1
+DISTNAME= lynx2.8.2dev.2
+PKGNAME= ja-lynx-2.8.2.2
CATEGORIES= japanese www
MASTER_SITES= ftp://sol.slcc.edu/pub/lynx/current/
MAINTAINER= shige@kuis.kyoto-u.ac.jp
NO_LATEST_LINK= YES
-WRKSRC= ${WRKDIR}/lynx2-8-1
+WRKSRC= ${WRKDIR}/lynx2-8-2
GNU_CONFIGURE= YES
-CONFIGURE_ARGS= --with-screen=ncurses --with-zlib --libdir="${PREFIX}/etc"
+CONFIGURE_ARGS= --with-screen=ncurses --with-zlib \
+ --libdir="${PREFIX}/etc" --disable-nls --enable-default-colors
MAKEFILE= makefile
-INSTALL_TARGET= install install-help install-doc
+INSTALL_TARGET= install install-help
MAN1= lynx.1
post-install:
- chown -R ${SHAREOWN}:${SHAREGRP} ${PREFIX}/lib/lynx_help
+.if !defined(NOPORTDOCS)
+ @(cd ${WRKSRC} ; make install-doc)
+ @chown -R ${SHAREOWN}:${SHAREGRP} ${PREFIX}/share/doc/lynx
+.endif
+ @chown -R ${SHAREOWN}:${SHAREGRP} ${PREFIX}/lib/lynx_help
.include <bsd.port.mk>
diff --git a/japanese/lynx-current/distinfo b/japanese/lynx-current/distinfo
index d71a257eebca..f54c7a73f583 100644
--- a/japanese/lynx-current/distinfo
+++ b/japanese/lynx-current/distinfo
@@ -1 +1 @@
-MD5 (lynx2.8.2dev.1.tar.gz) = fb8d6ec40da7d437514d841209421d2d
+MD5 (lynx2.8.2dev.2.tar.gz) = 2a692dc5175d429fd8c255f08b5be937
diff --git a/japanese/lynx-current/files/patch-ai b/japanese/lynx-current/files/patch-ai
new file mode 100644
index 000000000000..30d33f5030be
--- /dev/null
+++ b/japanese/lynx-current/files/patch-ai
@@ -0,0 +1,24 @@
+--- src/LYCurses.c.orig Wed Nov 11 11:11:52 1998
++++ src/LYCurses.c Wed Nov 11 11:10:32 1998
+@@ -1679,6 +1679,13 @@
+
+ PUBLIC void lynx_force_repaint NOARGS
+ {
++/*
++ * This code is harmful to display bold links.
++ * Already set COLOR attributes?
++ * Therefore we do not need this code.
++ * --- by shige@kuis.kyoto-u.ac.jp
++ */
++#if 0 /* do not need */
+ #if defined(COLOR_CURSES)
+ chtype a;
+ #ifndef USE_COLOR_STYLE
+@@ -1693,6 +1700,7 @@
+ #endif
+ attrset(a);
+ #endif /* COLOR_CURSES */
++#endif /* do not need */
+ clearok(curscr, TRUE);
+ }
+