aboutsummaryrefslogtreecommitdiff
path: root/japanese/mh
diff options
context:
space:
mode:
authorMotoyuki Konno <motoyuki@FreeBSD.org>2003-07-19 05:55:00 +0000
committerMotoyuki Konno <motoyuki@FreeBSD.org>2003-07-19 05:55:00 +0000
commitfea9346f1d73764a2148b051a6d7d0ecdf77a2c1 (patch)
tree7c823a9e4eca7ced785190b6d6835a5879afb1ea /japanese/mh
parent001d1e7f240c5cf01b76665774ec78749da1f801 (diff)
downloadports-fea9346f1d73764a2148b051a6d7d0ecdf77a2c1.tar.gz
ports-fea9346f1d73764a2148b051a6d7d0ecdf77a2c1.zip
* Update to 6.8.4 JP 3.05.
* Use <stdarg.h> instead of <varargs.h> [1]. Use of <varargs.h> causes error on FreeBSD 5-current with GCC 3.3.1. Submitted by: Hajimu UMEMOTO <ume@mahoroba.org> [1] PR: ports/54524
Notes
Notes: svn path=/head/; revision=85178
Diffstat (limited to 'japanese/mh')
-rw-r--r--japanese/mh/Makefile6
-rw-r--r--japanese/mh/distinfo2
-rw-r--r--japanese/mh/files/patch-al38
-rw-r--r--japanese/mh/files/patch-am33
-rw-r--r--japanese/mh/files/patch-an34
-rw-r--r--japanese/mh/files/patch-ao32
-rw-r--r--japanese/mh/files/patch-h:mh.h13
-rw-r--r--japanese/mh/files/patch-sbr:concat.c60
8 files changed, 92 insertions, 126 deletions
diff --git a/japanese/mh/Makefile b/japanese/mh/Makefile
index 7b69a8b586db..9471d98d0542 100644
--- a/japanese/mh/Makefile
+++ b/japanese/mh/Makefile
@@ -7,11 +7,11 @@
PORTNAME= mh
PORTVERSION= ${VERSION}.j${JP_VERSION}
-PORTREVISION= 1
CATEGORIES= japanese mail
-MASTER_SITES= ${MASTER_SITE_PORTS_JP} \
+MASTER_SITES= ${MASTER_SITE_LOCAL} \
ftp://komadori.planet.sci.kobe-u.ac.jp/pub/MH/ \
ftp://ftp.chem.eng.himeji-tech.ac.jp/pub/net/mh/
+MASTER_SITES_SUBDIR= motoyuki
DISTNAME= ${PORTNAME}-${VERSION}-JP-${JP_VERSION}
MAINTAINER= motoyuki@freebsd.org
@@ -21,7 +21,7 @@ BUILD_DEPENDS= jless:${PORTSDIR}/japanese/less
RUN_DEPENDS= jless:${PORTSDIR}/japanese/less
VERSION= 6.8.4
-JP_VERSION= 3.03
+JP_VERSION= 3.05
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-batchmode \
diff --git a/japanese/mh/distinfo b/japanese/mh/distinfo
index 26b0e71139b1..f6f4957be116 100644
--- a/japanese/mh/distinfo
+++ b/japanese/mh/distinfo
@@ -1 +1 @@
-MD5 (mh-6.8.4-JP-3.03.tar.gz) = 82e7bebde8d6697a03f35021991bff2b
+MD5 (mh-6.8.4-JP-3.05.tar.gz) = 2f307cfb49969cb7ec1d1db78a276507
diff --git a/japanese/mh/files/patch-al b/japanese/mh/files/patch-al
deleted file mode 100644
index 37c618abf428..000000000000
--- a/japanese/mh/files/patch-al
+++ /dev/null
@@ -1,38 +0,0 @@
---- zotnet/tws/dtime.c.orig Tue Feb 9 20:30:00 1999
-+++ zotnet/tws/dtime.c Tue Jan 4 20:46:46 2000
-@@ -170,7 +170,7 @@
- tw.tw_hour = tm -> tm_hour;
- tw.tw_mday = tm -> tm_mday;
- tw.tw_mon = tm -> tm_mon;
-- tw.tw_year = tm -> tm_year + CENTURY;
-+ tw.tw_year = tm -> tm_year + 1900;
- tw.tw_wday = tm -> tm_wday;
- tw.tw_yday = tm -> tm_yday;
- if (tm -> tm_isdst)
-@@ -212,7 +212,7 @@
- tw.tw_hour = tm -> tm_hour;
- tw.tw_mday = tm -> tm_mday;
- tw.tw_mon = tm -> tm_mon;
-- tw.tw_year = tm -> tm_year + CENTURY;
-+ tw.tw_year = tm -> tm_year + 1900;
- tw.tw_wday = tm -> tm_wday;
- tw.tw_yday = tm -> tm_yday;
- if (tm -> tm_isdst)
-@@ -370,12 +370,14 @@
- || (min = tw -> tw_min) < 0 || min > 59
- || (hour = tw -> tw_hour) < 0 || hour > 23
- || (mday = tw -> tw_mday) < 1 || mday > 31
-- || (mon = tw -> tw_mon + 1) < 1 || mon > 12)
-+ || (mon = tw -> tw_mon + 1) < 1 || mon > 12
-+ || (year = tw -> tw_year) < 0)
- return (tw -> tw_clock = -1L);
-- year = tw -> tw_year;
-
- result = 0L;
-- if (year < 100)
-+ if (year < 69)
-+ year += CENTURY + 100;
-+ else if (year < 100)
- year += CENTURY;
- for (i = 1970; i < year; i++)
- result += dysize (i);
diff --git a/japanese/mh/files/patch-am b/japanese/mh/files/patch-am
deleted file mode 100644
index 5b79e01d2cf3..000000000000
--- a/japanese/mh/files/patch-am
+++ /dev/null
@@ -1,33 +0,0 @@
---- zotnet/tws/dtimep.c-lexed.orig Tue Feb 9 20:30:00 1999
-+++ zotnet/tws/dtimep.c-lexed Tue Jan 4 11:03:29 2000
-@@ -151,6 +151,7 @@
-
- /* Zero out the struct. */
- bzero( (char *) &tw, sizeof tw);
-+ tw.tw_year = -1;
-
- /* Set default time zone. */
- #ifdef ZONEINFO
-@@ -175,17 +176,19 @@
- switch (cp = str, *cp ? lex_string( &str, start_cond) : 0) {
-
- case -1:
-- if (!gotdate || tw.tw_year == 0)
-+ if (!gotdate || tw.tw_year == -1)
- return (struct tws *)0;
- /* fall through */
- case 0:
-- if ( tw.tw_year == 0 ) {
-+ if ( tw.tw_year == -1 ) {
- /* Set default year. */
- time (&tclock);
- tw.tw_year = localtime(&tclock)->tm_year + 1900;
- }
-+ else if (tw.tw_year < 69) {
-+ tw.tw_year += 2000;
-+ }
- else if (tw.tw_year < 100) {
-- /* assume no 2-digit years > 1999 */
- tw.tw_year += 1900;
- }
- return &tw;
diff --git a/japanese/mh/files/patch-an b/japanese/mh/files/patch-an
deleted file mode 100644
index 0a67b1831849..000000000000
--- a/japanese/mh/files/patch-an
+++ /dev/null
@@ -1,34 +0,0 @@
---- zotnet/tws/dtimep.lex.orig Tue Feb 9 20:30:00 1999
-+++ zotnet/tws/dtimep.lex Tue Jan 4 11:32:43 2000
-@@ -181,6 +181,7 @@
-
- /* Zero out the struct. */
- bzero( (char *) &tw, sizeof tw);
-+ tw.tw_year = -1;
-
- /* Set default time zone. */
- #ifdef ZONEINFO
-@@ -205,17 +206,19 @@
- switch (cp = str, *cp ? lex_string( &str, start_cond) : 0) {
-
- case -1:
-- if (!gotdate || tw.tw_year == 0)
-+ if (!gotdate || tw.tw_year == -1)
- return (struct tws *)0;
- /* fall through */
- case 0:
-- if ( tw.tw_year == 0 ) {
-+ if ( tw.tw_year == -1 ) {
- /* Set default year. */
- time (&tclock);
- tw.tw_year = localtime(&tclock)->tm_year + 1900;
- }
-+ else if (tw.tw_year < 69) {
-+ tw.tw_year += 2000;
-+ }
- else if (tw.tw_year < 100) {
-- /* assume no 2-digit years > 1999 */
- tw.tw_year += 1900;
- }
- return &tw;
-
diff --git a/japanese/mh/files/patch-ao b/japanese/mh/files/patch-ao
index e9061669f6e3..3dd6f3474fe6 100644
--- a/japanese/mh/files/patch-ao
+++ b/japanese/mh/files/patch-ao
@@ -1,18 +1,16 @@
---- uip/replsbr.c.orig Fri Sep 10 13:51:41 1999
-+++ uip/replsbr.c Wed Jan 12 12:04:01 2000
-@@ -215,11 +215,9 @@
- finished:
- /* drop ending newline */
- for (i = 0; i < sizeof(wantcomp)/sizeof(wantcomp[0]); i++)
-- if ((cptr = wantcomp[i]) && cptr->c_text)
-- do {
-- if ((cp = rindex(cptr->c_text, '\n')) && !cp[1])
-- *cp = 0;
-- } while (cptr = cptr->c_next);
-+ for (cptr = wantcomp[i]; cptr; cptr = cptr->c_next)
-+ if (cptr->c_text && (cp = rindex(cptr->c_text, '\n')) && !cp[1])
-+ *cp = 0;
+--- uip/replsbr.c.orig Thu Apr 5 01:05:17 2001
++++ uip/replsbr.c Tue Jan 14 18:05:42 2003
+@@ -195,11 +195,12 @@
+ }
+ } while (cptr = cptr->c_next);
- /* if there's a "subject" component, strip any "re:"s off it */
- FINDCOMP (cptr, "subject")
-
+- while (state == FLDPLUS)
++ while (state == FLDPLUS) {
+ state = m_getfld (state, name, tmpbuf, SBUFSIZ, inb);
+ #ifdef JAPAN
+ (void) ml_conv(tmpbuf);
+ #endif /* JAPAN */
++ }
+ break;
+
+ case LENERR:
diff --git a/japanese/mh/files/patch-h:mh.h b/japanese/mh/files/patch-h:mh.h
new file mode 100644
index 000000000000..ae0a1e9bca2a
--- /dev/null
+++ b/japanese/mh/files/patch-h:mh.h
@@ -0,0 +1,13 @@
+Index: h/mh.h
+diff -u h/mh.h.orig h/mh.h
+--- h/mh.h.orig Wed Dec 2 02:05:00 1998
++++ h/mh.h Fri Jul 18 16:47:28 2003
+@@ -253,7 +253,7 @@
+ int atooi ();
+ char **brkstring ();
+ void closefds ();
+-char *concat ();
++char *concat (char *, ...);
+ char *copy ();
+ char **copyip ();
+ void cpydata ();
diff --git a/japanese/mh/files/patch-sbr:concat.c b/japanese/mh/files/patch-sbr:concat.c
new file mode 100644
index 000000000000..b3d83a61ac41
--- /dev/null
+++ b/japanese/mh/files/patch-sbr:concat.c
@@ -0,0 +1,60 @@
+Index: sbr/concat.c
+diff -u sbr/concat.c.orig sbr/concat.c
+--- sbr/concat.c.orig Wed Dec 1 13:01:21 1993
++++ sbr/concat.c Fri Jul 18 14:42:47 2003
+@@ -2,13 +2,12 @@
+
+ #include "../h/mh.h"
+ #include <stdio.h>
+-#include <varargs.h>
++#include <stdarg.h>
+
+
+ /* VARARGS */
+
+-char *concat (va_alist)
+-va_dcl
++char *concat (char *first, ...)
+ {
+ register char *cp,
+ *dp,
+@@ -17,19 +16,26 @@
+ register va_list list;
+
+ len = 1;
+- va_start (list);
+- while (cp = va_arg (list, char *))
+- len += strlen (cp);
+- va_end (list);
++ if (first) {
++ len += strlen (first);
++ va_start (list, first);
++ while (cp = va_arg (list, char *))
++ len += strlen (cp);
++ va_end (list);
++ }
+
+ dp = sp = malloc (len);
+ if (dp == NULL)
+- adios (NULLCP, "unable to allocate string storage");
++ err ("unable to allocate string storage");
+
+- va_start (list);
+- while (cp = va_arg (list, char *))
+- sp = copy (cp, sp);
+- va_end (list);
++ *sp = '\0';
++ if (first) {
++ sp = copy (first, sp);
++ va_start (list, first);
++ while (cp = va_arg (list, char *))
++ sp = copy (cp, sp);
++ va_end (list);
++ }
+
+ return dp;
+ }
+--
+’Çß’ËÜ ’È¥ ’¡÷ ’¥¤’¥ó’¥¿’¡¼’¥Í’¥Ã’¥È’¸ß’½õ’²ñ’²£’ÉÍ http://www.imasy.org/~ume/
+ume@mahoroba.org ume@bisd.hitachi.co.jp ume@{,jp.}FreeBSD.org
+’¥×’¥í’¥°’¥é’¥à’¤Ï’½ñ’¤¤’¤¿’¿Í’¤Î’°Õ’¿Þ’¤Ç’¤Ï’¤Ê’¤¯’½ñ’¤«’¤ì’¤¿’ÄÌ’¤ê’Æ°’¤¯ I hate Modula-3 :-)