aboutsummaryrefslogtreecommitdiff
path: root/japanese/migemo
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-09-25 09:24:57 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-09-25 09:24:57 +0000
commit98799a3a2f7ab6101c7eb721be0c6fd4b5159c47 (patch)
tree3203ec7c7478ad902d07ae741e8120113e8b2e0c /japanese/migemo
parent4f95e7a2cc5e2fc6ddcde0014bd53072df9e10c5 (diff)
downloadports-98799a3a2f7ab6101c7eb721be0c6fd4b5159c47.tar.gz
ports-98799a3a2f7ab6101c7eb721be0c6fd4b5159c47.zip
- Convert to USES=autoreconf
- Use BROKEN_ia64 - Don't display pkg-message from post-install
Notes
Notes: svn path=/head/; revision=369227
Diffstat (limited to 'japanese/migemo')
-rw-r--r--japanese/migemo/Makefile35
1 files changed, 14 insertions, 21 deletions
diff --git a/japanese/migemo/Makefile b/japanese/migemo/Makefile
index c0db965b8264..8420fe8db6be 100644
--- a/japanese/migemo/Makefile
+++ b/japanese/migemo/Makefile
@@ -19,28 +19,28 @@ COMMENT?= Japanese incremental search tool
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
+BUILD_DEPENDS= ${RUBY_SITELIBDIR}/romkan.rb:${PORTSDIR}/japanese/ruby-romkan \
+ ${RUBY_SITELIBDIR}/bsearch.rb:${PORTSDIR}/devel/ruby-bsearch
+RUN_DEPENDS= ${RUBY_SITELIBDIR}/romkan.rb:${PORTSDIR}/japanese/ruby-romkan \
+ ${RUBY_SITELIBDIR}/bsearch.rb:${PORTSDIR}/devel/ruby-bsearch
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-rubydir=${RUBY_SITELIBDIR}
+USES= autoreconf
+USE_RUBY= yes
+
.if !defined(SLAVE_PORT)
EXTRA_PATCHES= ${FILESDIR}/extra-patch-Makefile.am \
${FILESDIR}/extra-patch-configure.in
PLIST_SUB= MIGEMO="" ELISP="@comment "
.endif
-USE_RUBY= yes
-USE_AUTOTOOLS= automake14 autoconf213
-BUILD_DEPENDS+= ${RUBY_SITELIBDIR}/romkan.rb:${PORTSDIR}/japanese/ruby-romkan \
- ${RUBY_SITELIBDIR}/bsearch.rb:${PORTSDIR}/devel/ruby-bsearch
-RUN_DEPENDS+= ${RUBY_SITELIBDIR}/romkan.rb:${PORTSDIR}/japanese/ruby-romkan \
- ${RUBY_SITELIBDIR}/bsearch.rb:${PORTSDIR}/devel/ruby-bsearch
-
-CONFIGURE_ARGS+=--with-rubydir=${RUBY_SITELIBDIR}
MAKE_JOBS_UNSAFE= yes
SHEBANG_FILES= migemo migemo-client migemo-grep migemo-server
SKKDIC_FILE= SKK-JISYO.L-20110813
-.include <bsd.port.pre.mk>
-
EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-Makefile.am.ruby19 \
${PATCHDIR}/extra-patch-configure.in.ruby19 \
${PATCHDIR}/extra-patch-genchars.sh \
@@ -54,9 +54,9 @@ EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-Makefile.am.ruby19 \
${PATCHDIR}/extra-patch-migemo.rb.in \
${PATCHDIR}/extra-patch-tests_Makefile.am
-.if ${ARCH} == "ia64"
-BROKEN= Does not compile on ia64
-.endif
+BROKEN_ia64= Does not compile
+
+.include <bsd.port.options.mk>
post-extract:
.if ${SLAVE_PORT} == "no"
@@ -74,13 +74,6 @@ post-patch:
post-configure:
.if ${SLAVE_PORT} == "no"
(cd ${WRKSRC}; ${CAT} SKK-JISYO.L | ${RUBY} -Ke migemo-convert.rb > migemo-dict)
- ${CP} ${AUTOMAKE_DIR}/config.guess ${WRKSRC}
- ${CP} ${AUTOMAKE_DIR}/config.sub ${WRKSRC}
-.endif
-
-post-install:
-.if ${SLAVE_PORT} == "yes"
- @${CAT} ${PKGMESSAGE}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>