aboutsummaryrefslogtreecommitdiff
path: root/japanese/mozc-server/Makefile
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2015-02-20 05:15:17 +0000
committerHiroki Sato <hrs@FreeBSD.org>2015-02-20 05:15:17 +0000
commit00b407013b8400c492267901653fa659d6a5fe18 (patch)
tree9a3a1f1414f52dd873c813de73951900a23d0cb0 /japanese/mozc-server/Makefile
parentf4a3bd056de40bafcc77a49d2f506805eedd209d (diff)
downloadports-00b407013b8400c492267901653fa659d6a5fe18.tar.gz
ports-00b407013b8400c492267901653fa659d6a5fe18.zip
Notes
Diffstat (limited to 'japanese/mozc-server/Makefile')
-rw-r--r--japanese/mozc-server/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/japanese/mozc-server/Makefile b/japanese/mozc-server/Makefile
index 5a2cc5a5b743..c612837375f1 100644
--- a/japanese/mozc-server/Makefile
+++ b/japanese/mozc-server/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mozc
PORTVERSION= 2.16.2051.102
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= japanese
MASTER_SITES= LOCAL/hrs
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
@@ -142,7 +142,7 @@ EXTRACT_DEPENDS+= lha:${PORTSDIR}/archivers/lha
PLIST_FILES+= bin/mozc \
bin/mozc_server \
- bin/mozc_emacs_helper
+ libexec/mozc_emacs_helper
SUB_FILES+= mozc
post-extract-mozc_server:
@@ -163,8 +163,10 @@ do-build-mozc_server:
do-install-mozc_server:
${INSTALL_PROGRAM} \
${WRKSRC}/out_linux/${BUILD_MODE}/mozc_server \
- ${WRKSRC}/out_linux/${BUILD_MODE}/mozc_emacs_helper \
${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} \
+ ${WRKSRC}/out_linux/${BUILD_MODE}/mozc_emacs_helper \
+ ${STAGEDIR}${PREFIX}/libexec
${INSTALL_SCRIPT} \
${WRKDIR}/mozc ${STAGEDIR}/${PREFIX}/bin
.endif
@@ -295,6 +297,11 @@ post-extract-fcitx_mozc:
post-extract: post-extract-fcitx_mozc
+post-patch-fcitx_mozc:
+ cd ${PATCH_WRKSRC} && ${PATCH} < ${PATCHDIR}/extra-patch-unix_fcitx_fcitx_mozc.cc
+
+post-patch: post-patch-fcitx_mozc
+
do-build-fcitx_mozc:
${BUILD_MOZC_CMD_BUILD} unix/fcitx/fcitx.gyp:fcitx-mozc