aboutsummaryrefslogtreecommitdiff
path: root/japanese/navi2ch
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2016-11-16 00:43:30 +0000
committerHiroki Sato <hrs@FreeBSD.org>2016-11-16 00:43:30 +0000
commit0c58bf30ace5ca917dac5ce9df0d5654d986103b (patch)
tree38677bee9de665ee8ca137967ecd28cb79ebc7e0 /japanese/navi2ch
parentbbc402e7d9a1174f69caa164687496171600f80a (diff)
downloadports-0c58bf30ace5ca917dac5ce9df0d5654d986103b.tar.gz
ports-0c58bf30ace5ca917dac5ce9df0d5654d986103b.zip
- Add japanese/p5-2chproxy, an HTTP proxy converting contents of 2ch.net
into the old .dat format. - Update japanese/navi2ch to use japanese/p5-2chproxy as an HTTP server by default.
Notes
Notes: svn path=/head/; revision=426204
Diffstat (limited to 'japanese/navi2ch')
-rw-r--r--japanese/navi2ch/Makefile14
-rw-r--r--japanese/navi2ch/distinfo5
-rw-r--r--japanese/navi2ch/files/patch-elisp-comp11
-rw-r--r--japanese/navi2ch/files/patch-navi2ch-vars.el13
-rw-r--r--japanese/navi2ch/pkg-message8
5 files changed, 32 insertions, 19 deletions
diff --git a/japanese/navi2ch/Makefile b/japanese/navi2ch/Makefile
index 109d9ea98c29..6921794d7112 100644
--- a/japanese/navi2ch/Makefile
+++ b/japanese/navi2ch/Makefile
@@ -3,11 +3,9 @@
PORTNAME= navi2ch
PORTVERSION= 2.0.0.d
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 1
CATEGORIES= japanese www elisp
-MASTER_SITES= http://people.allbsd.org/~hrs/FreeBSD/ LOCAL/hrs
-DISTNAME= navi2ch-git-75ceac8e93d8d7cc02cc8fa44f14cd44ce0b9d0a
PKGNAMESUFFIX= -${EMACS_PORT_NAME}
MAINTAINER= hrs@FreeBSD.org
@@ -15,8 +13,12 @@ COMMENT= 2ch.net and 2ch-like BBS navigator for Emacsen
LICENSE= GPLv2
-USES= zip
+RUN_DEPENDS= ${LOCALBASE}/sbin/2chproxy.pl:japanese/p5-2chproxy
+
USE_EMACS= yes
+USE_GITHUB= yes
+GH_ACCOUNT= naota
+GH_TAGNAME= faebfd1
GNU_CONFIGURE= yes
CONFIGURE_ENV= EMACS="${EMACS_CMD}"
CONFIGURE_ARGS= --with-lispdir=${PREFIX}/${LISPDIR}/${PORTNAME}
@@ -30,10 +32,10 @@ PORTDOC_LISPS= gikope.el navi2ch-logo.el navi2ch-migemo.el
LISPDIR= ${EMACS_VERSION_SITE_LISPDIR}
OPTIONS_DEFINE= DOCS X11
-OPTIONS_DEFAULT=X11
+OPTIONS_DEFAULT=DOCS X11
X11_RUN_DEPENDS=${LOCALBASE}/share/mona/monak12.pcf.gz:japanese/font-mona
-post-install:
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC} && \
${INSTALL_DATA} ${PORTDOC_FILES} ${STAGEDIR}${DOCSDIR}
diff --git a/japanese/navi2ch/distinfo b/japanese/navi2ch/distinfo
index b4f09dc8238e..577e15a5c449 100644
--- a/japanese/navi2ch/distinfo
+++ b/japanese/navi2ch/distinfo
@@ -1,2 +1,3 @@
-SHA256 (navi2ch-git-75ceac8e93d8d7cc02cc8fa44f14cd44ce0b9d0a.zip) = c87f6a463ab96f2e736d16a61f58b78de503188040b35ef16a7dc268de20ef27
-SIZE (navi2ch-git-75ceac8e93d8d7cc02cc8fa44f14cd44ce0b9d0a.zip) = 575780
+TIMESTAMP = 1479256991
+SHA256 (naota-navi2ch-2.0.0.d-faebfd1_GH0.tar.gz) = e5da75c6aee6005349a4c8e830a0737cc58536c4c526aba7843e9f990da62966
+SIZE (naota-navi2ch-2.0.0.d-faebfd1_GH0.tar.gz) = 512558
diff --git a/japanese/navi2ch/files/patch-elisp-comp b/japanese/navi2ch/files/patch-elisp-comp
deleted file mode 100644
index 8c0de875505c..000000000000
--- a/japanese/navi2ch/files/patch-elisp-comp
+++ /dev/null
@@ -1,11 +0,0 @@
---- elisp-comp.orig 2014-11-22 16:23:24.000000000 +0900
-+++ elisp-comp 2014-11-22 16:23:43.000000000 +0900
-@@ -72,7 +72,7 @@
-
- (
- cd $tempdir
-- echo "(setq load-path (cons nil load-path))" > script
-+ echo "(setq load-path (cons \".\" load-path))" > script
- # $EMACS -batch -q -l script -f batch-byte-compile *.el || exit $?
- $EMACS -batch -q -l script -l ../bcomp.el || exit $?
- mv *.elc ..
diff --git a/japanese/navi2ch/files/patch-navi2ch-vars.el b/japanese/navi2ch/files/patch-navi2ch-vars.el
new file mode 100644
index 000000000000..592eef342516
--- /dev/null
+++ b/japanese/navi2ch/files/patch-navi2ch-vars.el
@@ -0,0 +1,13 @@
+--- navi2ch-vars.el.orig 2015-03-30 02:16:24 UTC
++++ navi2ch-vars.el
+@@ -2009,8 +2009,8 @@ Navi2ch$B%+%F%4%j$K!VAw?.95$(!WHD$,<+F0
+
+ ;; net variables
+ (defcustom navi2ch-net-http-proxy
+- (if (string= (getenv "HTTP_PROXY") "")
+- nil
++ (if (string= (or (getenv "HTTP_PROXY") "") "")
++ "127.0.0.1:8080"
+ (getenv "HTTP_PROXY"))
+ "*HTTP $B%W%m%-%7$N(B URL$B!#(B"
+ :type '(choice (string :tag "$B%W%m%-%7$r;XDj(B")
diff --git a/japanese/navi2ch/pkg-message b/japanese/navi2ch/pkg-message
new file mode 100644
index 000000000000..fb91f29b9334
--- /dev/null
+++ b/japanese/navi2ch/pkg-message
@@ -0,0 +1,8 @@
+navi2ch now requires ja-p5-2chproxy(japanese/p5-2chproxy) to access 2ch.net.
+Before using navi2ch, put the following line into /etc/rc.conf:
+
+ twochproxy_enable="YES"
+
+and start twochproxy service:
+
+ # service twochproxy start