aboutsummaryrefslogtreecommitdiff
path: root/japanese/nkf
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2009-04-27 13:50:06 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2009-04-27 13:50:06 +0000
commit0b7595c81d90f0ad5039255b4f56ccb34b75ce0a (patch)
treee51e2e501f9aea2caf73180437370b95477cd698 /japanese/nkf
parent89ea8859c18fe536a7b100c2d6d737b5fe84209a (diff)
downloadports-0b7595c81d90f0ad5039255b4f56ccb34b75ce0a.tar.gz
ports-0b7595c81d90f0ad5039255b4f56ccb34b75ce0a.zip
Fix some bugs.
PR: ports/133738 Submitted by: Tsurutani Naoki turutani at scphys kyoto-u ac jp Obtained from: nkf's git
Notes
Notes: svn path=/head/; revision=232842
Diffstat (limited to 'japanese/nkf')
-rw-r--r--japanese/nkf/Makefile1
-rw-r--r--japanese/nkf/files/patch-nkf.c46
2 files changed, 47 insertions, 0 deletions
diff --git a/japanese/nkf/Makefile b/japanese/nkf/Makefile
index 7a22fe1a3879..93a4eca6036a 100644
--- a/japanese/nkf/Makefile
+++ b/japanese/nkf/Makefile
@@ -7,6 +7,7 @@
PORTNAME= nkf
PORTVERSION= 2.0.9
+PORTREVISION= 20090221
PORTEPOCH= 1
CATEGORIES?= japanese
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_JP}
diff --git a/japanese/nkf/files/patch-nkf.c b/japanese/nkf/files/patch-nkf.c
new file mode 100644
index 000000000000..2b0c1215190a
--- /dev/null
+++ b/japanese/nkf/files/patch-nkf.c
@@ -0,0 +1,46 @@
+--- nkf.c.orig 2009-01-20 18:49:31.000000000 +0900
++++ nkf.c 2009-04-27 22:44:46.124911367 +0900
+@@ -21,7 +21,7 @@
+ * 3. This notice may not be removed or altered from any source distribution.
+ */
+ #define NKF_VERSION "2.0.9"
+-#define NKF_RELEASE_DATE "2009-01-20"
++#define NKF_RELEASE_DATE "2009-02-21"
+ #define COPY_RIGHT \
+ "Copyright (C) 1987, FUJITSU LTD. (I.Ichikawa).\n" \
+ "Copyright (C) 1996-2009, The nkf Project."
+@@ -468,6 +468,8 @@
+ {"Shift_JIS", 0, 0, 0, {0, 0, 0}, s_status, s_iconv, 0},
+ #ifdef UTF8_INPUT_ENABLE
+ {"UTF-8", 0, 0, 0, {0, 0, 0}, w_status, w_iconv, 0},
++ {"UTF-16", 0, 0, 0, {0, 0, 0}, NULL, w_iconv16, 0},
++ {"UTF-32", 0, 0, 0, {0, 0, 0}, NULL, w_iconv32, 0},
+ #endif
+ {0}
+ };
+@@ -1426,6 +1428,7 @@
+ output_endian = ENDIAN_LITTLE;
+ output_bom_f = TRUE;
+ break;
++ case UTF_32:
+ case UTF_32BE_BOM:
+ output_bom_f = TRUE;
+ break;
+@@ -6159,9 +6162,6 @@
+ output_endian = ENDIAN_LITTLE;
+ } else if (cp[0] == 'B') {
+ cp++;
+- } else {
+- output_encoding = nkf_enc_from_index(enc_idx);
+- continue;
+ }
+ if (cp[0] == '0'){
+ cp++;
+@@ -6232,6 +6232,7 @@
+ while ('0'<= *cp && *cp <='9') {
+ alpha_f |= 1 << (*cp++ - '0');
+ }
++ if (alpha_f & ((1 << 2) | (1 << 3))) alpha_f |= 1;
+ if (!alpha_f) alpha_f = 1;
+ continue;
+ case 'x': /* Convert X0201 kana to X0208 or X0201 Conversion */