aboutsummaryrefslogtreecommitdiff
path: root/japanese/plan/Makefile
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1998-12-01 03:06:49 +0000
committerSatoshi Asami <asami@FreeBSD.org>1998-12-01 03:06:49 +0000
commit555a3ebe6cdf7d9691773cd13c13503ad2fdffae (patch)
tree8b731a32ebffa1cf00831def0cd323e7ac45f8c5 /japanese/plan/Makefile
parentb84358bd6074f63917e478c7ba7a1f10f37db466 (diff)
downloadports-555a3ebe6cdf7d9691773cd13c13503ad2fdffae.tar.gz
ports-555a3ebe6cdf7d9691773cd13c13503ad2fdffae.zip
Use MASTERDIR where appropriate. Also, add FILE_DEPENDS to denote
that the port otherwise uses files from another port. (Note: support for FILE_DEPENDS is not in bsd.port.mk yet, so it's a no-op for now.)
Notes
Notes: svn path=/head/; revision=14974
Diffstat (limited to 'japanese/plan/Makefile')
-rw-r--r--japanese/plan/Makefile18
1 files changed, 7 insertions, 11 deletions
diff --git a/japanese/plan/Makefile b/japanese/plan/Makefile
index 29052be48cb5..c642c9217c04 100644
--- a/japanese/plan/Makefile
+++ b/japanese/plan/Makefile
@@ -3,7 +3,7 @@
# Date created: Sat Jan 31, 1998
# Whom: David O'Brien (obrien@cs.ucdavis.edu)
#
-# $Id: Makefile,v 1.2 1998/04/17 18:08:35 obrien Exp $
+# $Id: Makefile,v 1.3 1998/08/08 00:20:20 asami Exp $
#
#BROKEN= "need JIS libraries in print.c that I do not have"
@@ -11,20 +11,16 @@ BROKEN= "doesn't build properly from version 1.7.1"
MAKE_ENV+= JAPANESE=yes
-.include "${.CURDIR}/../../deskutils/plan/Makefile"
+MASTERDIR= ${.CURDIR}/../../deskutils/plan
+
+.include "${MASTERDIR}/Makefile"
PKGNAME= ja-${DISTNAME}
MAINTAINER= obrien@FreeBSD.org
-FILESDIR= ${.CURDIR}/../../deskutils/plan/files
-PATCHDIR= ${.CURDIR}/../../deskutils/plan/patches
-PKGDIR= ${.CURDIR}/../../deskutils/plan/pkg
+PLIST= ${WRKDIR}/PLIST
pre-install:
- ${ECHO} "share/doc/plan/plan_calSJ.ps" > ${PKGDIR}/PLIST
- ${CAT} ${.CURDIR}/../../deskutils/plan/pkg/PLIST \
- >> ${PKGDIR}/PLIST
- ${CP} ${.CURDIR}/../../deskutils/plan/pkg/DESCR \
- ${.CURDIR}/../../deskutils/plan/pkg/COMMENT \
- ${PKGDIR}/PLIST
+ ${ECHO} "share/doc/plan/plan_calSJ.ps" > ${PLIST}
+ ${CAT} ${PKGDIR}/PLIST >> ${PLIST}