aboutsummaryrefslogtreecommitdiff
path: root/japanese/plan/Makefile
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-05-13 17:37:21 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-05-13 17:37:21 +0000
commit6d404a4ee55914549c2d5ce095a53f2569a5430f (patch)
tree2ac22bcbedbf651a24cbe59e84ed03ff23ed47b0 /japanese/plan/Makefile
parent141111a2aba6fdbd6826e1a5c44e68b4240255d6 (diff)
downloadports-6d404a4ee55914549c2d5ce095a53f2569a5430f.tar.gz
ports-6d404a4ee55914549c2d5ce095a53f2569a5430f.zip
- Update to 1.9 (master port updated in previous PR)
- Convert spaces -> tabs - Respect NOPORTDOCS - Pass maintainership to submiter PR: ports/97156 Submitted by: Shaun Amott <shaun@inerd.com> Approved by: lawrance
Notes
Notes: svn path=/head/; revision=162252
Diffstat (limited to 'japanese/plan/Makefile')
-rw-r--r--japanese/plan/Makefile22
1 files changed, 14 insertions, 8 deletions
diff --git a/japanese/plan/Makefile b/japanese/plan/Makefile
index bcdc01ccbcff..feeb65cecac8 100644
--- a/japanese/plan/Makefile
+++ b/japanese/plan/Makefile
@@ -6,26 +6,32 @@
# $FreeBSD$
#
-PORTNAME= plan
-PORTVERSION= 1.8.4
+PORTNAME= plan
+PORTVERSION= 1.9
CATEGORIES= japanese
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= shaun@inerd.com
MAKE_ENV+= JAPANESE=yes
MASTERDIR= ${.CURDIR}/../../deskutils/plan
PLIST= ${WRKDIR}/PLIST
-EXTRA_PATCHES= ${.CURDIR}/files/patch-*
+EXTRA_PATCHES= ${.CURDIR}/files/patch-*
post-build:
- ${ECHO_CMD} share/doc/plan/plan_calEUC.ps > ${WRKDIR}/PLIST
+.if !defined(NOPORTDOCS)
+ ${ECHO_CMD} ${DOCSDIR:S|${PREFIX}/||}/plan_calEUC.ps > ${WRKDIR}/PLIST
+.endif
${CAT} ${MASTERDIR}/pkg-plist >> ${WRKDIR}/PLIST
post-install:
- @${MKDIR} ${PREFIX}/share/netplan.dir
- ${CHMOD} 1777 ${PREFIX}/share/netplan.dir
- ${INSTALL_DATA} ${.CURDIR}/files/plan_calEUC.ps ${PREFIX}/share/doc/plan
+ @${MKDIR} ${DATADIR}/netplan.dir
+ ${CHMOD} 1777 ${DATADIR}/netplan.dir
+
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${.CURDIR}/files/plan_calEUC.ps ${DOCSDIR}
+.endif
.include "${MASTERDIR}/Makefile"