aboutsummaryrefslogtreecommitdiff
path: root/japanese/scim-honoka-plugin-romkan/Makefile
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-10-03 23:43:42 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-10-03 23:43:42 +0000
commit80973297a003dac8b61783f1942db33fe9639e1c (patch)
treebf9a3f2a80b25827dd34762e85e6a7eb2fb38442 /japanese/scim-honoka-plugin-romkan/Makefile
parentb7718a26f7f65c4b4641cc467e464005ea5a8230 (diff)
downloadports-80973297a003dac8b61783f1942db33fe9639e1c.tar.gz
ports-80973297a003dac8b61783f1942db33fe9639e1c.zip
Honoka is the SCIM IMEngine module using various input method engines: Wnn,
anthy,prime,skk and canna. Honoka can also use them simultaneously. WWW: http://nop.net-p.org/modules/pukiwiki/index.php?%5B%5Bhonoka%5D%5D (in Japanese) This port is honoka romaji input plugin. Smart Common Input Method platform, in short SCIM, is a development platform to make Input Method developers live easier. WWW: http://scim.freedesktop.org PR: ports/98583 Submitted by: Masashi CHIBA
Notes
Notes: svn path=/head/; revision=174411
Diffstat (limited to 'japanese/scim-honoka-plugin-romkan/Makefile')
-rw-r--r--japanese/scim-honoka-plugin-romkan/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/japanese/scim-honoka-plugin-romkan/Makefile b/japanese/scim-honoka-plugin-romkan/Makefile
new file mode 100644
index 000000000000..2562f135830d
--- /dev/null
+++ b/japanese/scim-honoka-plugin-romkan/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: ja-scim-honoka-plugin-romkan
+# Date created: 3 Jun 2006
+# Whom: Masashi CHIBA
+#
+# $FreeBSD$
+#
+
+PORTNAME= scim-honoka-plugin-romkan
+PORTVERSION= 0.9.0
+CATEGORIES= japanese
+MASTER_SITES= http://nop.net-p.org/files/honoka/
+DISTNAME= honoka-plugin-romkan-${PORTVERSION}
+
+MAINTAINER= chiba.masashi@gmail.com
+COMMENT= Honoka plugin for romaji input
+
+BUILD_DEPENDS= scim:${PORTSDIR}/textproc/scim \
+ ${X11BASE}/lib/scim-1.0/IMEngine/honoka.so:${PORTSDIR}/japanese/scim-honoka
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+USE_GETTEXT= yes
+USE_GNOME= lthack gnomehack
+USE_X_PREFIX= yes
+USE_ICONV= yes
+USE_GMAKE= yes
+USE_AUTOTOOLS= libtool:15
+
+CONFIGURE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
+ PTHREAD_LIBS="${PTHREAD_LIBS}"
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500035
+IGNORE= does not build in FreeBSD < 5.x
+.else
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include -D__STDC_ISO_10646__" \
+ LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+.endif
+
+.include <bsd.port.post.mk>