aboutsummaryrefslogtreecommitdiff
path: root/japanese/sj3-lib
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>2000-07-05 12:37:06 +0000
committerThomas Gellekum <tg@FreeBSD.org>2000-07-05 12:37:06 +0000
commit546041ba3113a4a58d8f3e7e7cb90e78fcb38ea8 (patch)
tree7b9cd553a62be7a9bd52800d334be8b703eb93a1 /japanese/sj3-lib
parent01ab6da99c55af36e516b7f8016373124c4039cf (diff)
downloadports-546041ba3113a4a58d8f3e7e7cb90e78fcb38ea8.tar.gz
ports-546041ba3113a4a58d8f3e7e7cb90e78fcb38ea8.zip
As threatened on freebsd-ports: all startup scripts know about the two
options `start' and `stop' now (unless I have forgotten any). This allows us to call the scripts from /etc/rc.shutdown with the correct option. The (42 or so) ports that already DTRT before are unchanged.
Notes
Notes: svn path=/head/; revision=30229
Diffstat (limited to 'japanese/sj3-lib')
-rw-r--r--japanese/sj3-lib/Makefile8
-rw-r--r--japanese/sj3-lib/files/sj3.sh.in22
2 files changed, 23 insertions, 7 deletions
diff --git a/japanese/sj3-lib/Makefile b/japanese/sj3-lib/Makefile
index 62b9a2eb114e..d5ecaa18f71b 100644
--- a/japanese/sj3-lib/Makefile
+++ b/japanese/sj3-lib/Makefile
@@ -30,13 +30,7 @@ do-configure:
post-install:
if [ ! -f ${STARTUP_SCRIPT} ]; then \
${ECHO} "Installing ${STARTUP_SCRIPT} startup file."; \
- ${ECHO} '#!/bin/sh' > ${STARTUP_SCRIPT}; \
- ${ECHO} 'sj3=${PREFIX}/bin/sj3serv' >> ${STARTUP_SCRIPT} ; \
- ${ECHO} 'if [ -f $$sj3 ]; then' >> ${STARTUP_SCRIPT} ; \
- ${ECHO} ' $$sj3' >> ${STARTUP_SCRIPT} ; \
- ${ECHO} "fi" >> ${STARTUP_SCRIPT} ; \
- ${CHMOD} 755 ${STARTUP_SCRIPT} ; \
- ${CHOWN} bin.bin ${STARTUP_SCRIPT}; \
+ ${INSTALL_SCRIPT} ${FILESDIR}/sj3.sh ${STARTUP_SCRIPT}; \
fi
${SETENV} PKG_PREFIX=${PREFIX} \
${SH} ${PKGDIR}/INSTALL ${PKGNAME} POST-INSTALL
diff --git a/japanese/sj3-lib/files/sj3.sh.in b/japanese/sj3-lib/files/sj3.sh.in
new file mode 100644
index 000000000000..9361c1d8a604
--- /dev/null
+++ b/japanese/sj3-lib/files/sj3.sh.in
@@ -0,0 +1,22 @@
+#!/bin/sh
+
+if ! PREFIX=$(expr $0 : "\(/.*\)/etc/rc\.d/$(basename $0)\$"); then
+ echo "$0: Cannot determine the PREFIX" >&2
+ exit 1
+fi
+
+case "$1" in
+start)
+ sj3=${PREFIX}/bin/sj3serv
+ if [ -f $sj3 ]; then
+ $sj3
+ fi
+ ;;
+stop)
+ ;;
+*)
+ echo "Usage: `basename $0` {start|stop}" >&2
+ ;;
+esac
+
+exit 0