aboutsummaryrefslogtreecommitdiff
path: root/japanese/tdiary
diff options
context:
space:
mode:
authorDaichi GOTO <daichi@FreeBSD.org>2003-06-17 13:20:23 +0000
committerDaichi GOTO <daichi@FreeBSD.org>2003-06-17 13:20:23 +0000
commit4f033b7402a46577b8aa5079ce4170259c429fe8 (patch)
treeaa006bfa52b820501cafc72e70347c55277a820b /japanese/tdiary
parent434b74fea37d6a19874c06769280aa160302e916 (diff)
downloadports-4f033b7402a46577b8aa5079ce4170259c429fe8.tar.gz
ports-4f033b7402a46577b8aa5079ce4170259c429fe8.zip
Committed. Thanks!
Update ports: japanese/tdiary to 1.5.4_1 1. add 'www' category 2. Adjustment of Makefile and script PR: 53394 Approved by: Fumihiko Kimura <jfkimura@yahoo.co.jp> (maintainer)
Notes
Notes: svn path=/head/; revision=83151
Diffstat (limited to 'japanese/tdiary')
-rw-r--r--japanese/tdiary/Makefile27
-rw-r--r--japanese/tdiary/files/tdiary-FreeBSD.sh.in8
-rw-r--r--japanese/tdiary/pkg-message10
3 files changed, 27 insertions, 18 deletions
diff --git a/japanese/tdiary/Makefile b/japanese/tdiary/Makefile
index c6a3f752fa59..ade269e999f2 100644
--- a/japanese/tdiary/Makefile
+++ b/japanese/tdiary/Makefile
@@ -7,10 +7,13 @@
PORTNAME= tdiary
PORTVERSION= 1.5.4
-CATEGORIES= japanese ruby
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+PORTREVISION= 1
+CATEGORIES= japanese ruby www
+MASTER_SITES= \
+ ${MASTER_SITE_SOURCEFORGE} \
+ http://www.tdiary.org/download/
MASTER_SITE_SUBDIR= sourceforge/${PORTNAME}
-DISTNAME= ${PORTNAME}-full-${PORTVERSION:R}.${PORTVERSION:E}
+DISTNAME= ${PORTNAME}-full-${PORTVERSION}
MAINTAINER= jfkimura@yahoo.co.jp
COMMENT= A Web-based diary system (like weblog) written in Ruby
@@ -27,7 +30,7 @@ USE_RUBY= yes
TDIARYDIR= ${PREFIX}/share/examples/${PORTNAME}
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:R}.${PORTVERSION:E}
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
pre-everything::
@${ECHO_MSG}
@@ -43,9 +46,9 @@ pre-everything::
do-install:
@if [ -d ${TDIARYDIR} ]; then ${RM} -rf ${TDIARYDIR}; fi
${MKDIR} ${TDIARYDIR}
- ${SED} -e 's,@@@@PREFIX@@@@,${PREFIX},g' \
- ${FILESDIR}/tdiary-FreeBSD.sh.in > ${TDIARYDIR}/tdiary-FreeBSD.sh
- ${CHMOD} ugo=rx ${TDIARYDIR}/tdiary-FreeBSD.sh
+ @${SED} -e 's,@@@@PREFIX@@@@,${PREFIX},g' \
+ ${FILESDIR}/tdiary-FreeBSD.sh.in > ${TDIARYDIR}/tdiary-FreeBSD.sh
+ @${CHMOD} ugo=rx ${TDIARYDIR}/tdiary-FreeBSD.sh
${CP} -pR ${WRKSRC}/ ${TDIARYDIR}
.if defined(WITH_TDIARY_UCONV)
${INSTALL_DATA} ${WRKSRC}/misc/plugin/output_rdf.rb ${TDIARYDIR}/plugin
@@ -56,14 +59,14 @@ do-install:
@${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${TDIARYDIR}
post-install:
- @cd ${WRKSRC} && ${FIND} . -type f -o -type l | ${SED} 's,^\.,share/examples/${PORTNAME},' | sort >> ${TMPPLIST}
+ @cd ${WRKSRC} && ${FIND} . -type f -o -type l | ${SED} -e 's,^\.,share/examples/${PORTNAME},' >> ${TMPPLIST}
.if defined(WITH_TDIARY_UCONV)
- @cd ${WRKSRC} && ${ECHO} 'share/examples/${PORTNAME}/plugin/output_rdf.rb' >> ${TMPPLIST}
+ @${ECHO} 'share/examples/${PORTNAME}/plugin/output_rdf.rb' >> ${TMPPLIST}
.endif
.if defined(WITH_TDIARY_NORA)
- @cd ${WRKSRC} && ${ECHO} 'share/examples/${PORTNAME}/plugin/disp_referrer.rb' >> ${TMPPLIST}
+ @${ECHO} 'share/examples/${PORTNAME}/plugin/disp_referrer.rb' >> ${TMPPLIST}
.endif
- @cd ${WRKSRC} && ${FIND} . -type d -depth | ${SED} 's,^\.,@dirrm share/examples/${PORTNAME},' >> ${TMPPLIST}
- @${CAT} ${PKGMESSAGE}
+ @cd ${WRKSRC} && ${FIND} . -type d -depth | ${SED} -e 's,^\.,@dirrm share/examples/${PORTNAME},' >> ${TMPPLIST}
+ @${SED} -e "s,@@@@PREFIX@@@@,${PREFIX},g" ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/japanese/tdiary/files/tdiary-FreeBSD.sh.in b/japanese/tdiary/files/tdiary-FreeBSD.sh.in
index 77becc46560c..7b936942b22c 100644
--- a/japanese/tdiary/files/tdiary-FreeBSD.sh.in
+++ b/japanese/tdiary/files/tdiary-FreeBSD.sh.in
@@ -56,10 +56,12 @@ install)
# HOMEGRP=$GROUP
# HOMEDIR=$HOME
echo "HOME Directory : " ${HOMEDIR}
+ USERNAME=$USER
;;
*)
echo "HOME Directory : " ${HOMEDIR}
echo "USERNAME : " ${USERNAME}
+ USERNAME=$USER
;;
esac
@@ -88,7 +90,7 @@ if [ -x ${HOMEDIR} ]; then
echo "Copy tDiary ..." ${EXAMPLES}/tdiary/
echo " to " ${HOMEDIR}/${PUBLICHTML}/${DIARYDIR}/
cp -pR ${EXAMPLES}/tdiary/ ${HOMEDIR}/${PUBLICHTML}/${DIARYDIR}/
- chown -R ${HOMEOWN}:${HOMEGRP} ${HOMEDIR}/${PUBLICHTML}/
+ chown -R ${HOMEOWN}:${HOMEGRP} ${HOMEDIR}/${PUBLICHTML}/${DIARYDIR}/
chmod o+rwx ${HOMEDIR}/${PUBLICHTML}/${DIARYDIR}
echo "Done"
if [ -e ${HOMEDIR}/${PUBLICHTML}/${DIARYDIR}/tdiary.conf ]; then
@@ -128,6 +130,10 @@ else
exit 1
fi
echo ""
+echo ""
+echo "***"
+echo "You have to execute the following commands:"
+echo " % /usr/local/sbin/htpasswd -c" ${HOMEDIR}/.htpasswd ${USERNAME}
echo ""
echo "Be sure to read the ${HOMEDIR}/${PUBLICHTML}/${DIARYDIR}/README"
echo " file for additional information."
diff --git a/japanese/tdiary/pkg-message b/japanese/tdiary/pkg-message
index e0641e05af55..b2f9c9eb0d2b 100644
--- a/japanese/tdiary/pkg-message
+++ b/japanese/tdiary/pkg-message
@@ -1,14 +1,14 @@
+
=============================================================
There is a script to install tDiary in a user directory.
This script should be run manually.
- # cd ${PREFIX}/share/examples/tdiary
- # ./tdiary-FreeBSD.sh USERid
+ # @@@@PREFIX@@@@/share/examples/tdiary/tdiary-FreeBSD.sh USERid
or
- % cd ${PREFIX}/share/examples/tdiary
- % ./tdiary-FreeBSD.sh install
+ % @@@@PREFIX@@@@/share/examples/tdiary/tdiary-FreeBSD.sh install
There is a document by English in the following directories.
See ...
- ${PREFIX}/share/examples/tdiary/misc/i18n/
+ @@@@PREFIX@@@@/share/examples/tdiary/misc/i18n/
=============================================================
+