aboutsummaryrefslogtreecommitdiff
path: root/japanese/today
diff options
context:
space:
mode:
authorSatoshi Taoka <taoka@FreeBSD.org>2000-02-21 17:05:58 +0000
committerSatoshi Taoka <taoka@FreeBSD.org>2000-02-21 17:05:58 +0000
commit836b0df671869d47562b191b1e4e098ef44cfe67 (patch)
tree2a187a432526206510556fff30fdd1dc40b9840d /japanese/today
parentda961162c13fe6dd497e355f9dac34f480259390 (diff)
downloadports-836b0df671869d47562b191b1e4e098ef44cfe67.tar.gz
ports-836b0df671869d47562b191b1e4e098ef44cfe67.zip
Update to 2.11a
PR: 16873 Submitted by: KATO Tsuguru <tkato@prontomail.ne.jp> No response from: maintainer
Notes
Notes: svn path=/head/; revision=26099
Diffstat (limited to 'japanese/today')
-rw-r--r--japanese/today/Makefile29
-rw-r--r--japanese/today/distinfo4
-rw-r--r--japanese/today/files/Makefile143
-rw-r--r--japanese/today/files/patch-aa38
-rw-r--r--japanese/today/files/patch-ae38
-rw-r--r--japanese/today/files/patch-ag43
-rw-r--r--japanese/today/files/patch-ai18
-rw-r--r--japanese/today/files/patch-aj21
-rw-r--r--japanese/today/files/patch-al22
-rw-r--r--japanese/today/pkg-plist10
10 files changed, 139 insertions, 227 deletions
diff --git a/japanese/today/Makefile b/japanese/today/Makefile
index f36032fe7031..bdc8c069b67f 100644
--- a/japanese/today/Makefile
+++ b/japanese/today/Makefile
@@ -1,17 +1,15 @@
# New ports collection makefile for: today
-# Version required: 2.10b
+# Version required: 2.11a
# Date created: 24 June 1996
# Whom: ABURAYER Rewsirow <pcs51674@asciinet.or.jp>
#
# $FreeBSD$
#
-DISTNAME= td210bs
-PKGNAME= ja-today-2.10b
+DISTNAME= ja-today-2.11a
CATEGORIES= japanese games
-MASTER_SITES= ftp://ftp.waseda.ac.jp/pub/archive/fj.binaries.msdos/
-EXTRACT_SUFX= .lzh
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX} td210bm.lzh
+MASTER_SITES= ftp://ftp.vector.co.jp/pack/dos/personal/calendar/today/
+DISTFILES= td211as.lzh td211am.lzh
MAINTAINER= rewsirow@ff.iij4u.or.jp
@@ -21,27 +19,28 @@ BUILD_DEPENDS= lha:${PORTSDIR}/archivers/lha \
EXTRACT_CMD= lha
EXTRACT_BEFORE_ARGS= xfqw=${WRKDIR}
EXTRACT_AFTER_ARGS= # empty
+
NO_WRKSUBDIR= yes
post-extract:
@${ECHO_MSG} "===> Extracting tbl file for ${DISTNAME}"
- @(cd ${WRKDIR}; lha xqf tbl.lzh )
- @${ECHO_MSG} "===> Renaming file for ${DISTNAME}"
- @(cd ${WRKDIR}; \
- ${MV} rdcalend.c rdcalendar.c ; \
- ${MV} rdcalend.h rdcalendar.h )
+ @(cd ${WRKSRC}; lha xqf tbl.lzh )
@${ECHO_MSG} "===> Converting Kanji code for ${DISTNAME}"
- @(cd ${WRKDIR}; \
+ @(cd ${WRKSRC}; \
for i in *.c *.h *.doc *.cnf birthday.tbl event*.tbl flower.tbl \
- gengo.tbl hist??.tbl history.tbl holiday.tbl magazin.tbl \
- monthly.tbl week.tbl; \
+ gengo.tbl hist??.tbl history.tbl holiday.tbl magazine.tbl \
+ monthly.tbl schedule.tbl suffix.tbl week.tbl; \
do \
- ${SED} 's/.$$//' $$i | nkf -e > $$i.tmp ;\
+ ${SED} 's/.$$//' $$i | nkf -Se > $$i.tmp ;\
${MV} -f $$i.tmp $$i ; \
done)
+ @(cd ${WRKSRC}; lha xiqf utility.lzh src/dayinfo.c )
pre-patch:
@${ECHO_MSG} "===> Installing custom Makefile for ${DISTNAME}"
@(${CP} ${FILESDIR}/Makefile ${WRKSRC})
+post-patch:
+ @${PERL} -pi -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/*.cnf
+
.include <bsd.port.mk>
diff --git a/japanese/today/distinfo b/japanese/today/distinfo
index 2f8107846651..1c7f5f255ef9 100644
--- a/japanese/today/distinfo
+++ b/japanese/today/distinfo
@@ -1,2 +1,2 @@
-MD5 (td210bs.lzh) = df892531f83ab81ac1dda7403a7ff6b4
-MD5 (td210bm.lzh) = 6938f108ed938258d519bcc00f760aab
+MD5 (td211as.lzh) = 4e52d02c5ffaecbb1e23633ff83b18fa
+MD5 (td211am.lzh) = c612b80899f3ada3db3303b7a7389518
diff --git a/japanese/today/files/Makefile b/japanese/today/files/Makefile
index cfdd92f79d33..d12615871388 100644
--- a/japanese/today/files/Makefile
+++ b/japanese/today/files/Makefile
@@ -1,96 +1,81 @@
#
# Makefile for today
#
-
-CFLAGS += -DDISTRIBUTE -DMSG_STYLE
-PROGRAM = today
-MANPAGE = today.1
-PREFIX = /usr/local
-MANDIR = ${PREFIX}/man/ja/cat1
-OBJSMV = birthday.o config.o date.o event.o getfile.o getsb.o \
- history.o kansi.o kyureki.o kyusei.o list.o machine.o \
- main.o misc.o pager.o rdcalendar.o schedule.o sekki.o sepparam.o
-OBJS = $(OBJSMV) version.o
-OBJS2 = calendar.o config.o getfile.o getsb.o kyureki2.o misc2.o \
- rdcalendar.o schedule2.o
-
-all: ${PROGRAM} calendar-today dayinfo
-
-install: ${PROGRAM} calendar-today dayinfo
- ${INSTALL} -c -o bin -s ${PROGRAM} ${PREFIX}/bin
- ${INSTALL} -c -o bin -s calendar-today ${PREFIX}/bin
- ${INSTALL} -c -o bin -s dayinfo ${PREFIX}/bin
- mkdir -p ${MANDIR}
- cp today.doc ${MANPAGE}
- ${INSTALL} -c -m 644 ${MANPAGE} ${MANDIR}
-.if !defined(NOMANCOMPRESS)
- gzip -9nf ${MANDIR}/${MANPAGE}
-.endif
- mkdir -p ${PREFIX}/lib
- ${INSTALL} -c -m 644 -o bin today.cnf ${PREFIX}/lib
+# $FreeBSD$
+
+CC ?= cc
+CFLAGS += -DTRANS -DMSG_STYLE -DINTERNAL_KYUREKI_TBL -D_T_SEARCH_CMDPATH=\"${PREFIX}/etc\" #-DUSE_TERMCAP
+LDLIBS = -lm #-ltermcap
+
+HFILES = cdefs.h chu68k.h cmsdos.h cunix.h cwin32.h extern.h
+
+OBJST1 = birthday.o config.o date.o event.o getfile.o \
+ getsb.o history.o kansi.o kyureki.o \
+ kyusei.o list.o machine.o main.o misc.o
+OBJST2 = pager.o rdcalend.o rekichu.o schedule.o sekki.o \
+ sepparam.o
+OBJS_TDY = $(OBJST1) $(OBJST2) version.o
+OBJSC1 = config.o getfile.o getsb.o kyureki2.o \
+ misc2.o rdcalend.o schedule2.o
+OBJS_CAL = calendar.o $(OBJSC1)
+
+
+all: today calendar dayinfo
+
+install: today calendar dayinfo
+ ${BSD_INSTALL_PROGRAM} today ${PREFIX}/bin/today
+ ${BSD_INSTALL_PROGRAM} calendar ${PREFIX}/bin/calendar-today
+ ${BSD_INSTALL_PROGRAM} dayinfo ${PREFIX}/bin/dayinfo
+ ${BSD_INSTALL_DATA} today.cnf ${PREFIX}/etc
mkdir -p ${PREFIX}/share/today
- ${INSTALL} -c -m 644 -o bin *.tbl ${PREFIX}/share/today
-
-
-
-today : $(OBJS)
- $(CC) $(OBJS) -lm -o $@
-
-calendar-today : $(OBJS2)
- $(CC) $(OBJS2) -lm -o $@
+ ${BSD_INSTALL_DATA} *.tbl ${PREFIX}/share/today
+ mkdir -p ${PREFIX}/share/doc/ja/today
+ ${BSD_INSTALL_DATA} today.doc ${PREFIX}/share/doc/ja/today
-dayinfo : dayinfo.c
- $(CC) $(CFLAGS) -lm $? -o $@
+calendar: $(OBJS_CAL)
+ $(CC) $(OBJS_CAL) $(LDLIBS) -o $@
+
+today: $(OBJS_TDY)
+ $(CC) $(OBJS_TDY) $(LDLIBS) -o $@
-#inreki : inreki.c inreki.h
-# $(CC) $(CFLAGS) -DSTANDALONE $? -o $@
-#kansi : kansi.c kansi.h
-# $(CC) $(CFLAGS) -DSTANDALONE -DDEBUG $? -o $@
-#kyusei : kyusei.c kyusei.h
-# $(CC) $(CFLAGS) -DSTANDALONE $? -o $@
+dayinfo: dayinfo.c
+ $(CC) $(CFLAGS) $(LDLIBS) $? -o $@
-clean :
- rm -f *.o core calendar-today dayinfo inreki kansi kyusei today
+clean:
+ rm -f *.o core dayinfo calendar today
-birthday.o : birthday.c common.h main.h birthday.h getfile.h list.h misc.h \
- pager.h
-calendar.o : calendar.c common.h config.h getfile.h getopt.h getsb.h \
- kyureki.h misc.h rdcalendar.h schedule.h
+birthday.o: birthday.c $(HFILES)
+calendar.o: calendar.c $(HFILES) $(OBJSC1)
$(CC) $(CFLAGS) -DINCLUDE_CALENDAR -c -o $@ calendar.c
-config.o : config.c common.h config.h getfile.h
-date.o : date.c common.h main.h date.h kansi.h kyusei.h misc.h pager.h \
- tide_tbl.c
-event.o : event.c common.h main.h event.h getfile.h getsb.h kyureki.h list.h \
- misc.h pager.h sekki.h sepparam.h
-getfile.o : getfile.c common.h getfile.h
-getopt.o : getopt.c getopt.h
-getsb.o : getsb.c getsb.h sb_tbl.c
-history.o : history.c common.h main.h getfile.h history.h list.h misc.h pager.h
-#inreki.o : inreki.c inreki.h
-kansi.o : kansi.c kansi.h
-kyureki.o : kyureki.c common.h main.h getfile.h kyureki.h misc.h kyutbl.c
-kyureki2.o : kyureki.c common.h main.h getfile.h kyureki.h misc.h kyutbl.c
+config.o: config.c $(HFILES)
+date.o: date.c $(HFILES)
+event.o: event.c $(HFILES)
+getfile.o: getfile.c $(HFILES)
+getopt.o: getopt.c $(HFILES)
+getsb.o: getsb.c $(HFILES)
+history.o: history.c $(HFILES)
+kansi.o: kansi.c $(HFILES)
+kyureki.o: kyureki.c $(HFILES) kyutbl.c
+kyureki2.o: kyureki.c $(HFILES) kyutbl.c
$(CC) $(CFLAGS) -DINCLUDE_CALENDAR -c -o $@ kyureki.c
-kyusei.o : kyusei.c kyusei.h
-list.o : list.c list.h
-machine.o : machine.c common.h machine.h main.h
-main.o : main.c common.h main.h birthday.h config.h date.h event.h getfile.h \
- getopt.h history.h kyureki.h machine.h misc.h pager.h rdcalendar.h \
- schedule.h version.h
-misc.o : misc.c common.h main.h getfile.h kyureki.h misc.h
-misc2.o : misc.c common.h main.h getfile.h kyureki.h misc.h
+kyusei.o: kyusei.c $(HFILES)
+list.o: list.c $(HFILES)
+machine.o: machine.c $(HFILES)
+main.o: main.c $(HFILES)
+misc.o: misc.c $(HFILES)
+misc2.o: misc.c $(HFILES)
$(CC) $(CFLAGS) -DINCLUDE_CALENDAR -c -o $@ misc.c
-pager.o : pager.c common.h main.h getfile.h misc.h pager.h
-rdcalendar.o : rdcalendar.c common.h rdcalendar.h
-schedule.o : schedule.c common.h main.h getfile.h list.h misc.h pager.h \
- schedule.h
-schedule2.o : schedule.c common.h main.h getfile.h misc.h schedule.h
+pager.o: pager.c $(HFILES)
+rdcalend.o: rdcalend.c $(HFILES)
+rekichu.o: rekichu.c $(HFILES)
+schedule.o: schedule.c $(HFILES)
+schedule2.o: schedule.c $(HFILES)
$(CC) $(CFLAGS) -DINCLUDE_CALENDAR -c -o $@ schedule.c
-sekki.o : sekki.c sekki.h
-sepparam.o : sepparam.c sepparam.h
-version.o : version.c version.h $(OBJSMV)
+sekki.o: sekki.c $(HFILES)
+sepparam.o: sepparam.c $(HFILES)
+version.o: version.c $(HFILES) $(OBJST1) $(OBJST2)
diff --git a/japanese/today/files/patch-aa b/japanese/today/files/patch-aa
index fa0d343bc261..e9963c94288c 100644
--- a/japanese/today/files/patch-aa
+++ b/japanese/today/files/patch-aa
@@ -1,39 +1,11 @@
---- calendar.c.orig Fri Sep 19 20:27:37 1997
-+++ calendar.c Fri Sep 19 20:27:00 1997
-@@ -37,7 +37,14 @@
- #include "common.h"
- #include "config.h"
- #include "getfile.h"
--#include "getopt.h"
-+#ifdef __FreeBSD__
-+/* FreeBSD version 2.x and earlier has them defined in stdlib.h */
-+ #if __FreeBSD__ >= 3
-+ #include <unistd.h>
-+ #endif
-+#else
-+ #include "getopt.h"
-+#endif
- #include "getsb.h"
- #include "kyureki.h"
- #include "main.h"
-@@ -909,7 +916,7 @@
+--- calendar.c.orig Sun Mar 14 00:00:00 1999
++++ calendar.c Sun Feb 13 15:43:52 2000
+@@ -848,7 +848,7 @@
va_start(ap, fmt);
-- fprintf(stderr, "calendar: ", func);
-+ fprintf(stderr, "calendar: %s", func);
+- fprintf(stderr, "calendar: ");
++ fprintf(stderr, "calendar: %s");
if (level != ERR_INFO) {
fprintf(stderr, "%s: ", statname[level - ERR_WARN]);
}
-@@ -960,7 +967,11 @@
- /*
- * エラーによるプログラム中断処理
- */
-+#ifndef __FreeBSD__
- void terminate_program(int sig, int subcode)
-+#else
-+void terminate_program(int sig)
-+#endif
- {
- switch (sig) {
- case TERM_MEMERROR:
diff --git a/japanese/today/files/patch-ae b/japanese/today/files/patch-ae
index dab46f2fbd37..b147b6553967 100644
--- a/japanese/today/files/patch-ae
+++ b/japanese/today/files/patch-ae
@@ -1,39 +1,11 @@
---- main.c.orig Fri Sep 19 20:27:37 1997
-+++ main.c Fri Sep 19 20:27:01 1997
-@@ -18,7 +18,14 @@
- #include "date.h"
- #include "event.h"
- #include "getfile.h"
--#include "getopt.h"
-+#ifdef __FreeBSD__
-+/* FreeBSD version 2.x and earlier has them defined in stdlib.h */
-+ #if __FreeBSD__ >= 3
-+ #include <unistd.h>
-+ #endif
-+#else
-+ #include "getopt.h"
-+#endif
- #include "history.h"
- #include "kyureki.h"
- #include "machine.h"
-@@ -710,7 +717,7 @@
+--- main.c.orig Sun Mar 14 00:00:00 1999
++++ main.c Sun Feb 13 15:51:22 2000
+@@ -228,7 +228,7 @@
va_start(ap, fmt);
-- fprintf(stderr, "today: ", func);
-+ fprintf(stderr, "today: %s", func);
+- fprintf(stderr, "today: ");
++ fprintf(stderr, "today: %s");
if (level != ERR_INFO) {
fprintf(stderr, "%s: ", statname[level - ERR_WARN]);
}
-@@ -726,7 +733,11 @@
- /*
- * インタラプトやエラーによるプログラム中断処理
- */
-+#ifndef __FreeBSD__
- void terminate_program(int sig, int subcode)
-+#else
-+void terminate_program(int sig)
-+#endif
- {
- switch (sig) {
- case SIGINT:
diff --git a/japanese/today/files/patch-ag b/japanese/today/files/patch-ag
index 4ae251d7cdc2..0d4a96e42004 100644
--- a/japanese/today/files/patch-ag
+++ b/japanese/today/files/patch-ag
@@ -1,28 +1,9 @@
---- misc.c.orig Fri Sep 19 20:27:37 1997
-+++ misc.c Fri Sep 19 20:23:43 1997
-@@ -11,12 +11,17 @@
- *
- */
-
-+#ifdef __FreeBSD__
-+ #include <unistd.h>
-+#endif
- #include "common.h"
- #include "main.h"
- #include "getfile.h"
- #include "kyureki.h"
- #include "misc.h"
--
-+#ifdef __FreeBSD__
-+ #define strnicmp strncasecmp
-+#endif
- #ifndef INCLUDE_CALENDAR
- #define JULIAN 1720994
- #define MONTH 30.6001
-@@ -1105,7 +1110,11 @@
- sprintf(pbuf, "%06d", getpid() >> 4);
+--- misc.c.orig Sun Mar 14 00:00:00 1999
++++ misc.c Sun Feb 13 15:55:51 2000
+@@ -1188,7 +1188,11 @@
pb = pbuf + strlen(pbuf) - 5;
- #else /* #if defined(MSDOS) || defined(LSI_C) || defined(unix) */
+ #endif
+ #if defined(_T_MSDOS) || defined(_T_UNIX)
+#ifndef __FreeBSD__
sprintf(pbuf, "%05d", getpid());
+#else
@@ -30,16 +11,4 @@
+#endif
pb = pbuf;
#endif
- for (i = 0; i < 5; i++) {
-@@ -1280,7 +1289,11 @@
- buf = malloc(size);
- if (buf == NULL) {
- errprint("xmalloc", ERR_PANIC, "virtual memory exhausted, program stop.");
-+#ifndef __FreeBSD__
- terminate_program(TERM_MEMERROR, 0);
-+#else
-+ terminate_program(TERM_MEMERROR);
-+#endif
- }
- return (buf);
- }
+ #if defined(_T_WIN32CONSOLE) || defined(_T_WINDOWS)
diff --git a/japanese/today/files/patch-ai b/japanese/today/files/patch-ai
index d73fb4fac57b..617278792b7c 100644
--- a/japanese/today/files/patch-ai
+++ b/japanese/today/files/patch-ai
@@ -1,24 +1,24 @@
---- today.cnf.orig Fri Sep 19 20:27:37 1997
-+++ today.cnf Fri Sep 19 20:27:22 1997
-@@ -109,10 +109,10 @@
+--- today.cnf.orig Sun Mar 14 00:00:00 1999
++++ today.cnf Sun Feb 13 15:59:51 2000
+@@ -182,10 +182,10 @@
#
- pager = # 外部ページャーの指定
+ pager = # 外部ページャーの指定
# 指定しなければ、内蔵ページャー使用
-pause = yes # 内蔵ページャー 表示一時停止制御
+pause = no # 内蔵ページャー 表示一時停止制御
# yes 一時停止
# *no 停止しない
-pause_last = yes # 内蔵ページャー 表示終了後一時停止制御
-+pause_last = no # 内蔵ページャー 表示終了後一時停止制御
++pause_last = no # 内蔵ページャー 表示終了後一時停止制御
# yes 一時停止
# *no 停止しない
- #outputfile = %y%m%d.tdy # 出力ファイル名 (デフォルト:%y%m%d.tdy/%p.tdy)
-@@ -214,7 +214,7 @@
+ outputfile = %c%y%m%d.tdy # 出力ファイル名 (筑湊拂:%c%y%m%d.tdy/%p.tdy)
+@@ -369,7 +369,7 @@
#
$common # 以降 共通環境定義部
--#table_path = c:/tbl # 各テーブルの検索パス名
-+table_path = /usr/local/share/today # 各テーブルの検索パス名
+-#table_path = c:/bin/tbl # 各テーブルの検索パス名
++table_path = %%PREFIX%%/share/today # 各テーブルの検索パス名
# ';' で区切り複数指定可能
# 未定義の場合、環境変数 TODAYTBL の場所
diff --git a/japanese/today/files/patch-aj b/japanese/today/files/patch-aj
index fe274e025381..c5c791430567 100644
--- a/japanese/today/files/patch-aj
+++ b/japanese/today/files/patch-aj
@@ -1,22 +1,11 @@
---- version.c.orig Fri Sep 19 20:27:37 1997
-+++ version.c Fri Sep 19 20:23:43 1997
-@@ -28,6 +28,7 @@
- const char Version[] = "today " __DATE__ " version 2.10B (正式版)";
- const char RCSid[] ="$Id: version.c,v 1.1 1993/07/25 05:39:46 mori Exp $";
- const char UseLanguage[] =
-+#if !defined(TRANS)
- #if defined(human68k)
- #if defined(__GNUC__)
- "gcc version 1.00 Tool#1(68020) Based on 1.42";
-@@ -47,7 +48,10 @@
- /* by Sun-4/470 SunOS4.1.1+JLE1.1.1 */
+--- version.c.orig Sun Mar 14 00:00:00 1999
++++ version.c Sun Feb 13 16:07:25 2000
+@@ -42,7 +42,7 @@
#endif
- #endif
-+#else
-+ "gcc version 2.6.3";
-+#endif
#ifdef TRANS
-const char Modify[] = "Modified for 機種名/OS名 by 移植者名";
+const char Modify[] = "Modified for FreeBSD2.0.5R by pcs51674@asciinet.or.jp";
#endif
+
+ #endif /* !_T_WINDOWS */
diff --git a/japanese/today/files/patch-al b/japanese/today/files/patch-al
new file mode 100644
index 000000000000..873186378f58
--- /dev/null
+++ b/japanese/today/files/patch-al
@@ -0,0 +1,22 @@
+--- cunix.h.orig Tue Feb 15 03:17:23 2000
++++ cunix.h Sun Feb 13 16:38:34 2000
+@@ -38,7 +38,9 @@
+ #define _T_FPBUFSIZE (64 * 1024) /* fopen バッファ長 */
+ #define _T_TMPENV "temp" /* temporary 環境変数名 */
+ #define _T_TMPDIR "/tmp" /* temporary directory */
+-#define _T_SEARCH_CMDPATH "/usr/local/lib:/usr/lib"
++#ifndef _T_SEARCH_CMDPATH
++#define _T_SEARCH_CMDPATH "/usr/local/etc"
++#endif
+ #define _T_HOMEENV "HOME" /* home 環境変数 */
+ #define _T_PATHSEPARATOR ":" /* path list separator char */
+ #define _T_PATHSEP_CHR ':' /* path list separator char */
+@@ -53,7 +55,7 @@
+ #define _T_OUTFILE_DEFAULT "%c%y%m%d.today"
+ #define _T_OUTFILE_TMPNAME "%p.today"
+
+-#if defined(linux)
++#if defined(linux) || defined(__FreeBSD__)
+ #define _T_ACCESS_ROK R_OK
+ #define strnicmp strncasecmp
+ #else
diff --git a/japanese/today/pkg-plist b/japanese/today/pkg-plist
index 57dc9ff7a7a7..d88cc157fc50 100644
--- a/japanese/today/pkg-plist
+++ b/japanese/today/pkg-plist
@@ -1,8 +1,8 @@
bin/today
bin/calendar-today
bin/dayinfo
-man/ja/cat1/today.1.gz
-lib/today.cnf
+etc/today.cnf
+share/doc/ja/today/today.doc
share/today/birthday.tbl
share/today/event01.tbl
share/today/event02.tbl
@@ -33,7 +33,11 @@ share/today/hist12.tbl
share/today/history.tbl
share/today/holiday.tbl
share/today/kyureki.tbl
-share/today/magazin.tbl
+share/today/magazine.tbl
share/today/monthly.tbl
+share/today/schedule.tbl
+share/today/sekki.tbl
+share/today/suffix.tbl
share/today/week.tbl
@dirrm share/today
+@dirrm share/doc/ja/today