aboutsummaryrefslogtreecommitdiff
path: root/japanese/today
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1996-10-18 15:04:50 +0000
committerSatoshi Asami <asami@FreeBSD.org>1996-10-18 15:04:50 +0000
commit9ae6f48b553a50813e525a0eaea80ac020fafe59 (patch)
tree4ff3c0c90cfe3b09f683f0a3ea74c61e82fe9b1d /japanese/today
parent4c8b5a5f58a07b4e6eb0e83a75df64114b2cb3f1 (diff)
downloadports-9ae6f48b553a50813e525a0eaea80ac020fafe59.tar.gz
ports-9ae6f48b553a50813e525a0eaea80ac020fafe59.zip
Tells you what day today is.
Submitted by: ABURAYER Rewsirow <pcs51674@asciinet.or.jp>
Notes
Notes: svn path=/head/; revision=4033
Diffstat (limited to 'japanese/today')
-rw-r--r--japanese/today/Makefile49
-rw-r--r--japanese/today/distinfo2
-rw-r--r--japanese/today/files/Makefile96
-rw-r--r--japanese/today/files/patch-aa441
-rw-r--r--japanese/today/pkg-comment1
-rw-r--r--japanese/today/pkg-descr9
-rw-r--r--japanese/today/pkg-plist38
7 files changed, 636 insertions, 0 deletions
diff --git a/japanese/today/Makefile b/japanese/today/Makefile
new file mode 100644
index 000000000000..d6079561d2fb
--- /dev/null
+++ b/japanese/today/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: today
+# Version required: 2.10b
+# Date created: 24 June 1996
+# Whom: ABURAYER Rewsirow <pcs51674@asciinet.or.jp>
+#
+# $Id$
+#
+
+DISTNAME= td210bs
+PKGNAME= jp-today-2.10b
+CATEGORIES+= japanese games
+MASTER_SITES= ftp://ftp.waseda.ac.jp/pub/archive/fj.binaries.msdos/
+
+DISTFILES= td210bs.lzh td210bm.lzh
+
+MAINTAINER= pcs51674@asciinet.or.jp
+
+BUILD_DEPENDS= lha:${PORTSDIR}/archivers/lha
+BUILD_DEPENDS+= nkf:${PORTSDIR}/japanese/nkf
+
+EXTRACT_CMD= lha
+EXTRACT_SUFX= .lzh
+EXTRACT_BEFORE_ARGS= xfw=${WRKDIR}
+NO_WRKSUBDIR= yes
+PATCH_STRIP= -p1
+
+post-extract:
+ @echo "===> Extracting tbl file for ${DISTNAME}"
+ @(cd ${WRKDIR}; lha xf tbl.lzh )
+ @echo "===> Renaming file for ${DISTNAME}"
+ @(cd ${WRKDIR}; \
+ mv rdcalend.c rdcalendar.c ; \
+ mv rdcalend.h rdcalendar.h )
+ @echo "===> Converting Kanji code for ${DISTNAME}"
+ @(cd ${WRKDIR}; \
+ for i in *.c *.h *.doc *.cnf birthday.tbl event*.tbl flower.tbl \
+ gengo.tbl hist??.tbl history.tbl holiday.tbl magazin.tbl \
+ monthly.tbl week.tbl; \
+ do \
+ echo $$i ; \
+ sed 's/.$$//' $$i | nkf -e > $$i.tmp ;\
+ mv -f $$i.tmp $$i ; \
+ done)
+
+pre-patch:
+ @echo "===> Installing custom Makefile for ${DISTNAME}"
+ @(cp ${FILESDIR}/Makefile ${WRKSRC})
+
+.include <bsd.port.mk>
diff --git a/japanese/today/distinfo b/japanese/today/distinfo
new file mode 100644
index 000000000000..2f8107846651
--- /dev/null
+++ b/japanese/today/distinfo
@@ -0,0 +1,2 @@
+MD5 (td210bs.lzh) = df892531f83ab81ac1dda7403a7ff6b4
+MD5 (td210bm.lzh) = 6938f108ed938258d519bcc00f760aab
diff --git a/japanese/today/files/Makefile b/japanese/today/files/Makefile
new file mode 100644
index 000000000000..204568dfb2d2
--- /dev/null
+++ b/japanese/today/files/Makefile
@@ -0,0 +1,96 @@
+#
+# Makefile for today
+#
+
+CFLAGS += -DDISTRIBUTE -DMSG_STYLE
+PROGRAM = today
+MANPAGE = today.1
+PREFIX = /usr/local
+MANDIR = ${PREFIX}/man/ja_JP.euc/cat1
+OBJSMV = birthday.o config.o date.o event.o getfile.o getsb.o \
+ history.o kansi.o kyureki.o kyusei.o list.o machine.o \
+ main.o misc.o pager.o rdcalendar.o schedule.o sekki.o sepparam.o
+OBJS = $(OBJSMV) version.o
+OBJS2 = calendar.o config.o getfile.o getsb.o kyureki2.o misc2.o \
+ rdcalendar.o schedule2.o
+
+all: ${PROGRAM} calendar-today dayinfo
+
+install: ${PROGRAM} calendar-today dayinfo
+ ${INSTALL} -c -o bin -s ${PROGRAM} ${PREFIX}/bin
+ ${INSTALL} -c -o bin -s calendar-today ${PREFIX}/bin
+ ${INSTALL} -c -o bin -s dayinfo ${PREFIX}/bin
+ mkdir -p ${MANDIR}
+ cp today.doc ${MANPAGE}
+ ${INSTALL} -c -m 644 ${MANPAGE} ${MANDIR}
+.if !defined(NOMANCOMPRESS)
+ gzip -9nf ${MANDIR}/${MANPAGE}
+.endif
+ mkdir -p ${PREFIX}/lib
+ ${INSTALL} -c -m 644 -o bin today.cnf ${PREFIX}/lib
+ mkdir -p ${PREFIX}/share/today
+ ${INSTALL} -c -m 644 -o bin *.tbl ${PREFIX}/share/today
+
+
+
+today : $(OBJS)
+ $(CC) $(OBJS) -lm -o $@
+
+calendar-today : $(OBJS2)
+ $(CC) $(OBJS2) -lm -o $@
+
+dayinfo : dayinfo.c
+ $(CC) $(CFLAGS) -lm $? -o $@
+
+#inreki : inreki.c inreki.h
+# $(CC) $(CFLAGS) -DSTANDALONE $? -o $@
+#kansi : kansi.c kansi.h
+# $(CC) $(CFLAGS) -DSTANDALONE -DDEBUG $? -o $@
+#kyusei : kyusei.c kyusei.h
+# $(CC) $(CFLAGS) -DSTANDALONE $? -o $@
+
+clean :
+ rm -f *.o core calendar-today dayinfo inreki kansi kyusei today
+
+
+birthday.o : birthday.c common.h main.h birthday.h getfile.h list.h misc.h \
+ pager.h
+calendar.o : calendar.c common.h config.h getfile.h getopt.h getsb.h \
+ kyureki.h misc.h rdcalendar.h schedule.h
+ $(CC) $(CFLAGS) -DINCLUDE_CALENDAR -c -o $@ calendar.c
+
+config.o : config.c common.h config.h getfile.h
+date.o : date.c common.h main.h date.h kansi.h kyusei.h misc.h pager.h \
+ tide_tbl.c
+event.o : event.c common.h main.h event.h getfile.h getsb.h kyureki.h list.h \
+ misc.h pager.h sekki.h sepparam.h
+getfile.o : getfile.c common.h getfile.h
+getopt.o : getopt.c getopt.h
+getsb.o : getsb.c getsb.h sb_tbl.c
+history.o : history.c common.h main.h getfile.h history.h list.h misc.h pager.h
+#inreki.o : inreki.c inreki.h
+kansi.o : kansi.c kansi.h
+kyureki.o : kyureki.c common.h main.h getfile.h kyureki.h misc.h kyutbl.c
+kyureki2.o : kyureki.c common.h main.h getfile.h kyureki.h misc.h kyutbl.c
+ $(CC) $(CFLAGS) -DINCLUDE_CALENDAR -c -o $@ kyureki.c
+
+kyusei.o : kyusei.c kyusei.h
+list.o : list.c list.h
+machine.o : machine.c common.h machine.h main.h
+main.o : main.c common.h main.h birthday.h config.h date.h event.h getfile.h \
+ getopt.h history.h kyureki.h machine.h misc.h pager.h rdcalendar.h \
+ schedule.h version.h
+misc.o : misc.c common.h main.h getfile.h kyureki.h misc.h
+misc2.o : misc.c common.h main.h getfile.h kyureki.h misc.h
+ $(CC) $(CFLAGS) -DINCLUDE_CALENDAR -c -o $@ misc.c
+
+pager.o : pager.c common.h main.h getfile.h misc.h pager.h
+rdcalendar.o : rdcalendar.c common.h rdcalendar.h
+schedule.o : schedule.c common.h main.h getfile.h list.h misc.h pager.h \
+ schedule.h
+schedule2.o : schedule.c common.h main.h getfile.h misc.h schedule.h
+ $(CC) $(CFLAGS) -DINCLUDE_CALENDAR -c -o $@ schedule.c
+
+sekki.o : sekki.c sekki.h
+sepparam.o : sepparam.c sepparam.h
+version.o : version.c version.h $(OBJSMV)
diff --git a/japanese/today/files/patch-aa b/japanese/today/files/patch-aa
new file mode 100644
index 000000000000..a49cf622302e
--- /dev/null
+++ b/japanese/today/files/patch-aa
@@ -0,0 +1,441 @@
+#
+# FreeBSD のためのパッチ
+#
+#
+diff -c old/calendar.c new/calendar.c
+*** old/calendar.c Sun Jun 23 06:16:58 1996
+--- new/calendar.c Sun Jun 23 07:39:54 1996
+***************
+*** 37,43 ****
+ #include "common.h"
+ #include "config.h"
+ #include "getfile.h"
+! #include "getopt.h"
+ #include "getsb.h"
+ #include "kyureki.h"
+ #include "main.h"
+--- 37,45 ----
+ #include "common.h"
+ #include "config.h"
+ #include "getfile.h"
+! #ifndef __FreeBSD__
+! #include "getopt.h"
+! #endif
+ #include "getsb.h"
+ #include "kyureki.h"
+ #include "main.h"
+***************
+*** 960,966 ****
+--- 962,972 ----
+ /*
+ * エラーによるプログラム中断処理
+ */
++ #ifndef __FreeBSD__
+ void terminate_program(int sig, int subcode)
++ #else
++ void terminate_program(int sig)
++ #endif
+ {
+ switch (sig) {
+ case TERM_MEMERROR:
+diff -c old/common.h new/common.h
+*** old/common.h Sun Jun 23 06:17:24 1996
+--- new/common.h Sun Jun 23 06:07:18 1996
+***************
+*** 32,38 ****
+ #define MAXWIDTH 96 /* main.c */
+ #define MAXFNAMEBUF 23 /* misc.c 最大ファイル名 + '\0' */
+ #define MAXPATHNAME 100 /* main.c, pager.c */
+! #define BIG_ENDIAN /* kyureki.c */
+ #define BITFIELD_USE_UNSIGNED_INT /* kyureki.c */
+ #define OPEN_OPT (O_RDONLY | O_BINARY) /* kyureki.c */
+ #define UNDERLINE ((int)'_') /* misc.c */
+--- 32,38 ----
+ #define MAXWIDTH 96 /* main.c */
+ #define MAXFNAMEBUF 23 /* misc.c 最大ファイル名 + '\0' */
+ #define MAXPATHNAME 100 /* main.c, pager.c */
+! #define _BIG_ENDIAN /* kyureki.c */
+ #define BITFIELD_USE_UNSIGNED_INT /* kyureki.c */
+ #define OPEN_OPT (O_RDONLY | O_BINARY) /* kyureki.c */
+ #define UNDERLINE ((int)'_') /* misc.c */
+***************
+*** 69,75 ****
+ #define MAXWIDTH 80 /* main.c */
+ #define MAXFNAMEBUF 13 /* misc.c 最大ファイル名 + '\0' */
+ #define MAXPATHNAME 90 /* main.c, pager.c */
+! #define LITTLE_ENDIAN /* kyureki.c */
+ #if defined(LSI_C)
+ #define BITFIELD_USE_UNSIGNED_INT /* kyureki.c */
+ #endif
+--- 69,75 ----
+ #define MAXWIDTH 80 /* main.c */
+ #define MAXFNAMEBUF 13 /* misc.c 最大ファイル名 + '\0' */
+ #define MAXPATHNAME 90 /* main.c, pager.c */
+! #define _LITTLE_ENDIAN /* kyureki.c */
+ #if defined(LSI_C)
+ #define BITFIELD_USE_UNSIGNED_INT /* kyureki.c */
+ #endif
+***************
+*** 117,123 ****
+ #define MAXWIDTH 80 /* main.c */
+ #define MAXFNAMEBUF 256 /* misc.c 4.3BSD 最大ファイル名 + '\0' */
+ #define MAXPATHNAME 1024 /* main.c, pager.c */
+! #define BIG_ENDIAN /* kyureki.c */
+ #define OPEN_OPT (O_RDONLY) /* kyureki.c */
+ #define UNDERLINE ((int)'_') /* misc.c */
+ #define OUTFILE_DEFAULT "%y%m%d.today" /* pager.c */
+--- 117,123 ----
+ #define MAXWIDTH 80 /* main.c */
+ #define MAXFNAMEBUF 256 /* misc.c 4.3BSD 最大ファイル名 + '\0' */
+ #define MAXPATHNAME 1024 /* main.c, pager.c */
+! #define _LITTLE_ENDIAN /* kyureki.c */
+ #define OPEN_OPT (O_RDONLY) /* kyureki.c */
+ #define UNDERLINE ((int)'_') /* misc.c */
+ #define OUTFILE_DEFAULT "%y%m%d.today" /* pager.c */
+diff -c old/getfile.c new/getfile.c
+*** old/getfile.c Sun Jun 23 06:17:04 1996
+--- new/getfile.c Sun Jun 23 05:57:36 1996
+***************
+*** 11,16 ****
+--- 11,19 ----
+ *
+ */
+
++ #ifdef __FreeBSD__
++ #include <unistd.h>
++ #endif
+ #include "common.h"
+ #include "getfile.h"
+
+diff -c old/kyureki.c new/kyureki.c
+*** old/kyureki.c Sun Jun 23 06:17:09 1996
+--- new/kyureki.c Sun Jun 23 05:57:09 1996
+***************
+*** 11,16 ****
+--- 11,19 ----
+ *
+ */
+
++ #ifdef __FreeBSD__
++ #include <unistd.h>
++ #endif
+ #include "common.h"
+ #include "main.h"
+ #include "getfile.h"
+***************
+*** 32,38 ****
+ * 処理系によっては 4bytes にならない場合がある。
+ * その様な時は、内蔵旧暦テーブルを使用する。
+ */
+! #ifdef BIG_ENDIAN
+ #ifdef BITFIELD_USE_UNSIGNED_INT
+ struct KYUREKI_T {
+ unsigned char year;
+--- 35,41 ----
+ * 処理系によっては 4bytes にならない場合がある。
+ * その様な時は、内蔵旧暦テーブルを使用する。
+ */
+! #ifdef _BIG_ENDIAN
+ #ifdef BITFIELD_USE_UNSIGNED_INT
+ struct KYUREKI_T {
+ unsigned char year;
+***************
+*** 55,61 ****
+ };
+ #endif
+ #endif
+! #ifdef LITTLE_ENDIAN
+ #ifdef BITFIELD_USE_UNSIGNED_INT
+ struct KYUREKI_T {
+ unsigned char year;
+--- 58,64 ----
+ };
+ #endif
+ #endif
+! #ifdef _LITTLE_ENDIAN
+ #ifdef BITFIELD_USE_UNSIGNED_INT
+ struct KYUREKI_T {
+ unsigned char year;
+diff -c old/main.c new/main.c
+*** old/main.c Sun Jun 23 06:17:16 1996
+--- new/main.c Sun Jun 23 06:28:20 1996
+***************
+*** 18,24 ****
+ #include "date.h"
+ #include "event.h"
+ #include "getfile.h"
+! #include "getopt.h"
+ #include "history.h"
+ #include "kyureki.h"
+ #include "machine.h"
+--- 18,26 ----
+ #include "date.h"
+ #include "event.h"
+ #include "getfile.h"
+! #ifndef __FreeBSD__
+! #include "getopt.h"
+! #endif
+ #include "history.h"
+ #include "kyureki.h"
+ #include "machine.h"
+***************
+*** 726,732 ****
+--- 728,738 ----
+ /*
+ * インタラプトやエラーによるプログラム中断処理
+ */
++ #ifndef __FreeBSD__
+ void terminate_program(int sig, int subcode)
++ #else
++ void terminate_program(int sig)
++ #endif
+ {
+ switch (sig) {
+ case SIGINT:
+diff -c old/main.h new/main.h
+*** old/main.h Sun Jun 23 06:17:29 1996
+--- new/main.h Sun Jun 23 06:24:07 1996
+***************
+*** 119,122 ****
+--- 119,126 ----
+ #endif /* #ifndef INCLUDE_CALENDAR */
+
+ extern void errprint(const char *func, int level, const char *fmt, ...);
++ #ifndef __FreeBSD__
+ extern void terminate_program(int sig, int subcode);
++ #else
++ extern void terminate_program(int sig);
++ #endif
+diff -c old/misc.c new/misc.c
+*** old/misc.c Sun Jun 23 06:17:18 1996
+--- new/misc.c Sun Jun 23 06:33:03 1996
+***************
+*** 11,22 ****
+ *
+ */
+
+ #include "common.h"
+ #include "main.h"
+ #include "getfile.h"
+ #include "kyureki.h"
+ #include "misc.h"
+!
+ #ifndef INCLUDE_CALENDAR
+ #define JULIAN 1720994
+ #define MONTH 30.6001
+--- 11,27 ----
+ *
+ */
+
++ #ifdef __FreeBSD__
++ #include <unistd.h>
++ #endif
+ #include "common.h"
+ #include "main.h"
+ #include "getfile.h"
+ #include "kyureki.h"
+ #include "misc.h"
+! #ifdef __FreeBSD__
+! #define strnicmp strncasecmp
+! #endif
+ #ifndef INCLUDE_CALENDAR
+ #define JULIAN 1720994
+ #define MONTH 30.6001
+***************
+*** 1105,1111 ****
+--- 1110,1120 ----
+ sprintf(pbuf, "%06d", getpid() >> 4);
+ pb = pbuf + strlen(pbuf) - 5;
+ #else /* #if defined(MSDOS) || defined(LSI_C) || defined(unix) */
++ #ifndef __FreeBSD__
+ sprintf(pbuf, "%05d", getpid());
++ #else
++ sprintf(pbuf, "%05ld", getpid());
++ #endif
+ pb = pbuf;
+ #endif
+ for (i = 0; i < 5; i++) {
+***************
+*** 1280,1286 ****
+--- 1289,1299 ----
+ buf = malloc(size);
+ if (buf == NULL) {
+ errprint("xmalloc", ERR_PANIC, "virtual memory exhausted, program stop.");
++ #ifndef __FreeBSD__
+ terminate_program(TERM_MEMERROR, 0);
++ #else
++ terminate_program(TERM_MEMERROR);
++ #endif
+ }
+ return (buf);
+ }
+diff -c old/pager.c new/pager.c
+*** old/pager.c Sun Jun 23 06:17:19 1996
+--- new/pager.c Sun Jun 23 05:56:31 1996
+***************
+*** 11,16 ****
+--- 11,19 ----
+ *
+ */
+
++ #ifdef __FreeBSD__
++ #include <unistd.h>
++ #endif
+ #include "common.h"
+ #include "main.h"
+ #include "getfile.h" /* make_accesspath() */
+***************
+*** 34,40 ****
+ static int line_count;
+ static FILE *pager_fp = NULL;
+
+! static void pause(void);
+
+ /*
+ * TODAY 出力ファイルの作成
+--- 37,43 ----
+ static int line_count;
+ static FILE *pager_fp = NULL;
+
+! static void _pause(void);
+
+ /*
+ * TODAY 出力ファイルの作成
+***************
+*** 109,115 ****
+ }
+ if (pager_cmd == NULL) {
+ if (pager_lastpause == YES) {
+! pause();
+ }
+ } else {
+ sprintf(cmdbuf, "%s %s", pager_cmd, pager_file);
+--- 112,118 ----
+ }
+ if (pager_cmd == NULL) {
+ if (pager_lastpause == YES) {
+! _pause();
+ }
+ } else {
+ sprintf(cmdbuf, "%s %s", pager_cmd, pager_file);
+***************
+*** 168,174 ****
+--- 171,181 ----
+ fputs(linebuffer, pager_fp);
+ if (fputc('\n', pager_fp) == EOF) {
+ errprint("pager_output", ERR_ERROR, "ファイル(%s)に出力できません errno = %d", pager_file, errno);
++ #ifndef __FreeBSD__
+ terminate_program(TERM_FILEERROR, 0);
++ #else
++ terminate_program(TERM_FILEERROR);
++ #endif
+ }
+ }
+ if (pager_cmd != NULL) {
+***************
+*** 181,187 ****
+ line_count -= maxline;
+ if (line_count <= 0) {
+ line_count = screen_max_rows;
+! pause();
+ line_count -= maxline;
+ }
+ }
+--- 188,194 ----
+ line_count -= maxline;
+ if (line_count <= 0) {
+ line_count = screen_max_rows;
+! _pause();
+ line_count -= maxline;
+ }
+ }
+***************
+*** 196,202 ****
+ * それに、unix の環境なら外部ページャの方が良いと思う
+ */
+ static
+! void pause(void)
+ {
+ #if defined(human68k) || defined(MSDOS) || defined(LSI_C)
+ cprintf("\033[7m--- more ---\033[0m");
+--- 203,209 ----
+ * それに、unix の環境なら外部ページャの方が良いと思う
+ */
+ static
+! void _pause(void)
+ {
+ #if defined(human68k) || defined(MSDOS) || defined(LSI_C)
+ cprintf("\033[7m--- more ---\033[0m");
+diff -c old/today.cnf new/today.cnf
+*** old/today.cnf Sun Jun 23 09:50:19 1996
+--- new/today.cnf Sun Jun 23 10:27:08 1996
+***************
+*** 214,220 ****
+ #
+ $common # 以降 共通環境定義部
+
+! #table_path = c:/tbl # 各テーブルの検索パス名
+ # ';' で区切り複数指定可能
+ # 未定義の場合、環境変数 TODAYTBL の場所
+
+--- 214,220 ----
+ #
+ $common # 以降 共通環境定義部
+
+! table_path = /usr/local/share/today # 各テーブルの検索パス名
+ # ';' で区切り複数指定可能
+ # 未定義の場合、環境変数 TODAYTBL の場所
+
+diff -c old/version.c new/version.c
+*** old/version.c Sun Jun 23 06:17:23 1996
+--- new/version.c Sun Jun 23 10:37:15 1996
+***************
+*** 28,33 ****
+--- 28,34 ----
+ const char Version[] = "today " __DATE__ " version 2.10B (正式版)";
+ const char RCSid[] ="$Id: version.c,v 1.1 1993/07/25 05:39:46 mori Exp $";
+ const char UseLanguage[] =
++ #if !defined(TRANS)
+ #if defined(human68k)
+ #if defined(__GNUC__)
+ "gcc version 1.00 Tool#1(68020) Based on 1.42";
+***************
+*** 47,53 ****
+ /* by Sun-4/470 SunOS4.1.1+JLE1.1.1 */
+ #endif
+ #endif
+
+ #ifdef TRANS
+! const char Modify[] = "Modified for 機種名/OS名 by 移植者名";
+ #endif
+--- 48,57 ----
+ /* by Sun-4/470 SunOS4.1.1+JLE1.1.1 */
+ #endif
+ #endif
++ #else
++ "gcc version 2.6.3";
++ #endif
+
+ #ifdef TRANS
+! const char Modify[] = "Modified for FreeBSD2.0.5R by pcs51674@asciinet.or.jp";
+ #endif
+diff -c old/version.h new/version.h
+*** old/version.h Sun Jun 23 06:17:33 1996
+--- new/version.h Sun Jun 23 10:08:17 1996
+***************
+*** 11,17 ****
+ *
+ */
+
+! /*#define TRANS*/ /* 他機種へ移植した場合 define する */
+
+ extern const char Copyright[];
+ extern const char Version[];
+--- 11,17 ----
+ *
+ */
+
+! #define TRANS /* 他機種へ移植した場合 define する */
+
+ extern const char Copyright[];
+ extern const char Version[];
diff --git a/japanese/today/pkg-comment b/japanese/today/pkg-comment
new file mode 100644
index 000000000000..4b89663a5cbe
--- /dev/null
+++ b/japanese/today/pkg-comment
@@ -0,0 +1 @@
+Tells you what day today is.
diff --git a/japanese/today/pkg-descr b/japanese/today/pkg-descr
new file mode 100644
index 000000000000..3458b676f30e
--- /dev/null
+++ b/japanese/today/pkg-descr
@@ -0,0 +1,9 @@
+This port "today" tells you what day today is.
+
+ For example
+ Feb. 14 is St. Valentine's Day
+ Dec. 31 is New Year's Eve
+
+Of course, it may not know about all the important dates. Also, it
+will also display your birthday, assuming you registered it. This
+version also has a simple scheduler.
diff --git a/japanese/today/pkg-plist b/japanese/today/pkg-plist
new file mode 100644
index 000000000000..05f624a71656
--- /dev/null
+++ b/japanese/today/pkg-plist
@@ -0,0 +1,38 @@
+bin/today
+bin/calendar-today
+bin/dayinfo
+man/ja_JP.euc/cat1/today.1.gz
+lib/today.cnf
+share/today/birthday.tbl
+share/today/event01.tbl
+share/today/event02.tbl
+share/today/event03.tbl
+share/today/event04.tbl
+share/today/event05.tbl
+share/today/event06.tbl
+share/today/event07.tbl
+share/today/event08.tbl
+share/today/event09.tbl
+share/today/event10.tbl
+share/today/event11.tbl
+share/today/event12.tbl
+share/today/flower.tbl
+share/today/gengo.tbl
+share/today/hist01.tbl
+share/today/hist02.tbl
+share/today/hist03.tbl
+share/today/hist04.tbl
+share/today/hist05.tbl
+share/today/hist06.tbl
+share/today/hist07.tbl
+share/today/hist08.tbl
+share/today/hist09.tbl
+share/today/hist10.tbl
+share/today/hist11.tbl
+share/today/hist12.tbl
+share/today/history.tbl
+share/today/holiday.tbl
+share/today/kyureki.tbl
+share/today/magazin.tbl
+share/today/monthly.tbl
+share/today/week.tbl